Sonoff Zigbee Dongle. Limit an Geräten erreicht

Hallo.
Ich habe mir auf die Empfehlung von Simon42, den Dongle:
SONOFF Zigbee Gateway, ZBDongle-E USB Zigbee 3.0 USB Dongle Plus,EFR32MG21 + CH9102F Zigbee USB-Stick EFR32MG21 Coordinator für ZHA
gekauft.
Ich bin auch super zufrieden damit, habe jetzt nur das Problem, dass ich 50 Geräte ins Netzwerk eingepflegt habe und somit das Maximum an Geräten erreicht.
Da ich aber noch ein paar Geräte hinzufügen möchte, habe ich da mal so bis zwei Fragen.
Kann ich einen zweiten Dongle, auf einem anderen Kanal in HA betreiben?
Oder gibt es eine andere Möglichkeit, die Anzahl der Geräte zu erweitern?

Ich bin für jedenTipp oder Rat dankbar.

Marcus

:crayon:by HarryP: übermäßigen Fettdruck korrigiert

Hast du einfach mal probiert mehr anzulernen? Nur weil Hue nur 50 Geräte pro Bridge kann gilt das Limit nicht für alle andern Zigbee Netze.

Wenn du nicht nur Sensoren sondern auch Router (Steckdosen, Lampen etc…) im Netz hast sollte mehr möglich sein.

Ich habe den Dongle-P (CC2652P) der kann 50 Geräte direkt ansprechen und über Router 200 Zigbee 3.0 Geräte betreiben. (ältere Zigbee Geräte (vor version 3.0) glaube ich sogar noch mehr bin mir aber nicht sicher).

Ich denke das der Dongle-E ähnliche Limits hat und ohne Router auch nur 50 Geräte kann und mit deutlich mehr.

LG
Tobi

1 „Gefällt mir“

Ich habe aktuell 58 Zigbee Geräte an meinem SONOFF-E Stick - davon sind gut ein Dutzend Steckdosen und zwei Dutzend Lampen! Wenn also genug Router im Zigbee-Netz vorhanden ist das überhaupt kein Problem!

Ich bin bereits bei 105.

1 „Gefällt mir“

Ich habe versucht, mehr Geräte hinzu zufügen und ich habe auch mehrere Philips Hue Lampen und Osram Steckdosen drin aber ich kriege trotzdem nicht mehr Geräte rein.
Habe auch versucht über ein anderes Gerät ein neues hinzu zufügen aber es gehen nicht mehr rein.

Ich bin bei dem P-Dongle noch unter 50 Geräten, aber ich kann mir eine solche Beschränkung auch nicht vorstellen.

@erzgabriel was kommt beim Einbinden denn für eine Meldung oder Fehler? Was sagt das Protokoll dazu? Bei dir ist aber nicht einfach nur der Speicher voll?

Es kommt gar nichts. Kein Gerät gefunden. Speicher voll, kann nicht sein, das System läuft auf einer 250GB SSD und laut System, sind 7,6GB belegt. RPi 4 mit 8GB RAM, belegter Arbeitsspeicher, schwankt immer um die 800MG, plus minus 50MB.
Das System hat also noch genug Ressourcen frei.

okay, war auch nur eine Vermutung mit dem Speicher. Hast du mal nen Link zum Dongle, also zum Shop wo du den gekauft hast? Findest du denn in den Protokollen (Einstellungen/System/Protokolle) in den versuchten Zeitraum Einträge? (Uhrzeit merken)

Den Stick hatte ich bei Amazon bestellt, weil es am schnellst ging.
https://www.amazon.de/dp/B0B6P22YJC?ref=ppx_yo2ov_dt_b_product_details&th=1
Habe jetzt nochmal im Log und den Protokollen geschaut, habe auch nochmal einen Versuch gemacht, ein weiteres Gerät einzubinden. Keine Einträge zu finden.

Ach du hast den ZBDongle-E, ist mir vorher untergegangen, ob es damit eine Beschränkung gibt, kann ich leider nicht sagen. Vielleicht findet sich noch jemand der sich mit dem Stick auskennt…

Hi,
ich hab‘ zwar die P- Variante und bei weitem keine 50 Geräte … aber hast mal geschaut, welche Firmware auf dem Stick ist ? (Vielleicht gibts ja schon was neueres)

Auf der Sonoff Seite zum Dongle-E steht:

Wide Range of Supported Devices

Dongle Plus can be used as a Zigbee 3.0 gateway in open-source automation platforms to manage various sub-devices from various brands. The supported devices depend on the platforms.

  • Max direct children: 32.

Max children: no limit on firmware, depends on platforms

Edit:
und da ZHA kein Limit hat müsste eigentlich mehr gehen

Habe ich nicht, weil ich den Stick erst vor zwei Wochen eingerichtet habe und da auch sofort ein Firmeware Update gemacht habe.

Sonst muss ich mir halt die P Version holen aber wäre mies, weil dann muss ich ja alle Geräte neu pairen.

Nachtrag:
Ich glaube, ich habe das Problem gefunden.
In den Protokollen tauchte heute ein Device auf, den ich gar nciht mehr eingepflegt habe aber er scheint noch im System rum zu spucken und dadurch alles zu blockieren.

Logger: homeassistant.components.light.reproduce_state
Source: components/light/reproduce_state.py:118
Integration: Licht (documentation, issues)
First occurred: 22. November 2023 um 17:59:26 (3 occurrences)
Last logged: 04:57:14

Unable to find entity light.bett_licht

Das besagte Licht habe ich aber wieder aus dem System entfernt und ist seitdem auch nciht mehr am Strom angeschlossen. Ich habe auch gerade alles durchgeschaut, ob es noch irgendwo steht aber ist nirgends mehr zu finden.

:crayon:by HarryP: Zusammenführung Doppelpost

Etwas offTopic aber gibt zur Zeit bei Lidl (SILVERCREST® Steckdosen Zwischenstecker »Zigbee Smart …) Steckdosen mit Energiemessung. Ideal als Router, um das ZigbeeNetz zu erweitern und mit knapp 8,-Euro spott billig.

1 „Gefällt mir“

Ich habe es gelöst. Nachdem ich mein System komplett neu aufgesetzt habe, kann ich mehr wie 50 Geräte hinzufügen.
Ich bedanke mich für alle Tipps und Ratschläge.