Zigbee2MQTT: Geräte hinzufügen nicht möglich

Hallo zusammen,

ich bin was Home Assistant und Zigbee angeht noch sehr neu, habt bitte Rücksicht für meine Unwissenheit :slight_smile:

Seit einer Weile versuche ich nun schon Geräte mittels Zigbee2MQTT auf meinem Raspberry und dem Sonoff Dongle-P einzubinden. Speziell geht es dabei um den Fensterkontakt von Ikea (Parasoll). Doch beim Versuch des anlernens wird das Gerät einfach nicht gefunden.

Zur Einrichtung von Z2M habe ich das Video von Simon genutzt und ich weiß nicht mehr weiter…

[14:48:02] INFO: Preparing to start...
[14:48:03] INFO: Socat not enabled
[14:48:05] INFO: Starting Zigbee2MQTT...
Zigbee2MQTT:info  2024-01-17 14:48:11: Logging to console and directory: '/config/zigbee2mqtt/log/2024-01-17.14-48-11' filename: log.txt
Zigbee2MQTT:info  2024-01-17 14:48:11: Starting Zigbee2MQTT version 1.35.1 (commit #unknown)
Zigbee2MQTT:info  2024-01-17 14:48:11: Starting zigbee-herdsman (0.30.0)
Zigbee2MQTT:info  2024-01-17 14:48:12: zigbee-herdsman started (resumed)
Zigbee2MQTT:info  2024-01-17 14:48:12: Coordinator firmware version: '{"meta":{"maintrel":1,"majorrel":2,"minorrel":7,"product":1,"revision":20210708,"transportrev":2},"type":"zStack3x0"}'
Zigbee2MQTT:info  2024-01-17 14:48:12: Currently 0 devices are joined:
Zigbee2MQTT:info  2024-01-17 14:48:12: Zigbee: disabling joining new devices.
Zigbee2MQTT:info  2024-01-17 14:48:12: Connecting to MQTT server at mqtt://core-mosquitto:1883
Zigbee2MQTT:info  2024-01-17 14:48:12: Connected to MQTT server
Zigbee2MQTT:info  2024-01-17 14:48:12: MQTT publish: topic 'zigbee2mqtt/bridge/state', payload '{"state":"online"}'
Zigbee2MQTT:info  2024-01-17 14:48:13: Started frontend on port 8099
Zigbee2MQTT:info  2024-01-17 14:48:13: MQTT publish: topic 'homeassistant/binary_sensor/1221051039810110150109113116116_0x00124b002a4560e1/connection_state/config', payload '{"device":{"hw_version":"zStack3x0 20210708","identifiers":["zigbee2mqtt_bridge_0x00124b002a4560e1"],"manufacturer":"Zigbee2MQTT","model":"Bridge","name":"Zigbee2MQTT Bridge","sw_version":"1.35.1"},"device_class":"connectivity","entity_category":"diagnostic","name":"Connection state","object_id":"zigbee2mqtt_bridge_connection_state","origin":{"name":"Zigbee2MQTT","sw":"1.35.1","url":"https://www.zigbee2mqtt.io"},"payload_off":"offline","payload_on":"online","state_topic":"zigbee2mqtt/bridge/state","unique_id":"bridge_0x00124b002a4560e1_connection_state_zigbee2mqtt","value_template":"{{ value_json.state }}"}'
Zigbee2MQTT:info  2024-01-17 14:48:13: MQTT publish: topic 'homeassistant/binary_sensor/1221051039810110150109113116116_0x00124b002a4560e1/restart_required/config', payload '{"availability":[{"topic":"zigbee2mqtt/bridge/state","value_template":"{{ value_json.state }}"}],"availability_mode":"all","device":{"hw_version":"zStack3x0 20210708","identifiers":["zigbee2mqtt_bridge_0x00124b002a4560e1"],"manufacturer":"Zigbee2MQTT","model":"Bridge","name":"Zigbee2MQTT Bridge","sw_version":"1.35.1"},"device_class":"problem","enabled_by_default":false,"entity_category":"diagnostic","name":"Restart required","object_id":"zigbee2mqtt_bridge_restart_required","origin":{"name":"Zigbee2MQTT","sw":"1.35.1","url":"https://www.zigbee2mqtt.io"},"payload_off":false,"payload_on":true,"state_topic":"zigbee2mqtt/bridge/info","unique_id":"bridge_0x00124b002a4560e1_restart_required_zigbee2mqtt","value_template":"{{ value_json.restart_required }}"}'
Zigbee2MQTT:info  2024-01-17 14:48:13: MQTT publish: topic 'homeassistant/button/1221051039810110150109113116116_0x00124b002a4560e1/restart/config', payload '{"availability":[{"topic":"zigbee2mqtt/bridge/state","value_template":"{{ value_json.state }}"}],"availability_mode":"all","command_topic":"zigbee2mqtt/bridge/request/restart","device":{"hw_version":"zStack3x0 20210708","identifiers":["zigbee2mqtt_bridge_0x00124b002a4560e1"],"manufacturer":"Zigbee2MQTT","model":"Bridge","name":"Zigbee2MQTT Bridge","sw_version":"1.35.1"},"device_class":"restart","name":"Restart","object_id":"zigbee2mqtt_bridge_restart","origin":{"name":"Zigbee2MQTT","sw":"1.35.1","url":"https://www.zigbee2mqtt.io"},"payload_press":"","unique_id":"bridge_0x00124b002a4560e1_restart_zigbee2mqtt"}'
Zigbee2MQTT:info  2024-01-17 14:48:13: MQTT publish: topic 'homeassistant/select/1221051039810110150109113116116_0x00124b002a4560e1/log_level/config', payload '{"availability":[{"topic":"zigbee2mqtt/bridge/state","value_template":"{{ value_json.state }}"}],"availability_mode":"all","command_template":"{\"options\": {\"advanced\": {\"log_level\": \"{{ value }}\" } } }","command_topic":"zigbee2mqtt/bridge/request/options","device":{"hw_version":"zStack3x0 20210708","identifiers":["zigbee2mqtt_bridge_0x00124b002a4560e1"],"manufacturer":"Zigbee2MQTT","model":"Bridge","name":"Zigbee2MQTT Bridge","sw_version":"1.35.1"},"entity_category":"config","name":"Log level","object_id":"zigbee2mqtt_bridge_log_level","options":["info","warn","error","debug"],"origin":{"name":"Zigbee2MQTT","sw":"1.35.1","url":"https://www.zigbee2mqtt.io"},"state_topic":"zigbee2mqtt/bridge/info","unique_id":"bridge_0x00124b002a4560e1_log_level_zigbee2mqtt","value_template":"{{ value_json.log_level | lower }}"}'
Zigbee2MQTT:info  2024-01-17 14:48:13: MQTT publish: topic 'homeassistant/sensor/1221051039810110150109113116116_0x00124b002a4560e1/version/config', payload '{"availability":[{"topic":"zigbee2mqtt/bridge/state","value_template":"{{ value_json.state }}"}],"availability_mode":"all","device":{"hw_version":"zStack3x0 20210708","identifiers":["zigbee2mqtt_bridge_0x00124b002a4560e1"],"manufacturer":"Zigbee2MQTT","model":"Bridge","name":"Zigbee2MQTT Bridge","sw_version":"1.35.1"},"entity_category":"diagnostic","icon":"mdi:zigbee","name":"Version","object_id":"zigbee2mqtt_bridge_version","origin":{"name":"Zigbee2MQTT","sw":"1.35.1","url":"https://www.zigbee2mqtt.io"},"state_topic":"zigbee2mqtt/bridge/info","unique_id":"bridge_0x00124b002a4560e1_version_zigbee2mqtt","value_template":"{{ value_json.version }}"}'
Zigbee2MQTT:info  2024-01-17 14:48:13: MQTT publish: topic 'homeassistant/sensor/1221051039810110150109113116116_0x00124b002a4560e1/coordinator_version/config', payload '{"availability":[{"topic":"zigbee2mqtt/bridge/state","value_template":"{{ value_json.state }}"}],"availability_mode":"all","device":{"hw_version":"zStack3x0 20210708","identifiers":["zigbee2mqtt_bridge_0x00124b002a4560e1"],"manufacturer":"Zigbee2MQTT","model":"Bridge","name":"Zigbee2MQTT Bridge","sw_version":"1.35.1"},"enabled_by_default":false,"entity_category":"diagnostic","icon":"mdi:chip","name":"Coordinator version","object_id":"zigbee2mqtt_bridge_coordinator_version","origin":{"name":"Zigbee2MQTT","sw":"1.35.1","url":"https://www.zigbee2mqtt.io"},"state_topic":"zigbee2mqtt/bridge/info","unique_id":"bridge_0x00124b002a4560e1_coordinator_version_zigbee2mqtt","value_template":"{{ value_json.coordinator.meta.revision }}"}'
Zigbee2MQTT:info  2024-01-17 14:48:13: MQTT publish: topic 'homeassistant/sensor/1221051039810110150109113116116_0x00124b002a4560e1/network_map/config', payload '{"availability":[{"topic":"zigbee2mqtt/bridge/state","value_template":"{{ value_json.state }}"}],"availability_mode":"all","device":{"hw_version":"zStack3x0 20210708","identifiers":["zigbee2mqtt_bridge_0x00124b002a4560e1"],"manufacturer":"Zigbee2MQTT","model":"Bridge","name":"Zigbee2MQTT Bridge","sw_version":"1.35.1"},"enabled_by_default":false,"entity_category":"diagnostic","json_attributes_template":"{{ value_json.data.value | tojson }}","json_attributes_topic":"zigbee2mqtt/bridge/response/networkmap","name":"Network map","object_id":"zigbee2mqtt_bridge_network_map","origin":{"name":"Zigbee2MQTT","sw":"1.35.1","url":"https://www.zigbee2mqtt.io"},"state_topic":"zigbee2mqtt/bridge/response/networkmap","unique_id":"bridge_0x00124b002a4560e1_network_map_zigbee2mqtt","value_template":"{{ now().strftime('%Y-%m-%d %H:%M:%S') }}"}'
Zigbee2MQTT:info  2024-01-17 14:48:13: MQTT publish: topic 'homeassistant/sensor/1221051039810110150109113116116_0x00124b002a4560e1/permit_join_timeout/config', payload '{"availability":[{"topic":"zigbee2mqtt/bridge/state","value_template":"{{ value_json.state }}"}],"availability_mode":"all","device":{"hw_version":"zStack3x0 20210708","identifiers":["zigbee2mqtt_bridge_0x00124b002a4560e1"],"manufacturer":"Zigbee2MQTT","model":"Bridge","name":"Zigbee2MQTT Bridge","sw_version":"1.35.1"},"device_class":"duration","entity_category":"diagnostic","name":"Permit join timeout","object_id":"zigbee2mqtt_bridge_permit_join_timeout","origin":{"name":"Zigbee2MQTT","sw":"1.35.1","url":"https://www.zigbee2mqtt.io"},"state_topic":"zigbee2mqtt/bridge/info","unique_id":"bridge_0x00124b002a4560e1_permit_join_timeout_zigbee2mqtt","unit_of_measurement":"s","value_template":"{{ iif(value_json.permit_join_timeout is defined, value_json.permit_join_timeout, None) }}"}'
Zigbee2MQTT:info  2024-01-17 14:48:13: MQTT publish: topic 'homeassistant/switch/1221051039810110150109113116116_0x00124b002a4560e1/permit_join/config', payload '{"availability":[{"topic":"zigbee2mqtt/bridge/state","value_template":"{{ value_json.state }}"}],"availability_mode":"all","command_topic":"zigbee2mqtt/bridge/request/permit_join","device":{"hw_version":"zStack3x0 20210708","identifiers":["zigbee2mqtt_bridge_0x00124b002a4560e1"],"manufacturer":"Zigbee2MQTT","model":"Bridge","name":"Zigbee2MQTT Bridge","sw_version":"1.35.1"},"icon":"mdi:human-greeting-proximity","name":"Permit join","object_id":"zigbee2mqtt_bridge_permit_join","origin":{"name":"Zigbee2MQTT","sw":"1.35.1","url":"https://www.zigbee2mqtt.io"},"payload_off":"false","payload_on":"true","state_topic":"zigbee2mqtt/bridge/info","unique_id":"bridge_0x00124b002a4560e1_permit_join_zigbee2mqtt","value_template":"{{ value_json.permit_join | lower }}"}'
Zigbee2MQTT:info  2024-01-17 14:48:13: MQTT publish: topic 'zigbee2mqtt/bridge/state', payload '{"state":"online"}'
Zigbee2MQTT:info  2024-01-17 14:48:13: Zigbee2MQTT started!
Zigbee2MQTT:info  2024-01-17 14:48:44: Zigbee: allowing new devices to join.
Zigbee2MQTT:info  2024-01-17 14:48:44: MQTT publish: topic 'zigbee2mqtt/bridge/response/permit_join', payload '{"data":{"time":254,"value":true},"status":"ok","transaction":"iwta4-1"}'
Zigbee2MQTT:info  2024-01-17 15:09:07: Zigbee: allowing new devices to join.
Zigbee2MQTT:info  2024-01-17 15:09:07: MQTT publish: topic 'zigbee2mqtt/bridge/response/permit_join', payload '{"data":{"time":254,"value":true},"status":"ok","transaction":"0ih39-1"}'

services-up: info: copying legacy longrun mosquitto (no readiness notification)
services-up: info: copying legacy longrun nginx (no readiness notification)
[14:12:19] INFO: Starting NGINX for authentication handling...
s6-rc: info: service legacy-services successfully started
[14:12:19] INFO: Starting mosquitto MQTT broker...
2024-01-17 14:12:19: Warning: Mosquitto should not be run as root/administrator.
2024-01-17 14:12:19: mosquitto version 2.0.18 starting
2024-01-17 14:12:19: Config loaded from /etc/mosquitto/mosquitto.conf.
2024-01-17 14:12:19: Loading plugin: /usr/share/mosquitto/go-auth.so
2024-01-17 14:12:19:  ├── Username/password checking enabled.
2024-01-17 14:12:19:  ├── TLS-PSK checking enabled.
2024-01-17 14:12:19:  └── Extended authentication not enabled.
2024-01-17 14:12:19: Opening ipv4 listen socket on port 1883.
2024-01-17 14:12:19: Opening ipv6 listen socket on port 1883.
2024-01-17 14:12:19: Opening websockets listen socket on port 1884.
2024-01-17 14:12:19: mosquitto version 2.0.18 running
2024-01-17 14:12:19: New connection from 127.0.0.1:42646 on port 1883.
2024-01-17 14:12:19: Client <unknown> disconnected due to protocol error.
[14:12:21] INFO: Successfully send discovery information to Home Assistant.
[14:12:21] INFO: Successfully send service information to the Supervisor.
2024-01-17 14:12:25: New connection from 172.30.32.1:47429 on port 1883.
2024-01-17 14:12:25: New client connected from 172.30.32.1:47429 as 4xBn7lzflQk5v09o45CuXo (p2, c1, k60, u'homeassistant').
2024-01-17 14:12:49: New connection from 172.30.32.2:34736 on port 1883.
2024-01-17 14:12:49: Client <unknown> closed its connection.
2024-01-17 14:13:26: New connection from 172.30.33.3:56244 on port 1883.
2024-01-17 14:13:26: New client connected from 172.30.33.3:56244 as mqttjs_1fa3697e (p2, c1, k60, u'addons').
2024-01-17 14:14:49: New connection from 172.30.32.2:38298 on port 1883.
2024-01-17 14:14:49: Client <unknown> closed its connection.
2024-01-17 14:16:49: New connection from 172.30.32.2:41910 on port 1883.
2024-01-17 14:16:49: Client <unknown> closed its connection.
2024-01-17 14:18:49: New connection from 172.30.32.2:60166 on port 1883.
2024-01-17 14:18:49: Client <unknown> closed its connection.
2024-01-17 14:20:49: New connection from 172.30.32.2:58322 on port 1883.
2024-01-17 14:20:49: Client <unknown> closed its connection.
2024-01-17 14:22:49: New connection from 172.30.32.2:34792 on port 1883.
2024-01-17 14:22:49: Client <unknown> closed its connection.
2024-01-17 14:24:49: New connection from 172.30.32.2:51454 on port 1883.
2024-01-17 14:24:49: Client <unknown> closed its connection.
2024-01-17 14:26:49: New connection from 172.30.32.2:44504 on port 1883.
2024-01-17 14:26:49: Client <unknown> closed its connection.
2024-01-17 14:27:04: Client mqttjs_1fa3697e disconnected.
2024-01-17 14:28:22: New connection from 172.30.33.3:35918 on port 1883.
2024-01-17 14:28:22: New client connected from 172.30.33.3:35918 as mqttjs_dcb6cd92 (p2, c1, k60, u'addons').

Ich hoffe, ihr könnt mit weiterhelfen.

Hi und willkommen im Forum,

wie sieht denn die Benutzeroberfläche von Zigbee2MQTT aus? Auf welchem Zigbee-Kanal läuft der Dongle? Hast du die MQTT-Integration finden können und eingebunden? Hast du den Dongle auch mal mit einem Verlängerungskabel getestet?

Hallo,

die Benutzeroberfläche sieht wie folgt aus:

Der Dongle läuft auf dem Kanal 11.
Mit Verlängerungskabel habe ich noch nicht testen können. Das kommt hoffentlich morgen. Aber würde das tatsächlich schon so viel ausmachen können?

Das der Dongle gar nichts findet, ist auch ohne Verlängerung ungewöhnlich, ich kenne mich nur mit Raspis nicht aus. Hattest du den Stick vorher schon mal in Verwendung? Hast du wie Simon beschrieben die Konfig von Z2M und die Datei “/zigbee2mqtt/configuration.yaml” angepasst und die “/zigbee2mqtt/coordinator_backup.json” gelöscht? (Das ist nur nötig, wenn du vorhandene Geräte migrieren willst, so weit ich weiß)

Herzlich willkommen im Forum.

Du schreibst von mehreren Geräten. Hat es denn mit anderen Geräten schon geklappt?

Auf jeden Fall immer sinnvoll ist, den Stick mindestens einen halben Meter vom USB-Port weg zu platzieren. Leg außerdem den WLAN-Kanal des Routers mal fest auf 11. Hat des Öfteren schon Wunder bewirkt.

Der Stick ist komplett neu.

Ich habe mich komplett nach diesem Video gerichtet: https://www.youtube.com/watch?v=PR-ugz1uLWc

Von Konfig bearbeiten habe ich da nichts mitbekommen :confused:

Das war mit den mehreren Geräten war von mir etwas unglücklich ausgedrückt. Ich meinte damit mehrere von diesen Ikea-Fensterkontakten. Sollten aber mit Z2M kompatibel sein. Ich werde aber morgen mal ein anderes Zigbee-Gerät ausprobieren.

Den WLAN-Kanal habe ich auf 11 festgelegt, brachte allerdings keinen Erfolg.

Meint Ihr WLAN oder Zigbee Kanal?

@kakaoistgesund92 Hast du mal einen anderen Kanal versucht? 15 läuft bei mir gut, nur mit den Ikea-Teilen habe ich keine Erfahrung.

Neu gestartet hast du HA und die Hardware bereits?

Kannst auch mal versuchen den Mosquitto broker und Zigbee2MQTT zu löschen und neu zu installieren.

Mosquitto und Zigbee2MQTT habe ich mehrmals de- und neuinstalliert, sowie alles dutzende Male neugestartet.

Habe bei Zigbee2MQTT jetzt mal den Kanal auf die 15 geändert. Jetzt wird mir folgende Fehlermeldung ausgespuckt:

Beende das Add-on von Z2M, geh in die Konfiguration, Wechsel auf “Als Yaml bearbeiten” und füg mal unter den Port den Kanal ein:

port: /dev/ttyUSB0
advanced:
  channel: 15

BTW: Die Kurzform vom Port sollte auch klappen (Port prüfen).
Jetzt Mosquitto broker neustarten, Add-On Zigbee2MQTT starten und versuchen die Benutzeroberflläche aufzurufen.

Klappt das nicht, beende mal beide Add-Ons, öffne den File Editor, navigiere zum Unterordner zigbee2mqtt und öffne die Datei configuration.yaml - steht da ziemlich am Anfang der Kanal 15 im Abschnitt advanced?
z.B.:

advanced:
  channel: 15

Steht da Kanal 11 dann ändern. Datei speichern und dann die coordinator_backup.json im gleichen Ordner öffnen. Such nach channel, du solltest 2 Suchergebnisse wie folgt finden:

  "channel": 15,
  "channel_mask": [
    15
  ],

Steht da jeweils etwas anderes als 15, ändern, abspeichern und Editor verlassen. Jetzt im Add-On Zigbee2MQTT den Abschnitt

advanced:
  channel: 15

löschen (Konfiguration/YAML), Speichern und beide Add-Ons wieder starten. Wenn alles klappt, sollte wenigstens die Benutzeroberfläche starten, im besten Fall Geräte gefunden werden.

Jetzt komme ich zumindest wieder auf die Benutzeroberfläche. Allerdings werden nach wie vor keine Geräte gefunden… :frowning:

Schau mal unter Geräte&Dienste ob die MQTT Integration eingerichtet ist:
2024-01-20 00_15_21-Einstellungen – Home Assistant – Mozilla Firefox
Falls nicht, auf Einrichten oder Konfigurieren klicken.

Schau auch mal ob die Integration von ZHA aktiv ist
2024-01-19 23_58_32-Einstellungen – Home Assistant – Mozilla Firefox

Wenn ja, dann deaktivieren, System neu starten und nochmal versuchen.

Wenn nein oder sich nichts ändert, kontrolliere in der Z2M-Benutzeroberfläche unter Einstellungen → Rohdaten welcher Kanal hinterlegt ist, am besten mit STRG+F nach channel suchen, es müssten 2 Stellen vorhanden sein.

Dann öffne mit dem File Editor die /zigbee2mqtt/configuration.yaml und schau ob da ab Zeile 3 die Daten nach dem Schema existieren:

advanced:
  network_key:
  ...
  pan_id: ......
  ext_pan_id:
  ...
  channel: 15

Die Einträge sollten m.E. in der Reihenfolge (network_key, pan_id, ext_pan_id und channel) enthalten sein, natürlich mit Daten. Fehlen die Einträge oder die Daten, müssen wir mal schauen wie du die finden kannst.

MQTT habe ich konfiguriert. ZHA ist auch nicht aktiviert. Habe da auf ignorieren geklickt uns seitdem wird es mir auch nicht mehr vorgeschlagen.

Ich habe gerade mal geschaut.
In den Rohdaten stehen zwei Einträge mit Channel 15. Einmal steht allerdings als “default” der Kanal 11:


Ich gehe aber davon aus, dass dies hier keinen Einfluss hat.

In der config sind die von dir genannten Einträge mit Daten vorhanden:

Kurzes Update: nachdem ich zum wiederholten mal den USB-Port am Raspi gewechselt und HA neugestartet habe, funktioniert es nun plötzlich. Ich konnte das Gerät finden und einbinden.

Es kann so einfach sein :smile:

1 „Gefällt mir“

Stopp mal das Add-On von Z2M, dann füg unter Zeile 29 noch

  channel: 15

ein, die 2 Leerzeichen davor nicht vergessen und kleinschreiben. Add-On wieder neu starten, ggf. das System.

Der default-Eintrag in den Rohdaten hab ich auch, lass den erstmal liegen.

Oh cool, hauptsache es funktioniert jetzt! :smiley:

Ich lasse jetzt erstmal die Finger von der Config, richte nach und nach die Geräte ein und schaue wie es sich entwickelt. Vielleicht läuft es jetzt vernünftig.

Vielen Dank für deine Hilfe :slight_smile:

1 „Gefällt mir“

Besser ist das, wenn es so läuft Finger weg von der Konfig :smiley: