Paperless Dokumente

ich brauche bitte mal eure Hilfe. Ich habe paperless installiert auf meiner Synology über den Container Manager. Das funktioniert auch alles gut.
In paperless habe ich noch ein E-mail Konto und E-mail Regeln erstellt.
Danach habe ich mehrere Test-E-Mails gesendet mit PDF Rechnungen.
Irgendwann müsste doch dann im Reiter Dokumente die Rechnungen auftauchen?
Jemand eine Idee, wo der Fehler liegt?

Kann sich Paperless mit dem E-Mail Konto verbinden? In den Einstellungen zu dem Konto kannst Du die Verbindung testen.

Wie sieht deine E-Mail Regel im Detail aus?

Schau mal unter Dateiaufgaben - Reiter “Abgeschlossen”, ob da überhaupt etwas verarbeitet wurde.
Wenn ja, neue Dokumente bekommen zunächst den Tag “Posteingang” in der Standardeinstellung. Hast Du den vielleicht in der Dokumente - Ansicht draußen?

da steht nichts.

das war das erste, was ich überprüft habe. Ja, kann sich verbinden

hier sind die Regeln, die ich eingestellt habe.

:crayon:by HarryP: Zusammenführung Doppelpost (bei Änderungen oder hinzufügen von Inhalten bitte die „Bearbeitungsfunktion“ anstatt „Antworten“ zu nutzen)

du hast warscheinlich noch keinen “inbox” Tag erstellt.

Die Mails mit den Rechnungen sind im Posteingang auch als ungelesen markiert?

OK, das habe ich jetzt mal so gemacht. Davon stand aber nichts in den ganzen YouTube Videos die ich mir angeschaut habe.

ja, ich habe die Testmails extra nicht geöffnet.

ich habe mal den Ordner E-Mail geöffnet. Da werden die E-Mails verarbeitet.
Dort steht ganz rechts der Status.
Ist hier vielleicht ein Fehler so sehen?

vielleicht liegt hier der Fehler?
WebSocket Verbindung.

:crayon:by HarryP: Zusammenführung Mehrfachpost (bei Änderungen oder hinzufügen von Inhalten bitte die „Bearbeitungsfunktion“ anstatt „Antworten“ zu nutzen)

Grundsätzlich sieht die Config gut aus. Den Websocketfehler sollte man sich mal angucken, passt aber nicht zum Fehlerbild als Ursache.

Ich würde mal den Empfängerfilter rausnehmen. Ich nutze den nicht, aber ich kann mir vorstellen, dass der exakt matcht und dann ist „Karl Example <karl@example.org>“ != „karl@example.org“

Ansonsten hast du unter Protokolle ein Mail.log, da ist er eigentlich recht mitteilungsfreudig weshalb er Nachrichten skippt.

Noch ein kleiner usability-Tipp: ich finde die Identifizierung über gelesen als sehr unzuverlässig, weil das in einem Wettrennen endet, ob ich oder paperless die Mail zuerst findet. Ich würde deshalb über Tags gehen:

Im Beispiel macht dir Paperless einen Tag „paperless-done“ an verarbeitete Mails, sie sind aber weiter ungelesen im Posteingang

vielen Dank für deine Tipps. Der Fehler im Websockel konnte ich mittlerweile lösen.
Den Empfängerfilter habe ich jetzt rausgenommen.
Ich habe mir gerade wieder eine E-Mail gesendet mit einer PDF im Anhang.
Sie ist ungeöffnet. Müsste ja irgendwann im Ordner Dokumente auftauchen. Tut es aber nicht!
Dann bin ich auf E-Mail-Regeln und habe dort mal auf den Punkt verarbeitete Mail anzeigen gedrückt. Dort finde ich alle Mails.
Zusehen auf dem Bild.
Dann habe ich mal, wie du es geschrieben hast, den Mail.log geöffnet. Kann man hier vielleicht was lesen, was den Fehler verursacht? So tief bin ich dann doch nicht im Thema drin.

Moin,

nein, musst Du auch nicht!
Mit INBOX ist ja das Verzeichnis Deines Mail Accounts gemeint.

Wenn ich das bei mir anschaue, dann sind die Mails, die verarbeitet wurden unter Status mit einem Haken versehen

Da Du keine alten Mails verarbeitest, werden diese auch alle geskippt


Das mache ich auch anders

VG
Bernd

Ich habe habe den Dateianhangtyp noch auf “Alle Anhänge verarbeiten, auch Anhänge im Textkörper” gesetzt.

bedeutet ja, dass meine Mails nicht bearbeitet werden. Die Frage ist warum?

den Status mit den grünen Hacken im Status habe ich nicht. Also, hier wird der Fehler bei mir sein.

:crayon:by HarryP: Zusammenführung Doppelpost (bei Änderungen oder hinzufügen von Inhalten bitte die „Bearbeitungsfunktion“ anstatt „Antworten“ zu nutzen)

kannst du mir sagen, was damit gemeint ist? Was bedeutet keine alten Mails verarbeitest, werden diese auch alle geskippt.

so, ich glaube es läuft jetzt. Vielen Dank für eure Hilfe.

Super. Kannst du bitte noch kurz schreiben was deine Lösung war, wenn in 6 Monaten jemand mit dem selben Problem den Post hier findet.

ich habe jetzt alles geändert, was heute so geschrieben wurde.
Ich habe die Regel geändert, so wie es dp20eic geschrieben hat. Die Tags eingefügt und den Absenderfilter gelöscht.

Moin,

als ich damals die E-Mail Regel hinzugefügt habe, wollte ich, dass mindestens das letzte Jahr alle Telefonrechnungen im E-Mail-Account erfasst werden, deswegen steht bei mir dort 365 Tage drin.

Wenn da 1 steht, dann wird alles, was älter als ein Tag ist ignoriert, auch wenn die Mail nicht als gelesen markiert ist.
Bei mir wurde ja eine E-Mail mit Fehler angezeigt, ich musste also diese E-Mail einfach nur wieder auf ungelesen setzten und paperless-ngx hat sie dann noch einmal verarbeitet, weil sie in die 365 Tage passte :wink:
grafik
Bei dir, obwohl alle Mails nicht verarbeitet wurden und auch nicht als gelesen markiert wurden, werden dies Mails nicht wieder angefasst.

VG
Bernd