Hue Wandschalter Modul in HomeAssistant über ZHA

Hallo,

ich habe das Hue Wandschalter Modul eingebaut und über ZHA eingebunden. Dies hat auch super funktioniert. Wenn man den angeschlossenen Lichtschalter drückt geht die Beleuchtung an per Automation. Wenn man den Lichtschalter ausschaltet feuert er eine Aktion ab Left Press Release der jedoch in den Automationen beim Gerät dann nicht ausgewählt werden kann. Dort gibt es nichts mit left dafür aber rechts gedrückt. Dachte probiere ich aus evtl. stellt ers es andersherum dar. Hat aber natürlich nicht funktioniert.
Hat jemand evtl. es auch so eingebunden und eine Idee ?
Vielen Dank. Gruß aus Frankfurt , Marco

Hab auch so ein Ding und noch nicht zum Laufen gebracht. Weder unter ZHA noch unter Zigbee2Mqtt. Damit scheint es generell ein Problem zu geben. Soll angeblich unterstützt werden, aber es gibt viele offene Threads zu dem Teil.

Ich für meinen Teil hätte gern zwei Taster angeschlossen, aber das funktioniert so gar nicht.

NACHTRAG
OMG, ich hab den Fehler bei mir gefunden. Ich habe einen Serientaster (Jalousietaster) mit zwei Wippen, aber mit einem gemeinsamen Pol. Ich hatte die beiden gelben Kabel an dem gemeinsamen Pol. Dabei kam nur Käse raus. Jetzt hab ich die beiden weißen am gemeinsamen. Jetzt gehts

Danke, dass du mich gerade nochmal darauf getriggert hast. Vielleicht ist das ja auch dein Problem?

Gern geschehen ;-). Ich hab ihn ja eingebunden und läuft auch. (Hab aber nur einen Lichtschalter mit 1 Taster dran). Aber kannst ja mal berichten wie es mit Du es dann mit den Automatisierungen machst. Wie gesagt er triggert etwas was ich nicht auswählen kann.

Hast du dir mal die Eigenschaften der Entität angeschaut? Also über ZHA in den Entitäten den Schalter aufrufen.

Ich hab nur FOH-Switches (Friends of Hue), die per Hue Bridge und Integration eingebunden sind, bei mir sieht das so aus:


Unter Ereignisse sehe ich welche Tasten verfügbar sind, Numerierung geht da von links oben(1)/unten(2) - rechts oben(3)/unten(4). Unter Logbuch erscheint in Echtzeit was vom Schalter kam.

Hallo, und Danke für deine Antwort. Aber klar da habe ich ja die getriggerten Events her. Und ich habe das Modul über ZHA eingebunden nicht über die Hue Bridge.

Wie hast du denn die Automation aufgebaut, also welchen Trigger zum Abfangen der Taster?

Ich habe das Gerät als Auslöser ausgewählt und dann dort das Modul eingetragen und dort werden mir ja dann die Möglichkeiten aufgeführt. Wie gesagt einschalten funktioniert einwandfrei. Evtl. sollte ich es mal als yaml erstellen und das event triggern welches für das auschalten gesendet wird.

Steuerst du Ein/Aus über die gleiche Automatisierung? Lass als Trigger nur den Tastendruck als Gerät und geh direkt zur Aktion, dort eine Wenn/Dann - Wenn Lampe an - Dann ausschalten - Sonst einschalten.

Nein es sollten zwei Automatisierungen werden, aber wie gesagt er findet das event nicht welches getriggert wird. Hab es gerade mal als yaml code eingegeben aber da kommt ddie Meldung das er es nicht findet. Geht leider auch nicht wie oben beschrieben weil ja die Taste nach unten zum ausschalten gedrückt werden soll und dann feuert er ja wieder die Press Left ab, die ich nicht auswählen kann.

Bei 2 Automatisierungen stören die sich gegenseitig, wenn es 2 sein sollen, brauchst du nen Helfer, als Schalter (Ein/Aus) und musst den Zustand in beiden Automatisierungen kontrollieren und ändern. Daher finde ich die einzelne Automatik einfacher.

Ich hätte es auch in einer das wäre mir eh lieber aber wie gesagt der Tastendruck zum einschalten funktioniert das das event ausgewählt getriggert werden kann. Beim ausschalten halt leider nicht. Einen Trigger nur für Tastendruck gibt es leider nicht.

Sorry, ich hab das falsch verstanden, ich dachte du hättest einen smarten Wandschalter, aber ich habe das Modul überlesen. Darüber könnte ich nur spekulieren.

Wer lesen kann ist klar im Vorteil… :smiley:

Trotzdem Danke :smiling_face: für deine schnelle Reaktion.

Hi Marco,

das klingt, als wäre der Schalter in den Einstellungen als Push-Button, also als Taster, eingerichtet, denn nur dann gibt er das Release als Event beim Ausschalten aus. Wenn er als Rocker (Wippschalter) definiert ist, setzt er beim Ein- und Ausschalten Press-Events ab, und Du kannst in der Automation für das Licht einfach umschalten (toggle) wählen. Ich weiß nicht, wie das bei ZHA aussieht, bei Z2M wäre es in Deinem Fall ein Single Rocker. Eventuell ist bei Dir auch beim Anlernen schon etwas schiefgelaufen, denn dieser Modus ist eigentlich der Standard.

Hallo und vielen Dank.
Ich hab gestern noch das dazu gefunden:

Kann es leider erst morgen ausprobieren und versuchen es umzustellen.

Danke ich habe es probiert umzustellen auf Single Rocker war aber auch schon so eingestellt. Bin jetzt auf Z2M umgestiegen da funktioniert es. Danke Dir.

Sehr gerne. ZHA muss offensichtlich noch etwas reifen. Ich hab fast 100 Geräte verschiedenster Klassen und Hersteller unter Z2M am Laufen, und alles funktioniert blendend.