Abfragen der PowerFox Daten:

Hallo zusammen,

ich komme einfach nicht mehr weiter… :frowning:
Ich sitze nun seit gut drei Tagen an diesem Project…

Ich habe zwei PowerOpiti im Einsatz:

  1. PowerOpti
    1x Einspeisung
    1x Bezug

  2. PowerOpti:
    1x HT/NT für Wäremepumpe
    1x Gesamtverbrauch

Nun habe ich mir via Stepp by Stepp die configuration.yaml angepasst
mit unten genannten Code. Jedoch scheint der Home-Assistant die Sensoren
nicht eindeutig zu erkennen. Die PV Einspeisung findet das System überhaupt nicht.

Auch habe ich das Gefühl, dass die gelieferten Daten so gar nicht stimmen…
Vor allem weiß ich gerade nicht wirklich, welcher Sensor nun welche Daten liefert?!?!?

rest:
  - authentication: basic
    username: fo.net*****@online.de
    password: mein persönliches Passwort
    scan_interval: 30
    resource: https://backend.powerfox.energy/api/2.0/my/main/current?unit=kwh
    sensor:
      - name: "poweropti"
        json_attributes:
          - "Watt"
          - "Timestamp"
          - "A_Plus"
          - "A_Minus"
          - "Outdated"
  - authentication: basic
    username: fo.n********@online.de
    password: Mein persönliches Passwort
    scan_interval: 30
    resource: https://backend.powerfox.energy/api/2.0/my/246f28*******0/current?unit=kwh
    sensor:
      - name: "poweroptizwei"
        json_attributes:
          - "Watt"
          - "Timestamp"
          - "A_Plus"
          - "A_Minus"
          - "Outdated"
template:
  - sensor:
      - name: "Strom-Warm-aktuell"
        unit_of_measurement: "W"
        device_class: "power"
        state_class: "measurement"
        state: >
            {{ state_attr('sensor.poweropti', 'Watt') }}
      - name: "Strom-Warm-Bezug"
        unit_of_measurement: "kWh"
        device_class: "energy"
        state_class: "total_increasing"
        state: >
            {{ state_attr('sensor.poweropti', 'A_Plus') }}
  - sensor:
      - name: "StromZwei-OVAG-aktuell"
        unit_of_measurement: "W"
        device_class: "power"
        state_class: "measurement"
        state: >
            {{ state_attr('sensor.poweroptizwei', 'Watt') }}
      - name: "StromZwei-OVAG-Bezug"
        unit_of_measurement: "kWh"
        device_class: "energy"
        state_class: "total_increasing"
        state: >
            {{ state_attr('sensor.poweroptizwei', 'A_Plus') }}
              - name: "StromZwei-OVAG-PV-Einspeisung"
        unit_of_measurement: "kWh"
        device_class: "energy"
        state_class: "total_increasing"
        state: >
            {{ state_attr('sensor.poweropti', 'A_Minus') }}

Auch bekomme ich derzeit im Energy DashBoard unter Stromnetz → Verbraucher die Meldung die Im Screenshot zu sehende Meldung…
grafik

Gerne würde ich die Daten der PV Abragen und den Batterie-Speicher mit hinzufügen…Aber irgendwie bekomme ich das nicht realisiert… :frowning:

Viele Grüße
der Absolute neuling… :blush: