Warum Home Assistant Thermostat Karten nicht gut sind

Hallo Simon, super Video :-) Bei mir wird leider unten in der Karte statt den Kurven nur "NaN" angezeigt. Ich kann aber den Sollwert und den Istwert im oberen Bereich sehen. Wenn ich auf "NaN" klicke sehe ich auch unter dem Reiter Verlauf meine Temperaturkurve. Ich würde mich sehr freuen, wenn mir jemand helfen kann :-) LG Pascal

Unbenannt11.PNG

@pascalblub: Kannst du mal deine config posten?

Hier ist meine Config:

<p>cards:<br />- cards:<br />- cards:<br />- entity: climate.ankleidezimmer<br />name: Heizung<br />type: custom:simple-thermostat<br />type: custom:swipe-card<br />type: horizontal-stack<br />- cards:<br />- align_state: center<br />entities:<br />- color: '#DAF7A6'<br />entity: climate.ankleidezimmer<br />index: 0<br />name: Ankleidezimmer<br />type: custom:mini-graph-card<br />type: horizontal-stack<br />type: custom:vertical-stack-in-card</p>
<p> </p>
<p> </p>

...

<p>Diese "Meldung" wird mir angezeigt, wenn ich den Code in das Fenster einfüge:</p>
<div class="title"><strong>Visueller Editor wird für diese Konfiguration nicht unterstützt:</strong></div>
<ul>
<li><strong>this._configElement.setConfig is not a function</strong></li>
</ul>
<p><strong>Du kannst deine Konfiguration weiterhin in YAML bearbeiten.</strong></p>

Ich verstehe, als Neuling etwas nicht, ich nehme einmal an, daß diese Codes bzw Cards in yaml kopiert und angepaßt werden:

cards:
  - cards:
      - cards:
          - entity: climate.1e89f334
            name: Klimaanlage
            type: custom:simple-thermostat
          - entity: climate.heizung_wohnbereich_int0000001
            name: Heizung Wohnzimmer
            type: custom:simple-thermostat
          - entity: climate.heizung_schlafzimmer_int0000003
            name: Heizung Schlafzimmer
            type: custom:simple-thermostat
          - entity: climate.heizung_bad_int0000002
            name: Heizung Bad
            type: custom:simple-thermostat
        type: custom:swipe-card
    type: horizontal-stack

Usw.

Nun meine Frage, ich habe Zugriff über ssh auf den config Ordner von HA, und habe auch schon etwas damit gearbeitet, nur weiß ich nicht, wie bzw wo die Yaml Datei abgelegt wird.

Könnte mir jemand einen Tip geben :+1:

:pencil2:by HarryP: Codezeilen formatiert (bitte immer </> verwenden)

@Charlydelta
Das sind lediglich neue Karten fürs Dashboard.
Im genannten Beispiel ein neuer Horizontaler Stapel mit 4 Thermostat-Karten drin. Kann man direkt über die Dashboard UI machen, dafür braucht man noch nicht mal den yaml Code.

Ich habe mich auch erst mit der Karte beschäftigt. Bei mir war der Wert ein Attribut. Habe RWE/Livisi Raumthermostate im Einsatz. Mal unter Entwicklerwerkzeuge - Zustände den Sensor aufrufen, da siehst Du was als Zustand bzw als Attribut ausgegeben wird. Das Ganze ist bei mir in einer Swipe-card.

So sieht der Code bei mir für die mini-graph-card aus.

type: custom:mini-graph-card
align_state: center
entities:
  - color: '#DAF7A6'
    entity: climate.r1_wohnzimmer_ventil_1_wohnzimmer
    index: 0
    name: Wohnzimmer
    attribute: current_temperature
    unit: ' °C'
    decimals: 1

Ausser einer berechtigten Mini Rüge ist meine Frage nicht beantwortet worden. Wie kann ich per Konsole auf die Karten zugreifen? Mein Problem ist, ich verstehe nur Bahnhof es ist wie mit der Rüge, ich weiß nicht wo für </> genau ist und wo es hin kommt. Ich muss mir, das was ich mache, kopieren, einfügen und die Werte ändern können und zwar so wie es Im Video, Text beschrieben wird. Ich habe Tage gebraucht um hacs zu installieren, weil ich nie verstanden habe wo hacs her kommt, also suchen, verstehe was man sucht usw. Ich bin also im Gänsemarsch unterwegs, die meisten von euch stellen sich etwas von, Tip, Tip und fertig ist die Karte, Der helfer usw.

Der Code ist die obere Karte. Die untere Karte siehe mein Beitrag.

Nachtrag:

Bitte sachlich bleiben. Es gibt diverse Videos, bei denen Deine Fragen beantwortet werden. Ich habe allein an der Swip-card mehere Tage gesessen. Und mittlerweile ein Ergebnis das für mich richtig gut ist.
Zu Deiner Frage: Die Bearbeitung der Karten erfolgt recht einfach in der Weboberfläche von HA. Wurde weiter oben schon einmal von @Charlydelta beantwortet.

:crayon:by HarryP: Zusammenführung Doppelpost.

Du kannst über die Konsole auf die Karten zugreifen.

ABER, ich denke Du solltest das besser vorerst nicht tun! Grund ist, das du aktuell selbst sagts wenig Durchblick hast, und dadurch kannst du dir wirklich ruckzuck deinen ganzen Home Assistsnat zerschiessen.

Später kannst du das mal angehen, das geht entweder über das SMB Add On (Filezugriff auf HA Share vom PC) oder über das SSH Add On (Konsolenzugriff, aber halt Linux dann). Gibt dazu gute Videos, damit hatte ich das auch gelernt damals.

Aber wie @uh13 usw gesagt haben brauchst du das gar nicht, denn du kannst das direkt im Dashboard eingeben, indem du dort auf die Option Code Editor umschaltest:

Hattest du die nicht bei dir gefunden?

Aber auch dort bitte vorsichtig sein, falsche Einträge da können auch Fehler verursachen. Ist aber ungefährlicher als direkt in Konsole oder Filesystem rumzueditieren

Hallo zusammen,
ich bin neu hier und auch neu mit Homeassistant und möchte erstmal Viele Grüße in die Runde schicken :grinning:

Eines meiner Problem konnte ich schon direkt bei lesen der Beiträge lösen, doch bei dem anderen tappe ich noch im dunkeln. Ich habe KNX im Einsatz und bin schon recht weit gekommen. Aktuelle habe ich noch den IOBroker laufen und bin am überlegen ob ich wechsle. Kommt drauf an wie es sich mit HA so gibt.

Ich habe nun ein Problem mit diesen Karten und habe bei den oberen Anzeigen der Räume unten links ui.card.climate.operation stehen. Kennt das jemand bzw. wie bekommt man das weg oder was fehlt?

Hab auch mal ein Bild hiervon.

Vielen Dank schon mal :raising_hand_man:

Update: Bin grade an verschiedenen Orten hier im Forum fündig geworden :raised_hands:

Jetzt ist mir noch aufgefallen bzw. hätte ich gerne statt 21.1 Grad das es z.B. in ganzen oder halben Gradzahlen nach oben oder unten geht? Funktioniert das?

Hi :raising_hand_man: hab das mal eingebaut und auch mal in den Entwicklerwerkzeugen geschaut. Es sieht schon mal besser aus, aber das mit der Anzeige mit z.B. 21.1 Grad bekomme ich nicht weg. Also das z.B. 21.5 steht und ich dann in 0.5er Schritten schalte. Das mit den 0.5 Schritten habe ich mit step_size: 0.5 hinbekommen, aber dann halt auch von den .1 Grad. Es steht dann z.B. 21.6 Grad da. Wenn es da noch ne Lösung von jemanden gibt wäre das Mega.

Vielen Dank und viele Grüße!

Stell die Temperatur 1x auf eine volle Gradzahl. Dann ändere die step_size auf 0.5. Dann sollte es zukünftig passen.

1 „Gefällt mir“