Energie Dashboard zeigt Falsche werte an

Hallo,
Ich habe nach dem Video von Simon meinen Stromzähler mit Tasmota und SML eingerichtet in HA kommen auch alle werde richtig an.
Im Energie Dashboard werden sie aber falsch angezeigt.

Hier noch ein paar Infos.
image

Configuration.yaml:

# Loads default set of integrations. Do not remove.
default_config:

# Load frontend themes from the themes folder
frontend:
  themes: !include_dir_merge_named themes

automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml
sensor: !include sensor.yaml


template:
  - sensor:
    # Stromzähler Verbrauch
      - name: "Stromzähler Verbrauch"
        unique_id: "StromVerbrauch"
        unit_of_measurement: 'kWh'
        device_class: "energy"
        state_class: "total_increasing"
        state: >-
            {{ float(states('sensor.netzbezug_einspeisung_counter_pos')) | round(3) }}
  - sensor:
    # Stromzähler Erzeugung
      - name: "Stromzähler Erzeugung"
        unique_id: "StromErzeugung"
        unit_of_measurement: 'kWh'
        device_class: "energy"
        state_class: "total_increasing"
        state: >-
            {{ float(states('sensor.netzbezug_einspeisung_counter_neg')) | round(3) }}

image
image

Ich bin jetzt nicht wirklich durchgestiegen, welche Werte falsch und richtig sind. Aber kann es an , (Komma) bzw. an . (Punkt) bei der Dezimalzahl liegen. Im englischen steht der Punkt für Komma und umgekehrt.

So kommen die Werte richtig in HA im Übersichts Dashboardan an:

image

Im Energie Dashboard wird das angezeigt:

Und das ist völlig falsch.

Schau mal unter Entwicklerwerkzeuge - Statistik und such dort dir falsche Entität. Hinten hast du dann ein Button “Summe anpassen”. Klick mal drauf und schau woher der enorme Anstieg kommt bzw. wann der kam.

Alles klar danke, teste ich dann heute abend, bin gerade im Spätdienst.

Habe das gefunden

image
image


image

Du solltest für die kommenden User den richtigen Beitrag als Lösung markieren, wo dann auch steht wo das zu finden ist.

Ich weis leider nicht was du meinst es werden immer noch falschwerte im Energie Dashboard angezeigt.

image

Du hast deinen Beitrag als gelöst markiert.

Du kannst über die Statistik die Werte auch korrigieren.

Das mit der Markierung ist mir nicht aufgefallen.
Danke für die Hilfe