Aqara Tür - und Fenstersensor

Hallo,

gibt es eine Möglichkeit, den Aqara Tür-Fenster Sensor direkt zu triggern, dass er sein aktuellen Zustand erneut sendet?

Hintergrund:
Ich habe bemerkt, dass mein Zigbee Netz nicht wirklich bei allen Sensoren zuverlässig arbeitet. Manchmal bekommt HA eine Zustandsänderung nicht mit. (Beispielsweise, wird ein Fenster noch als geöffnet gemeldet, obwohl es bereits geschlossen ist)
Das mag an der Entfernung/Verbindungsqualität liegen, die ich bereits versucht durch Zigbee Steckdosen als Repeater zu verbessern. Ist auch besser geworden als zuvor, aber dennoch nicht perfekt.

Deshalb würde ich gerne, bevor ich z.B. eine Automatisierung starte, den Sensor nochmals triggern sein aktuellen Zustand zu senden um sicher zugehen. Ist sowas möglich?

Danke und Gruß

Die Sensoren senden nur bei Änderungen des Zustandes. Nu so halten die Batterien gefühlt ewig…

Ich habe einige davon verbaut… Wenn die Entfernung zu weit ist, sind offline… Ein Wert dazwischen gibt’s nicht.

1 „Gefällt mir“

Ich arbeite mich gerade auch in ZigBee ein. ZHA/SkyConnect als Coordinator. Dabei stelle ich oft fest, daß die Geräte aber auch kuriose Verbindungen aufbauen, die mit Verstand wenig Sinn ergeben. Aber so lange es funktioniert. :man_shrugging:

Beispiel. Thermostat Küche Endpoint, hat einen halben Meter weiter die Hue LED Leiste auf dem Balkon, Router. Verbindet sich aber zuverlässig mit dem Zwischenstecker im Kinderzimmer, auch Router, durch zwei Wände, 8m Luftlinie entfernt ist. Reproduzierbar.

Wie sieht deine Toplogie aus? mit welchem Router ist dein Türkontakt verbunden? Das Problem ist manchmal wenn du ein Gerät an einer anderen Stelle anlernst, als da wo es verbaut wird, verbindet sich der Türsensor mit dem nächsten Router und behält die Verbindung bei dem am Anfang verbundenem Router. Abhilfe könnte sein: den Türkontakt aus Zigbee zu löschen und erneut an der verbauten Stelle zu koppeln.

Ich verwende ZHA mit SkyConnect.
Als Beispiel (Kellertür): Laut der Visualisierung habe ich ein “Verbindungs”-Wert, der zwar nicht der Beste ist, sollte aber dennoch funktionieren. Türkontakt → Steckdose Waschmaschine → dann weiter…

Obwohl die Tür zu war, zweigt er mir diese offen an. Wenn ich erneut auf-zu mache zeigt er mir diese wieder korrekt an. Ist leider nicht immer so, manchmal funktioniert es auch richtig.

Die Meldungen Kellertür Attribute Updated event was fired kommt eigentlich zu oft… oder ist das ein Prellen?
Wenn ich also die Tür auf und wieder zu mache, dürfte die Meldung doch nur zweimal erscheinen?

Was mir noch aufgefallen ist, ist eine Meldung im HA Log (meist nach dem Starten):

Der SkyConnect Stick ist ca.1,5m vom Router entfernt. Kann den baulich nicht anders anbringen. Wlan Kanal vom Router (im 2,4GHz Band) habe ich bereits geändert, damit der nicht mit dem SkyConnect kollidiert. Hat aber nichts gebracht.
Bin mir aber auch nicht sicher ob’s überhaupt damit zusammenhängt.

Die Aqara Geräte sind dafür bekannt, dass sie den Verbindungspunkt nicht dynamisch wechseln.
D.h. gerade bei den Aqara Geräten ist es wichtig sie, wie @Romka1983 geschrieben hat, an dem Ort anzulernen, an dem sie arbeiten sollen. Da hilft es auch nicht eine Steckdose o.ä. später dazwischen zu setzten als Verstärker.
Wenn man einen Verstärker verbaut muss man das Gerät löschen und am besten direkt an dem Verstärker anlernen.
Bei Z2M kann man oben das Anlernen im Dropdown auf ein Gerät (in dem Fall der Verstärker) begrenzen, dann verbindet sich der Aqara Sensor auch immer nur genau mit diesem Verstärker.

2 „Gefällt mir“

Danke für den Tipp.
Leider ist es so, dass ich bereits den Türsensor an der am Nächsten vorhandenen Zigbee-Steckdose gepaart habe (sind ca. 3m Türsensor zur Steckdose). Irgendwie ist es, zumindest bei mir so, das mit Zigbee nicht besonders zuverlässig. Aber liegt sicherlich nur an meiner Umgebung.

Werde wahrscheinlich mal den Türsensor tauschen, vielleicht hat auch nur der ein Problem.

@silberfuxx , Ich bin mit diesen Dingern zufrieden und teile deinen Post. Das Preis-Leistungsverhältnis stimmt, man muss jedoch einiges über die Dinger wissen. Dies hast du besser erklärt, als ich es könnte.

1 „Gefällt mir“

Ich würde hier gerne mal meine Erfahrungen schildern und die o.g. Aussagen etwas relativieren wollen:
Meine Aqara-Tür-/Fensterkontakte und auch der Airquality-Monitor und meine Bewegungsmelder verbinden sich lt. Netzwerkübersicht mit mehreren Repeatern bzw. dem SkyConnect und wandern auch zwischen den Punkten bzw. signalisieren wechselnde, teilweise sich sogar sprunghaft ändernde Empfangsstärken.
Ich “überwache” meine ZigBee-Geräte graphisch mit ihren RSSI-Werten:




Die Schwankungen/Sprünge kommen eindeutig von einem Wechsel der Verbindung zu den unterschiedlichen AP’s.

Danke @harryp. Das klingt ja gut.
Ich habe das nur mehrfach so gelesen und auch hier im Forum hat das wohl bei dem Einen oder Anderen das Problem gelöst, das Gerät an Ort und Stelle mit einem bestimmten Repeater zu verbinden. Mein Bewegungsmelder im Keller hat erst dann problemlos funktioniert, als ich ihn direkt dort vor Ort an der HUE Birne angelernt hatte. Aber ich glaube dir das auch bedenkenlos.
Es ging ja nur darum, ein mögliches Problem und eine passende Lösung aufzuzeigen und bei manchen hat es wohl geholfen.
Wie hast du ausgeschlossen, dass es keine Störquellen sind bzw. Messschwankungen?

Kann ich natürlich nicht völlig ausschließen, aber vor allem die sprungförmigen Veränderungen sowie die Netzwerkübersicht deuten auf den Wechsel des AP hin:

So können sich die Interpretationen unterscheiden.
Auf deine Erklärung wäre ich nie gekommen. Ich hätte auf Messungenauigkeiten in Verbindung mit Störeinflüssen getippt.
Die RSSI finde ich bei mir nicht.

Hast Du die entsprechende Entität auch aktiviert?

Das hab ich vermutlich nicht bei Z2M
grafik

Nein, beim z2m sieht man nur die LQI.

@silberfuxx
Den LQI kannste ja analog dem RSSI verwenden/überwachen, wobei ich den LQI auf Deinem Bild auch nicht sehe.

Müsste ich für HA extra aktivieren, aber in der Z2M Übersicht ist er auch so zu sehen.
Danke für die Infos

Wo bitte finde ich diese Übersichten, um schwach angebundene Geräte zu identifizieren?

z.B. unter zigbee2mqtt der LQI.

Du hast gerade eine Frage beantwortet, bevor ich sie stellen konnte. :upside_down_face:

Ich habe gestern überlegt, mit einer auto-entity Karte eine übersicht zu erstellen, welche Geräte gerade eine schlechte Verbindung haben. So wie man das zB mit dem Batteriestand machen würde.

Ich warte gerade auf einen Sonoff Stick. Ich setzte mein Smarthome gerade komplett neu auf und ziehe dabei von ZHA auf Z2M um da ich glaube, dass ZHA schon ziemlich gut ist, aber eben noch nicht gut genug in manchen Fällen.