Update Probleme HA auf Synology VM seit Update 2023.12.x

Hallo zusammen

Leider habe ich seit dem Update auf 2023.12.x Probleme mit meiner Synology Home Assistant Installation. Auf Version 2023.11.3 hat alles noch einwandfrei funktioniert.

Ich erhalte folgende Meldungen im HA Log:
IMG_1777

Auf Synology zeigt es mir diese IP Adressen an. Ich vergeb HA die Ip 192.168.1.6
IMG_1778

Hat auch jemand von euch Probleme mit der Synology VM HA Installation seit diesem Update? Leider kann HA danach nicht mehr richtig starten.

Deshalb bin ich aktuell immer noch auf der Version 2023.11.3, da diese einwandfrei ohne die Fehlermeldung und Probleme funktioniert.

Gruss
Chefchoch

Moin,
meine HomeAssistant VM auf meiner Synology 920+ läuft ohne Probleme und habe alles auf dem neusten stand.
image

Das ist komisch und kann ich mir nicht erklären.

Die Anzeige ist glaube ich nicht richtig, sonnst hätte mein HA und meine Ubuntu keine IP.

LG

Ich verstehe das auch nicht, weshalb es bei mir diese beiden zusätzlichen IP Addressen anzeigt. Ich denke, dass ist das Problem, welches auch in folgendem Forum beschrieben wird.

Update to 2023.12 can not be finish on Synology OVA · Issue #105254 · home-assistant/core (github.com)

War bei mir aber auch so, als ich HA noch auf der Synology in einer VM laufen hatte.

Ok, danke für die Antwort. Dann sind diese zusätzlichen IPs also normal? Woher kommen die den?

Die 172er IPs müsste der IP Bereich von den Docker Containern / Addons sein.

LG

Sieht man den welches Add-On welche IP braucht? Wenn ich alle Add-Ons deinstallieren würde, würde es diese IPs auch nicht mehr anzeigen? Bei dir zeigt es ja nur eine IP an. Hast du keine zusätlichen Add-Ons installiert?

Wie @totow bereits geschrieben hat sind die 172.30.x.x IP vollkommen normal


und diese werden intern von den HA Docker und dem Supervisor genutzt. Z.B. wird darüber geprüft ob ein MQTT Broker noch vorhanden ist.

Diese invalid authentication Meldung tauchte bei mir auch schon mal bei irgendeiner HA Core Version auf, allerdings aktuell nicht bei Core 2023.12.4 oder Core 2024.1.2. Ich meine das das einfach nur ein allgemeines Verbindungsproblem von HA und/oder dem HA Supervisor war und ich da gar nichts gemacht habe. Am nächsten Tag und/oder nach ein paar Reboots vom HA Host, war die automatisch weg. So genau kann ich mich daran aber leider nicht mehr erinnern.

Kommt die Meldung bei Dir denn mit 2023.12.x immer und bleibt auch durchgehend vorhanden und gibt es dann irgendwelche konkreten Probleme mit Deiner HA-Install? Falls ja solltest Du mal alle möglichen Passwörter bzw. Authentifizierung die bei den Addons verwendet werden überprüfen.

VG Jim

1 „Gefällt mir“

Hallo Jim

Vielen Dank für deine Antwort. Das spannende an meinem Problem ist, dass die Fehlermeldung mit der Version 2012.11.3 nicht erscheint. Mit allen Versionen danach erscheint diese Meldung. Die Meldung erscheint aber nur, wenn ich z.b. Update auf die neuere Home Assistant Version oder auch die Virtuelle Maschine komplett ausschalte und wieder einschalte. Dann kommt die Meldung Non-Stop und HA startet nicht mehr richtig auf, sprich das Update schlägt fehl. So konnte ich mehrmals gar nicht update und habe das Backup vom 2023.11.3 wiederhergestellt.

Wenn es mal läuft mit den neuen Versionen, funktioniert es und ich kann auch Home Assistant neu starten ohne diese Fehlermeldung.

Es passt eigentlich genau zu dieser Meldung. Nur das es bei mir leider auch mit der neusten Version nicht funktioniert:
Update to 2023.12 can not be finish on Synology OVA · Issue #105254 · home-assistant/core (github.com)

Ich habe 5 Add-Ons installiert (Grafana, InfluxDB, Samba Backup, Samba Share und Sharptools). Ich werde das mit den Passwörtern einmal versuchen, vielen Dank für den Tipp. Was mir noch aufgefallen ist, ein Add-On machte bei mir Probleme Samba Share. Das konnte nicht mehr richtig gestartet werden.

Ok wenn das Problem bei einem Update immer wieder auftaucht ist das natürlich blöd. Ich habe mir jetzt nicht die ganzen Postings in dem Link von Dir durchgelesen, aber wie hast Du die HA VM auf Deiner DS denn eingerichtet? Insbesondere wie viel RAM hast Du der gegeben, Default VM Network als Netzwerk usw.?
DS_HA_VM_Res

Auf meiner DS720+ läuft aktuell DSM 7.2.1-69057 Update 1 und die aktuelle Version von VMM und ich habe wie gesagt überhaupt keine Probleme. Weder mit Core 2023.12.4 oder auch Core 2024.1.2.

Was Du auch noch testen könntest ist die Addons mal alle temporär zu deaktivieren, bzw. nicht zu starten und dann schauen ob die Fehlermeldung weg ist und das Update keine Probleme mehr macht. Falls ja dann Zug um Zug die Addons wieder aktivieren und dann schauen ob und wann das Problem wieder auftaucht.

VG Jim

Das ist mein Hauptproblem, dass die Updates nicht klappen. Und das Update hat nun bereits mehrmals nicht geklappt, so dass ich das Backup zurückholen musste.

Die VM ist bei mir folgendermassen eingerichtet. Muss aber sagen, dass ich vorher nur 2 GB RAM hatte und Reservierte CPU-Threads 0 und auch die CPU Relative Gewichtung auf Normal. Damit habe ich auch schon etwas rumgespielt:

Es ist super, dass ich jetzt weiss, dass es an den Add-Ons liegt. Das hilft mir viel. Auch habe ich die IPs im configuration.yaml auch einmal unter Trusted-proxies ergänzt. Das hat aber leider noch nichts gebracht. Die Add-Ons temporär zu deaktivieren finde ich auch ein sehr guter Tipp.

Hallo zusammen,
hatte das gleiche Problem und die Tage gesucht wie ein blöder.
Gestern das Update letzte Update durchgeführt und läuft.

image

Gruß