Paperless NGX: Permission denied (AddOn HA in VM)

Hallo zusammen,

ich bin leider nicht fündig geworden im Forum und auch Google half mir nicht weiter.

Setup:

HA läuft auf einer VM auf einer Synology Disktation (DS918+)

Paperless NGX ist als Add-On installiert

SAMBA als Add-On installiert

Daten für Paperless sollen später in das /share/paperless/consume Verzeichnis abgelegt werden.

Die Ablage über Netzwerk in das Verzeichnis funktioniert ohne Probleme.

Problem:

Beim automatischen Verarbeiten in Paperless werden die meisten Dateien mit einem “Permission denied” Fehler abgelegt, da Paperless scheinbar nicht schreiben darf. Einige Dateien kommen durch und werden verarbeitet (Quote so bei 5% oder so).

Meine Recherche hat ergeben, das die UID und die GID entsprechend hinterlegt werden sollen (so steht es beim Troubleshooting mit Docker Installationen).

Die UID von meinem Diskstation Nutzer habe ich per SSH abgefragt. Ebenfalls die von meinem Mac mit dem ich Daten, probeweise, abgelegt habe.

Beides führt nicht zum Erfolg.

Frage:

Welche UID und GID müssen denn hinterlegt werden?

Macht es etwas aus, dass die VM eine andere IP Adresse hat, als der Host (Disktation) auf dem sie läuft?

Wenn ja, wie bekomme ich die richtige ID raus?

Oder gibt es einen anderen Ansatz?

Wenn ich etwas vergessen habe, gerne nachfragen und ich liefere die Infos (ja ich weiß, das Problem sitzt in der Regel vor dem PC :sweat_smile: )

Danke im Voraus und viele Grüße

Jens

gelöst:

Wie gesagt sitzt das Problem vor dem PC.

SSH auf HA installiert, da die UID herausgefunden und eingetragen. Geht dann.