ESP Home "no route to Host"

Hallo,
ich habe gerade mal wieder einen ESP Mini mit ESP Home geflasht. Der code ist folgender

esphome:
  name: hkfussboden
  friendly_name: FussbodenHeizung

esp8266:
  board: esp01_1m

# Enable logging
logger:

# Enable Home Assistant API
api:
  encryption:
    key: "xxxxxxxxxxxxxxxxxxxxxxxxxx"

ota:


wifi:
  ssid: !secret WLan_ssid
  password: !secret WLan_password
  manual_ip:
    static_ip: 192.168.2.110
    gateway: 192.168.2.1
    subnet: 255.255.255.0
    dns1: 192.168.2.1

  # Enable fallback hotspot (captive portal) in case wifi connection fails
  ap:
    ssid: "HKFussboden-AP"
    password: !secret Fallback_PW

captive_portal:
    

dallas:
  pin:
    number: 2
    mode:
      input: true
      pullup: true
  update_interval: 10s 

# Individual sensors

Den Cod ekann ich per WiFi hochladen aber dann bekomme ich die folgende Fehlermeldung

INFO ESPHome 2023.12.9
INFO Reading configuration /config/esphome/esphome-web-145db1.yaml...
INFO Generating C++ source...
INFO Compiling app...
Processing hkfussboden (board: esp01_1m; framework: arduino; platform: platformio/espressif8266@3.2.0)
--------------------------------------------------------------------------------
HARDWARE: ESP8266 80MHz, 80KB RAM, 1MB Flash
Dependency Graph
|-- ESPAsyncTCP-esphome @ 2.0.0
|-- ESPAsyncWebServer-esphome @ 3.1.0
|-- DNSServer @ 1.1.1
|-- ESP8266WiFi @ 1.0
|-- ESP8266mDNS @ 1.2
|-- noise-c @ 0.1.4
RAM:   [====      ]  41.8% (used 34212 bytes from 81920 bytes)
Flash: [=====     ]  48.2% (used 493293 bytes from 1023984 bytes)
========================= [SUCCESS] Took 6.21 seconds =========================
INFO Successfully compiled program.
INFO Connecting to 192.168.2.110
ERROR Connecting to 192.168.2.110:8266 failed: [Errno 113] No route to host

WLan Empfang ist ausreichend vorhanden.
Habt ihr eine Idee was ich machen kann ?
Danke euch schon mal im voraus
Gruß
Andreas

Denke mal, dass 110 die IP ist, die du dem ESP zuweisen willst.
Er versucht über “192.168.2.110:8266” auf HA zuzugreifen.
Nimm mal die " dns1: 192.168.2.1" raus.

Auch das hat keinen Unterschied gebracht :frowning:
Wenn ich die Anweisungen für eine statische IP komplett weglasse dann kommt das

INFO Successfully compiled program.
INFO Resolving IP address of hkfussboden.local
ERROR Error resolving IP address of hkfussboden.local. Is it connected to WiFi?
ERROR (If this error persists, please set a static IP address: https://esphome.io/components/wifi.html#manual-ips)
ERROR Error resolving IP address: Error resolving address with mDNS: Did not respond. Maybe the device is offline., [Errno -5] No address associated with hostname

Ich bin echt am verzweifeln denn genau so habe ich einen anderen ESP am laufen und der leigt nicht mal einen Meter daneben also sollte der Empfang wohl OK sein.
gruß
Andreas

Für mich verbindet er sich nicht mit dem WLan.

Ich habe nicht WLan_ssid und WLan_password
sondern wifi_ssid und wifi_password, als Zugangsdaten.
Auch alle klein geschrieben, ist da der Fehler?

wifi:
  ssid: !secret wifi_ssid
  password: !secret wifi_password

  # Enable fallback hotspot (captive portal) in case wifi connection fails
  ap:
    ssid: "Hz-Vor-Rucklauf-Bttracker"
    password: "xxxxxxxxxxxxxxx"

captive_portal:

    

Danke für den Hinweis, ich habe das auch nochmal geprüft und sogar die SSID und PW im Klartext eingetragen aber immernoch der gleiche Fehler
Mist :frowning:

Hattest Du den ESP schon mal mit einem anderen Programm bespielt und im Einsatz?
Wenn ja, setze ihn einmal über ESP Home Web zurück?

Ich hatte auch schon einmal Probleme mit dem WLAN Zugang und konnte nur über obigen Link den neuen Code aufspielen.
(ursächlich war aber Shelly der mir einfach eine schon genutzte IP Adresse geklaut hat :slight_smile: )

Hast du noch einen ESP?
Vielleicht hat der eine Macke oder wie schon geschrieben mit ESP Home Web mal beschreiben.

Wie hast du den ESP initial beschrieben, per USB?

@spiderrolli

wen ich das richtig verstehe versucht er sich mit dein Router zu verbinden sagst immer aber auch gleich

manual_ip:
static_ip: 192.168.2.110
gateway: 192.168.2.1
subnet: 255.255.255.0
dns1: 192.168.2.1

das du ihn nur darüber erreichst wen dein Router nicht die ip 192.168.2.110 kann er sich auch nicht verbinden lösch den teil mal raus und versuch es noch mall

ps. wen du ein D1 mini hast bitte
board: d1_mini
eingeben dann kann man die Sensoren mit D4 zb. ansprechen

Wenn ich mir das so anschaue, versucht er initial per WLAN (OTA) den ESP zu flashen,

Das geht aber erst, wenn der einmal per USB geflashed wurde.

Schau mal die letzten 3 Zeilen.

DANKE,
bestes Forum :+1:t3:
Ich habe die .yaml Datei compiliert und per ESP Home direkt per USB runtergeladen.
Jetzt geht es zwar findet er den Temperatur sensor noch nicht aber ich bin auf jeden fall schon mal ein großes Stück weiter.
Hier mal die Meldung bzgl. des Sensors vielleicht hat ja von euch jemand noch eine Idde dazu.

[20:55:45][W][dallas.sensor:080]:   Found no sensors!
[20:55:45][C][captive_portal:088]: Captive Portal:
[20:55:45][C][mdns:115]: mDNS:
[20:55:45][C][mdns:116]:   Hostname: fussbodenhk
[20:55:45][C][ota:097]: Over-The-Air Updates:
[20:55:45][C][ota:098]:   Address: 192.168.2.110:8266
[20:55:45][C][api:139]: API Server:
[20:55:45][C][api:140]:   Address: 192.168.2.110:6053
[20:55:45][C][api:142]:   Using noise encryption: YES
[20:55:47][E][dallas.sensor:112]: Requesting conversion failed
[20:55:57][E][dallas.sensor:112]: Requesting conversion failed
[20:56:07][E][dallas.sensor:112]: Requesting conversion failed
[20:56:17][E][dallas.sensor:112]: Requesting conversion failed
[20:56:26][D][api:102]: Accepted 192.168.2.12
[20:56:26][W][api.connection:091]: : Socket operation failed: HANDSHAKESTATE_READ_FAILED errno=11
[20:56:27][E][dallas.sensor:112]: Requesting conversion failed
[20:56:37][E][dallas.sensor:112]: Requesting conversion failed

Nachtrag:
So Sensor auch fertig, war nur nicht richtig angeschlossen, Die Drähte an den Dingern sind einfach zu dünn :grinning:
Jetzt habe ich “nur” noch ein Warnung

[21:04:33][D][api:102]: Accepted 192.168.2.12
[21:04:33][W][api.connection:091]: : Socket operation failed: HANDSHAKESTATE_READ_FAILED errno=11
[21:05:33][D][api:102]: Accepted 192.168.2.12
[21:05:33][W][api.connection:091]: : Socket operation failed: HANDSHAKESTATE_READ_FAILED errno=11
[21:06:33][D][api:102]: Accepted 192.168.2.12
[21:06:33][W][api.connection:091]: : Socket operation failed: HANDSHAKESTATE_READ_FAILED errno=11

Ich hoffe das das auch mal jemand interpretieren kann

Danke an euch alle schon mal im Voraus.
Gruß
Andreas

:crayon:by HarryP: Zusammenführung Doppelpost

Per WLAN geht erst, wenn OTA gemacht werden soll, muss der ESP erstmal per USB geladen werden.

Wie wird der ESP im Router angezeigt?
Denke mal mit 192.168.2.12, ist die 192.168.2.110 wirklich frei?