Aktueller Stromverbrauch / Strombezug hat hohe Leistungsspitzen (>200.000 Watt)

Hallo,

ich habe seit einigen Tagen einen neuen (smarten) Stromzähler weil der alte defekt war.

Ich hab also für den IR-Lesekopf (Hichi mit Tasmota) ein neues Script eingefügt, die Template-Sensoren aktualisiert und es scheint (normalerweise) alles zu funktionieren wie vorher nur dass ich 1 oder 2 mal am Tag sehr sehr hohe Leistungsspitzen von teilweise über 200.000 Watt habe:

momentanverbrauch-leistungsspitzen-01

Ich bezweifel dass ich am 14.02. um 22:15 tatsächllich 999.999 Watt verbraucht habe! :wink:

Hat jemand eine Idee woran das liegen könnte?

Hier mein Tasmita-Script vom Lesekopf:

>D  
>B  
->sensor53 r
>M 1  
+1,3,s,1,9600,SML
1,77070100010800ff@1000,Bezug,KWh,Total_in,20
1,77070100020800ff@1000,Einspeisung,KWh,Total_out,20
1,77070100100700ff@1,Wirkleistung,W,curr_w,20
#

und hier der Template-Sensor:

  - sensor:
      - name: "Momentanverbrauch"
        unique_id: "Momentanverbrauch"
        unit_of_measurement: 'W'
        state_class: "measurement"
        device_class: "power"
        state: >-
          {{ float(states('sensor.tasmota_sml_curr_w')) | round(1) }}
        availability: "{{ is_number(states('sensor.tasmota_sml_curr_w')) }}"

Mein neuer Stromzähler ist ein “Apator Lepus”

Im Tasmota-Menü vom IR Lesekopf hab ich unter Configuation / Configure Logging / Telemetry period 10 eingetragen (kleinst-möglicher Wert) es hat aber mit 20 auch nichts geändert…

Ich wäre sehr dankbar für jede Hilfe da dadurch ja auch die “Energieverteilung” auf dem Dashboard völlig falsche Werte anzeigt:

momentanverbrauch-leistungsspitzen-02

NACHTRAG:

Mir ist grade aufgefallen dass in dem ursprünglichen Tasmota-Script dass ich auf irgend einem Forum gefunden habe hinter curr_w “,0” stand.

@anon58637561 hatte mich in einem anderen Thread darauf hingewiesen dass man dise Zahl plus 16 addieren muss um die Daten in echtzeit auszulesen (danke nochmal dafür!) - ich hatte da 20 stehen weil bei “Einspeisung” und “Bezug” vorher 4 da stand. Jetzt muss ich abwarten ob das die Lösung war…

die kannst du mit dem “median” Parameter glätten, siehe Smart Meter Interface - Tasmota

1 „Gefällt mir“

Hallo @noschvie und danke für Deine Antwort,

ich hab mir die Infos auf der verlinkten Seite durchgelesen aber verstehe leider nicht wie man das anwendet - ich gehe davon aus dass ich nicht einfach die Zeile 16 irgendo ins script einfügen kann oder?

Unter Configuration in der Tasmota Software finde ich auch nichts mit flag oder median.

Könntest Du mir ein Anwendungsbeispiel geben?

+1,3,s,16,9600,SML

<flag> auf 16 für “enable median filter”

1 „Gefällt mir“

Vielen Dank!

Jetzt wo Du mich drauf aufmerksam gemacht hat wo das hinkommt hab ich nochmal nachgesehen wie mein altes Script (vom alten Stromzähler) war - und siehe da: Es stand auch eine 16 an der Stelle! :sweat_smile: