ESP32-CAM Wasserzähler auslesen

Hallo,
ich wollte gern eine Wasserzählerfernauslesung platzieren.

Aktuell glückt es mir nicht, diesen Flash-Vorgang zu starten bzw. zu beenden. Das Tool 3.9.5 erkennt am COM3 eine Hardware und ich trage die nötigen Parameter ein… aber es passiert nichts.

Können Sie mir hier helfen?

MfG Chr. Städtler

Benutze doch einfach den Webinstaller: AI on the Edge Device - Webinstaller

Hallo,
das hatte ich vergessen …

und dann kommt dieses Meldung

image

Nachtrag:

@NightWatcher
Hallo,
das klappt leider nicht.

:crayon:by HarryP: Zusammenführung Doppelpost

Du brauchst ein USB Kabel dass Datenübertragung unterstützt.

Hallo, das Gerät wird ja am COM 3 erkannt. Also sollte die Kommunikation passen?! Oder?

Hallo,
ich konnte das System per online Flash durchführen. Nun blinkert die LED vom ESP Modul die ganze Zeit Rhythmisch vor sich hin?!
Wie leite ich den Bootvorgang ein?

LC Christian

Ich hab dir doch geschrieben es kann sein dass dein USB Kabel keine Daten übertragen kann. Es gibt unterschiedliche Kabel die meisten sind nur zum Laden geeignet.
Wenn du die daten übertragen hast den ESP abstecken, die Daten auf die SD schreiben und nicht vergessen das wlan ein zu richten.
SD einstecken und ESP wieder mit Stromversorgung/USB anschließen.
Dann sollte es normal funktionieren.
Nach neuen Netzwerkgerät in deinem Router schauen und die IP im Browser aufrufen.
Wenn du das Gerät einrichtest nicht Wasserzähler verwenden nur Wasserzaehler.

Wichtig ist auch, den ESP in den Flash Modus zu bringen, i.a. GPIO0 auf GND. Und die SD Karte vorher zu bearbeiten inkl. WLAN Settings.

OK. Danke.

Ich habe das mit dem Updaten der firmware noch nicht ganz abschließen können …

We have one or more critical errors:
0x00000010

Die Struktur auf der Karte stimmt?! Ich sehe die CAM auch bereits im W-Lan.

Schön, dass es funktioniert hat. Ich dachte, du hättest ein ähnliches Problem wie ich.
Ich schreibe das trotzdem kurz hier, falls jemand hier drüber stolpert.
Bei meinen ersten Versuchen einen ESP an Windows11 zu installieren, hatte ich auch die Verbindung, die du im Bild gezeigt hast, aber ich konnte, auch mit dem Web-Installer, den ESP nicht vorberieten, bis ich noch einen Treiber für das ESP-Board (zusätzlich) installiert hatte. Danach hatte ich zusätzlich noch einen zweiten Port zur Auswahl und mit dem hat es dann funktioniert. (Ich glaube irgendwas mit UART-Bridge o.ä.) Ich kann das gerade nicht testen von unterwegs.

@noschvie
Hallo noschvie,
das war glaube ich mein Hauptproblem. Das hatte ich nicht richtig aktiviert bekommen. Aber jetzt klappt es. Ich bin da sehr glücklich drüber.

LG Christian

@silberfuxx
Hallo silberfuxx,
das mit den Treibern unter Win 11 hatte ich ganz am Anfang bereits (unbewusst) erledigt. Ich hatte ganz am Anfang diesen COM 3 auch nicht angeboten bekommen und nach der Treiberinstallation hatte ich auch diese Hürde genommen.

LG Christian

:crayon:by HarryP: Zusammenführung Doppelpost

1 „Gefällt mir“

Da es bei dir ja funktioniert hat, ist das ja fein.
Ich habe mal einen Screenshot gemacht:
ESP32
grafik
ESP8266
grafik

Die oberen hatte Windows “automatisch” installiert, aber das hat bei mir zwar etwas “gemacht”, aber schlussendlich nicht funktioniert.
Ich habe dann per Internetsuche auf den HPs der Chipherstellers entsprechende Treiber geladen und installiert und dann ist die zweite Option aufgetaucht und mit der war eine Web-Installation möglich.
Nur als Information, falls noch jemand Probleme mit dem Standard Windowstreiber hat.