Influx DB v2 und Grafana

Soweit so gut.
Daten kommen keine an???
Die Aliassache funktioniert auch nicht
sprich influxDB .yaml erstellt:

 api_version: 2
  ssl: false
  host: (der gleiche wie HA)
  port: 8086
  token:...geheim
  organization: RANDOM_16_DIGIT_HEX_ID
  bucket: BUCKET_NAME
  tags:
    source: home_assitent
  tags_attributes:
    - friendly_name
  default_measurement: units

inn config .yaml verlinkt: (influxdb: !include influxDB.yaml)

also ist der Eintrag in der config.yaml ist die Konfigurationsprüfung ok
als alias zeigt die Konfigurationsprüfung fehler:(influxdb: !include influxDB.yaml)
Error loading /config/configuration.yaml: in “/config/configuration.yaml”, line 12, column 11: Unable to read file /config/influxDB.yaml.

Moin,

wenn das Deine influxDB.yaml ist,

api_version: 2
  ssl: false
  host: (der gleiche wie HA)
  port: 8086
  token:...geheim
  organization: RANDOM_16_DIGIT_HEX_ID
  bucket: BUCKET_NAME
  tags:
    source: home_assitent
  tags_attributes:
    - friendly_name
  default_measurement: units

Dann bin ich mir auch nicht sicher ob das klappt,

  • Zeile 1, sieht ok aus
  • Zeile 2, sieht ok aus
  • Zeile 3, da steht hoffentlich eine IP drin im Original
  • Zeile 4, sieht ok aus
  • Zeile 5, sieht ok aus, wenn da entweder der Token steht oder halt !secret influxDB_token
  • Zeile 6, ob das so funktioniert, kann ich nicht sagen, denn bei mir steht da die ID meiner Organisation
  • Zeile 7, ist aus meiner Sicht auch nicht ok, denn so heißt Dein Bucket BUCKER_NAME
  • Zeile 8 ff, ist so weit ok.

Zeig doch mal Deine configuration.yaml, kann es sein, dass Du einmal alles klein schreibst, dann wieder Groß-, Klein mixt?

VG
Bernd

  • Zeile 1, sieht ok aus
  • Zeile 2, sieht ok aus
  • Zeile 3, da steht hoffentlich eine IP drin im Original ja
  • Zeile 4, sieht ok aus
  • Zeile 5, sieht ok aus, wenn da entweder der Token steht oder halt !secret influxDB_token (Weis ich jetzt wo und wie)
  • Zeile 6, ob das so funktioniert, kann ich nicht sagen, denn bei mir steht da die ID meiner Organisation (wie bekomme ich den richtigen Input her?)
  • Zeile 7, ist aus meiner Sicht auch nicht ok, denn so heißt Dein Bucket BUCKER_NAME (wie bekomme ich den richtigen Input her?)
  • Zeile 8 ff, ist so weit ok.

meine configuration.yaml

# Loads default set of integrations. Do not remove.
default_config:

# Load frontend themes from the themes folder
frontend:
  themes: !include_dir_merge_named themes

automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml
influxdb: !include influxDB.yaml

irgendwie sieht der Editor anders aus.

Moin,

und die Datei heißt auch genau so und liegt auch da wo die configuration.yaml liegt?
Siehe, wie es bei mir aussieht:

VG
Bernd

1 „Gefällt mir“

ja ich denke schon habe noch mal geschaut
Aber egal
Ich denke die richtigen Einträge sind erst einmal wichtiger.
Also ert eimal alles richtig in der configuration .yaml
und dann in extra yaml

Moin,

keine Ahnung, worauf sich das bezieht :thinking:
Ich nutze das Add-on
grafik
Du vielleicht
grafik

Falls Du etwas anderes meinst, musst Du das noch mal besser beschreiben.

VG
Bernd

1 „Gefällt mir“

Mein File editor zeigt ein anderes Bild

Ist doch eigentlich egal, wie es aussieht, der Inhalt, sprich der yaml-code zählt.

Zumal es immer besser ist, den Code hier richtig zu posten

tippe oder füge den Code hier ein

und nicht einfach nur Hardcopy’s einzustellen!

Moin,

bitte lösche das Bild mal, denn da steht Deine E-Mail für Google Drive drin.

VG
Bernd

Kann leider nicht folgen, was meinst Du mit ein anderes Bild, ich sehe eine recht Jungfräuliche configuration.yaml Datei.

1 „Gefällt mir“

ja ich bin erst am Anfang was HA betrifft
mit der Yaml erst recht.
Das Bild welches du gepostet hast, ist wohl ein extern im Explorer ?
es zeigt eine gute Übersicht.
Man sieht die unterschiedlichen yamls.
Im HA File Editor ist das nicht so übersichtlich.

Auf jeden fall sind die Bezeichnungen (influxBD.yaml) kleingeschrieben und genau wie sie sollten. (also keine zusätzlichen Freizeichen)
Deshalb verstehe ich nicht weshalb der Verweis nicht so funktioniert wie der direkte Eintrag in die configuration.yaml.
Aber wie gesagt erst einmal influxDB zum laufen Bringen und danach (extra yaml)

noch einmal die Frage:

Token , IP-HA, Port sind klar.
organization: und bucket: sind unklar (sollten in InfluxDB vergeben werden glaube ich) oder wo nehme ich die her?

lG rick

@harryp

Du hast vollkommen recht mit Hardcopys
Ich mache allerdings beim schreiben noch mehr Fehler als beim kopieren.

Auf jeden Fall macht ihr Wissenden euch viel Mühe mit den Unwissenden.
Dafür Danke!

Ich lerne viel wenn auch langsam.

1 „Gefällt mir“

Moin,

ich kann das nicht für die Installation als Add-on beantworten, da ich meine Dienste außerhalb von HA betreibe.

Aber Du kannst Dir das alles in influxDB anlegen, bzw. kannst Du in der influxDB WEB-UI nachschauen, was es schon gibt, also durch die Installation des Add-ons schon eingerichtet wurde.
Dazu, geh mal alle Punkte, Members, About, Switch Organisations, durch und schau, was es dort gibt
grafik
Wenn Du dann noch keine Organisation hast, dann mit Create Organisation eine erstellen und dann in diese Organisation wechseln → Switch Organisations, da kannst Du Dir dann ein neues Bucket erstellen.

Aber noch einmal, schau erst, was schon da ist.

VG
Bernd

1 „Gefällt mir“

Ich habe jetzt die Infux DB V2 auf meiner Qnap installiert

Nun teste ich weiter

1 „Gefällt mir“