Zigbee2Mqtt benötigt Firmware Update

Hallo

ich habe mir einen Aquara Bewegungsmelder gekauft und dieser lässt sich leider nicht richtig anlernen. Wenn ich auf den Link in der Weboberfläche klicke wird mir gezeigt das es eine entsprechende Firmware gäbe und damit sei dies kein Problem.


https://www.zigbee2mqtt.io/devices/RTCGQ14LM.html


Ich habe es auch schon versucht das gerät direkt neben dem Dongle anzulernen.

Das komische ist bei anderen geraten von Aquara ist das kein Problem (Taster und Temperatur/Feuchtigkeitssensor)


Leider funktioniert das anlernen vom Hue Bewegungsmelder bei mir auch nicht.

Vielleicht habt ihr ja eine Idee :)

Hi Strak,
Habe den Sensor leider selber nicht und kann von daher relativ wenig dazu sagen… Aber ich habe auf der Seite gelesen, dass man auf alle Fälle die Firmware vom Dongle aktualisieren muss.

Hattest du das schon gemacht?

Hallo,

ne das mit dem Update habe ich leider noch nicht geschafft. Damit tu ich mich grad schwer da ich keinen Windows PC habe um es Über den Flasher zu machen und der weg mit Python funktioniert bei mir nicht (bin mir ziemlich sicher das ich etwas falsch mache).
Da stehe ich aktuell auf dem Schlauch aber morgen fahre ich zu einem Kollegen der hat einen windows PC da darf ich das Update durchführen 👍

Guter Reminder für mich an der Stelle, ich wollte ohnehin ein Video darüber machen, wie man das Firmwareupdate direkt auf Home Assistant machen kann 😅

Aber das ist doch ein Super Plan! Berichte gerne wieder, ob das Problem dann gelöst ist. Und verpasst morgen nicht mein Video zum neuen Home Assistant Update 2022.12 ;)

Beste Grüße und für dich und deinen Kollegen schon mal vorab ein schönes Wochenende 👋

Also ich habe das Update jetzt an dem Rechner meines Kumpels durchführen können, war alles schnell erledigt.

Bin dann direkt nach hause zum ausprobieren aber leider lässt sich der Bewegungsmelder immer noch nicht anlernen.

Also ich war von dem sonoff stick und zigbee2mqtt echt angetan da ich gerbe eine Bridge für alles hätte aber mittlerweile kommt immer mehr Ernüchterung zum Vorschein da ich viele gerate die angeblich ohne weiteres funktionieren sollen nicht anlernen kann 😓

Kann es sein das an meiner Installation eventuell etwas falsch ist ?

Ich bekomme immer diesen link angezeigt:
https://www.zigbee2mqtt.io/advanced/support-new-devices/01_support_new_devices.html

leider bin ich damit völlig überfordert.

Vielleicht wäre das ja auch mal eine Video Idee :D

Lg

Also irgendwie ist das schon sehr merkwürdig. Wenn das Gerät als Support in der Z2M Datenbank steht und es nicht zufällig neue Hardware-Versionen geben sollte, haben die bei mir immer einwandfrei funktioniert...

Und ja, das mit dem Hinzufügen eigener Geräte wird ein Thema für ein neues Video, aber frühestens in Q2 2023 würde ich mal schätzen. 👍

Hast du die Geräte mal möglichst nahe am Dongle angelernt und das Anlernene mal einfach ein 2tes mal versucht (Z2M Anlernmodus aktivieren, Gerät nicht aus Z2M löschen und einfach das Gerät noch mal in den Anlernmodus bringen)

Beste Grüße und bis bald 👋

Ja finde es auch etwas Merkwürdig, bei mir hat auch alles bisher problemlos funktioniert. Vielleicht solltest du mal ein Back Up von deinem HA machen und die wirklich den Sonoff Stick neu installieren. Einfach nur mal um zu testen, ob du dann deinen Bewegungssensor rein bekommst.

Und auf das Video bin ich schon gespannt Simon, das würde mich sehr interessieren.

Vielen Dank für die Antworten :)

Also das mit dem Backup und der Neuinstallation werde ich in ruhiger Minute mal durchführen das ist aufjedenfall einen versuch wert.


Muss ich dann einfach ein Backup erstellen und dort dann Zigbee2Mqtt und Mosquitto aus dem Backup ausschließen?
Und muss ich meine Geräte dann alle wieder neu anlernen oder kann ich die vorhandenen gerate per Backup sichern und nachher wieder in die Neuinstallation includieren?

----

Allerdings befürchte ich auch das mein komplettes HASSIO Setup an einem ungünstigen Ort platziert ist und zwar im Heizungsraum dort ist der Sicherungskasten, Gastherme, WLan Router und da habe ich dann noch in unmittelbarer nähe den PI mit Raspberrymatic und Sonoff Stick.
Raspberrymatic und Sonoff habe ich mit Verlängerungskabel vom PI entfernt (ca 1m).

Vermute mal das sich die Funknetze dort ordentlich stören oder ?

@simon42 das mehrfach anlernen habe ich auch direkt schon probiert da ich das in einem anderen Post hier im Forum gelesen habe :+1: hat leider alles nicht funktioniert.

Das Back Up ist dafür da, das selbst wenn die Neuinstallation nix bringt, du wieder dein Back Up aufspielen kannst und es so ist wie vorher. Wenn es klappt, musst du dann auch deine restlichen Geräte neu an lernen, anders wird das nicht gehen, zumindestens nicht das ich wüsste.

WICHTIG, wenn du sie neu an lernst, dann nenne sie so wie vorher und vergess nicht den Hacken für die Entitätsänderung! Dann musst du nicht deine ganzen Automationen und Dashboard neu anpassen.

Und ja der Aufbau deines Setups ist schlicht weg ein Paradies für den Funkkrieg unter deinen Geräten, Wahnsinn. Funktioniert sonst, alles bei dir zuverlässig, oder geht gerne mal was nicht?

@maikel Ok alles klar dann werde ich das mal machen. Das gute ist das ich bisher nur 5 Geräte an dem Sonoff Stick angelernt habe, das ist also noch zu verkraften.

Ich kann bisher nicht feststellen das etwas nicht funktioniert bis auf die Situation grad mit dem Sonoff Stick. Bin mir aber auch bewusst das es so nicht optimal ist und das wohl als erstes geändert werden sollte.
Das Setup wird auch nicht immer dort bleiben im neuen Jahr baue ich mein Büro aus ( saniere grad einen alten Resthof) und dort wird dann nur der Pi mit den beiden Sticks platziert werden, dieser Raum ist dann auch Zentral im Haus.

So ich hab mich eben mal drangemacht und bin als erstes mit meinem Setup ins Wohnzimmer gezogen ( meine Freundin wird sich freuen :D ), anschließend habe ich alles deinstalliert und wieder neu installiert. Das merkwürdige war jetzt nur nachdem ich fertig war hat das AddOn meine ganzen Geräte die vorher angelernt waren so wieder mit aufgenommen. Als wäre nix gewesen ...

Nochmal versucht den Bewegungsmelder anzulernen aber das war ohne Erfolg

Wie muss ich denn beim Löschen vorgehen damit wirklich nichts über bleibt und ich von neu Installieren kann?
Oder muss ich das System komplett neu aufspielen ?

Wenn ich mich nicht irre legt das addon eine DB Datei an... Nutze es aktuell nicht warte noch auf meinen Stick.

Könnte mir aber vorstellen das dort deine geräte hinterlegt sind.

Würde Mal mit dem File Editor oder samba die Dateien durchsuchen .

Ja genau, schau mal im Fileeditor nach ob nicht irgendwo Rückstände sind, oder wie schon gesagt wurde mit Samba Share. Dort in die Suchleiste mal Zigbee oder so eingeben und mal schauen was er aus spuckt. Wenn er was mit Zigbee2Mqtt findet, einfach mit löschen.

Abend😎

Also ich wollte mich nochmal zurückmelden.

Ich habe mich letzten Endes jetzt von zigbee2mqtt verabschiedet und bin auf ZHA umgestiegen. Ich denke mal auch das sollte für meine Bedürfnisse vollkommen reichen bzw. habe ich da auch die Hoffnung das die Entwicklung da ja auch immer weitergeht und ZHA dem zigbee2mqtt nicht zu sehr hinterher hängt😅

Es läuft aufjedenfall alles Stabil und ich kann alle Geräte die ich habe anlernen somit bin ich zufrieden 👍🏻

Ich konnte auch einen SkyConnect Stick ergattern, dieser soll im Januar ausgeliefert werden und mal schauen was das ganze so mit sich bringt ☺️

vielen Dank an euch und schöne Feiertage!