ZigBee Entitäten im Frontend

Guten Morgen,

ich musste leider ein frisches HA System aufsetzen und dann ein BackUp einspielen. Habe das dann gleich genutzt um vom Pi400 auf einen Pi4 zu wechseln, der mittlerweile bezahlbar ist. Es hat gedauert, aber nun läuft es wieder.

Für ZigBee Einbindung nutze ich ZigBee2MQTT, Einbindung wie hier von Simon beschrieben. Alle Geräte sind im ZigBee Dashboard ansprechbar, schaltbar und liefern Daten. Leider werden sie aber auch ausnahmslos alle nicht im Frontend dargestellt und die Automationen mit den ZigBee Entitäten laufen auch nicht.

Neustarts inkl. Addons habe ich mehrfach durchgeführt wie hier empfohlen. Leider erfolglos. Im Frontend werden die Entitäten dargestellt, aber in grau bzw. Entität nicht verfügbar. Irgendwo hakt wohl die Verbindung.

Weiß jemand Rat? DANKE!

Hast du mal unter Einstellungen - Geräte & Dienste - Geräte geschaut ob sie dort vorhanden sind?

Hallo,

sie werden unter MQTT alle aufgeführt, allerdings kann ich sie nicht ansprechen (ausgegraut).Das Problem scheint MQTT zu sein, denn ich erhalte folgende Meldung:

Diese Entität wird nicht mehr von der Integration mqtt bereitgestellt. Wenn die Entität nicht mehr verwendet wird, lösche sie in den Einstellungen.

Ich noch mal… es scheint so zu sein, dass MQTT Broker und ZicBee2MQTT nicht ordentlich verbunden sind. Ich habe jetzt die Passworte ergänzt und nach meiner Recherche müsste es richtig sein:

Zigbee2MQTT Konfiguration:

data_path: /config/zigbee2mqtt
socat:
enabled: false
master: pty,raw,echo=0,link=/tmp/ttyZ2M,mode=777
slave: tcp-listen:8485,keepalive,nodelay,reuseaddr,keepidle=1,keepintvl=1,keepcnt=5
options: “-d -d”
log: false
mqtt:
base_topic: zigbee2mqtt
server: mqtt://192.168.178.63:1883
username: CHRISTOPH
password: XXXXX
serial:
port: /dev/ttyUSB0

Mosquitto broker Konfiguration:

logins:

  • username: CHRISTOPH
    password: XXXXX
    require_certificate: false
    certfile: fullchain.pem
    keyfile: privkey.pem
    customize:
    active: false
    folder: mosquitto

Dann war noch einmal ein username und Passwort in der configuration.yaml des ZidBee2MQTT aufgeführt, auch hier habe ich geändert:

homeassistant: true
mqtt:
server: mqtt://192.168.178.63:1883
user: CHRISTOPH
password: XXXXX

Läuft aber leider immer noch nicht bzw. nichts hat sich hierdurch verändert.

In der configuration.yaml brauchst du dafür nichts eintragen.

Läuft der broker den richtig? Also das Mosquitto Addon?