Wofür verwendet man die Utility Meter Integration?

Hey, versuche gerade zu verstehen wofür man die Utility Meter benötigt. So grob habe ich es verstanden aber zeichnet nicht das Energie Dashboard eh alle Werte auf?

Meine Werte zeichnet das Energie Dashboard zwar auf, aber so schön übersichtlich wie hier lässt es sich nicht abrufen/darstellen.
Dann kann man den Utility Meter natürlich auch für Werte nutzen, die NICHT im Energie Dashboard hinterlegt sind.

Ich muss aber leider sagen, dass der “Utility Meter” auch Macken/Schwächen hat.
Ein Reboot von Home Assistant kann ihn auch ganz schön durcheinander wirbeln und schnell hat man doppelte und dreifache Tageswerte da stehen.

Gerade in meiner Anfangszeit von HomeAssistant mit vielen Anpassungen, Einstellungsänderungen und somit Reboots bin ich schier verzweifelt. Mittlerweile läuft es aber stabil.

1 „Gefällt mir“

Hallo @Soul,

mir hilft es z.B. hier (Rettung der Shelly kWh Daten) weiter.

Gruß
Frank

1 „Gefällt mir“

Das gefällt mir super. Würde ich zumindest auch neben dem Energie Dashboard ein weiteres für den Strom aufziehen. Bei meinem Phev Auto habe ich das schon eingerichtet.

Ist es auch möglich mehrere Entitäten in einem Helfer einfach zu summieren? Würde ich dann mit meinen Steckdosen machen bspw. Einen einzigen Verbrauchszähler im Sicherungskasten bin ich noch am überlegen, sowas wie ein Shelly einzubauen

2023-05-02 19_23_39-Übersicht – Home Assistant – Mozilla Firefox

@Soul

so summiere ich meinen Shelly 3EM.
Gruß
Frank

template:
  - sensor: # Zusammenfassung der Gesamtleistung Shelly 3EM L1+L2+L3
    - name: "Gesamtleistung"
      unique_id: "Total_Energy"
      device_class: power
      state_class: total
      unit_of_measurement: "W"
      state: >
        {{ 
        states('sensor.phase_l1_power')| float(0) + 
        states('sensor.phase_l2_power')| float(0) +
        states('sensor.phase_l3_power')| float(0) 
        }}
        
  - sensor: # Zusammenfassung des Gesamtverbrauchs Shelly 3EM L1+L2+L3
    - name: "Gesamt Energieverbrauch"
      unique_id: "Total_Energy_Use"
      device_class: energy
      state_class: total
      unit_of_measurement: "kWh"
      state: >
        {{ 
        states('sensor.phase_l1_energy')| float(0) + 
        states('sensor.phase_l2_energy')| float(0) +
        states('sensor.phase_l3_energy')| float(0) 
        }}
1 „Gefällt mir“

Danke habe ich nun auch integriert mit einer Summe angelegt und zusätzlich Utility Meter Helfer für die Intervalle. Komischerweise ist täglich höher als der Rest oder muss sich das erst einpendeln? Zurücksetzen ist überall aus bzw. muss das überhaupt eingeschaltet werden?

2023-05-02 21_13_32-Übersicht – Home Assistant – Mozilla Firefox

zeigt mal Deinen Code für die Utility Meter.
Dann schau mal oben meinen Post und das Problem mit den Utility Meter. Und zeige in Deinem Screenshot mal die Entitäten an. Womöglich ist da auch was nicht korrekt.

Das pendelt sich gerade wohl ein, weil die Sensoren erst alle gestern von mir angelegt wurden. Ich teste erst mal weiter rum und morgen kommen meine Zigbee Steckdosen, dann kommen die großen Abnehmer mit dran.

Ich denke, Du hast da noch einen Bock in der Konfig. Täglich würde ich erst mal als Heute benennen. Ab 0 Uhr wird das dann auf Woche, Monat, Jahr in Deinem Fall aufsummiert.

Klar kann heute höher als der Rest sein, denn es ist ja der Verbrauch eben heute gesehen.

Aber… ich könnte mir vorstellen, dass im utility_meter jährlich als period weekly drinsteht und deshalb der Wert gleich ist.

1 „Gefällt mir“

Lege gerade div. Zigbee Steckdosen an und bin gerade dabei alles einzurichten. Sollte aber so passen. Dafür lege ich mir jeweils Helfer an

  • täglich
  • wöchentlich
  • monatlich
  • jährlich

Reset mache ich dann monatlich. Die Aufzeichnung für Jährlich bleibt ja dann trotzdem bestehen oder? Dann kann ich für jeden Helfer eine eigene Statistik führen.

Man setzt doch immer die aktuelle _energie der Sensoren ein oder müssen das auch die von den Helfern sein, also Helfer mit täglich?

template:
  - sensor: # Zusammenfassung des Gesamtverbrauchs
    - name: "Gesamt Energieverbrauch"
      unique_id: "Total_Energy_Use"
      device_class: energy
      state_class: total
      unit_of_measurement: "kWh"
      state: >
        {{ 
        states('sensor.autoladegerat_energie')| float(0) + 
        states('sensor.backofen_energy')| float(0) +
        states('sensor.gefriertruhe_energy')| float(0) +
        states('sensor.kuhlschrank_energy')| float(0) + 
        states('sensor.nas_ha_laptop_energy')| float(0) +         
        states('sensor.pc_daniel_energy')| float(0) + 
        states('sensor.pc_nick_energy')| float(0) +
        states('sensor.pc_phil_energy')| float(0) +
        states('sensor.spulmaschine_energy')| float(0) +
        states('sensor.trockner_energy')| float(0) +
        states('sensor.tv_schlafzimmer_energy')| float(0) +
        states('sensor.waschmaschine_energy')| float(0) +
        states('sensor.waschmaschine_energy')| float(0) +
        states('sensor.router_tv_wohnzimmer_energy')| float(0) 
        }}


@frittes müssen die Helfer immer Zurückgesetzt werden für jeden Status, also täglich, monatlich usw.?

Moin, weiß niemand ob man die Utility Meter Helfer nun zurücksetzen muss oder nicht? Steh gerade echt auf den Schlauch

Bezüglich der fehlerhaften Berechnungen habe ich noch etwas interessantes gefunden

Wenn ich das nun richtig interpretiere, kann es sein, wenn der Sensor, die Daten verdoppelt, weil der State noch nicht verfügbar ist.

Hat jemand schon mal mit dem Code was gemacht?

availability_template: "{{ states('sensor.total_yield') not in ['unavailable', 'unknown', 'none'] }}"

Nein, müssen sie nicht. Wenn Du cycle setzt geht das automatisch.

EDITH:

Ich mache das so (yaml).

Integration Sensor:

Die source ist Watt.

- platform: integration
  source: sensor.sensor_schalter_lastenrad_power
  name: Lastenrad
  unit_prefix: k
  method: left
  round: 2

Dann utility_meter:

power_lastenrad_monthly:
  unique_id: "Lastenrad Monat"
  source: sensor.lastenrad
  cycle: monthly

Oder halt yearly oder daily oder bis zu viertelstündlich runter.

P.S.: Du rechnest die Waschmaschine 2x drauf in Deiner Config.

1 „Gefällt mir“

Danke, dass mit der Waschmaschine hatte ich auch schon gefunden und angepasst.

Der Sensor der Waschmaschine dreht aber durch. Zeigte kürzlich 362000 kWh an :joy: vielleicht war es in Watt oder weißt nicht. Die Summe im Stecker passte aber immer selbst.

Ich rechne jetzt jetzt mit Integral und Utility Meter einfach die W zusammen und bis jetzt passt es.

Die Nous Plugs melden alle 5 Sek die currenr Power aber nur alle 5 Minuten die kWh Summe. Ka ob es was damit zu tun hat. Gibt auf jeden Fall ein paar Meldung dazu im GitHub usw

Ich nutze nur die Watt-Angaben der Aktoren, den Rest berechne ich bei allen im HA. Wäre auch eine Option.

Sie oben schon einmal von mir beschrieben hat der „utility meter“ das Problem, dass er, so von mir beobachtet, nach einem HA reboot gerne einmal nicht die Differenz des Vorwertes zum jetzigen ermittelt und hinzuaddiert, sondern den kompletten aktuellen Wert.
Beispiel:
Der aktuelle Wet des Sensors ist 25kWh
der Tageswert ist 2kWh

nach dem Reboot sollte sich der Tageswert eigentlich nicht verändert haben, aber plötzlich ist der Tageswert 27kWh und nach einem weiteren Reboot 52kWh.
Es kommt aber nicht immer vor, kann aber passieren. Richtig wäre es gewesen nach dem Reboot einen Tageswert von 2kW zu haben und wenn dann der Sensor auf 25,1kWh steigt sollte auch der Tageswert von 2kWh auf 2,1kWh steigen.
Ich denke, dass der „Utility Meter“ sich, wenn es blöd läuft, heftig verschlucken kann. Am Anfang meiner HA Zeit mit vielen KonfigAnpassungen und Reboots ist mir das oft passiert. Aktuell passiert es nur noch sehr selten. Was mir auch geholfen hat war die Nutzung nur die YAML Dateien neu zu laden, die ich verändert hatte.
ansonsten bleibt nichts anderes übrig als die „Utility Meter“ manuell zu korrigieren.

Was das „availability_template“ bewirkt ist mir noch nicht klar.

1 „Gefällt mir“

Ja, so ist es mir auch aufgefallen. Also viele Reboots zerhauen dir einfach die Werte , sollte aber eigentlich nicht so sein. Weiß nicht ob man das umgehen kann, bspw anders Triggern oder so aber schon sehr lästig. Für mich dann auch eher ein Bug vom Utility_meter.

Momentan läuft es mit den berechneten Watt-Werten besser, die werden auch alle 5 Sek aus den Plugs angefragt und seitdem habe ich keinen ausreisser mehr.

Mit dem „availability_template“ soll man wohl abfragen können, ob der Plug in dem Moment überhaupt einen Wert oder Zahl ausgibt, wenn bspw. NULL oder unavailable sollen die Werten unverändert bleiben bzw. nicht verfälscht werden. Hat bei mir aber eh nicht funktioniert

1 „Gefällt mir“

Ab jetzt reine Vermutung und Spekulation

Ich gehe davon aus, dass HA sequentiell startet und arbeitet.
Darum habe ich, wie man es natürlich nicht unbedingt machen sollte, 2 Änderungen vorgenommen und dadurch die Zuverlässigkeit erhöht.
Ich habe die Utility-Meter, die ich schon immer in einer eigenen yaml ausgelagert hatte in meine configuration.yaml als absolut letztes eingebunden. So sollte alle anderen Sensoren, auf die ich im Utility-Meter zugreifen könnte schon initialisiert und da sein.
Dann habe ich auch die Utility-Meter an Sensoren angebunden die ich selber erstelle oder erstellt habe.
—> seitdem habe ich nicht mehr manuell korrigieren müssen.

Meine Vermutung:
Wenn nach einem Reboot der Ausgangssensor, der im Utility-Meter verwendet wird noch nicht existiert oder saubere Werte liefert, dann setzt der Utility-Meter eventuell den Startwert auf 0. Sobald dann ein Wert geliefert wird berechnet der Utility-Meter die Differenz und addiert diese zu seinem eigenen Wert hinzu.
—> getestet habe ich diese Theorie aber nie.

unavailable template
Ich muss mir mal einen Sensor suchen der regelmäßig „unavailable“ liefert und darauf einen Sensor aufbauen um das man zu testen. Solch einen Sensor zu finde ist gar nicht so leicht :joy: Mein OpenDTU liefert in glaube solch einen sobald länger keine ableistend mehr fließt.

Claudius

1 „Gefällt mir“

Das klingt recht simpel und plausibel. Muss ich mal schauen, wie ich das mache. Habe bei mir alles von Anfang über Packages aufgebaut

homeassistant:
  packages: !include_dir_named packages

Spannend auch, mittlerweile soll ich sogar was einspeisen, was ich gar nicht kann :smiley:

1 „Gefällt mir“

Dann sollte das falsch konfiguriert sein. Wie sind die yaml-Configs?