Update Intervalle unregelmäßig

Hi Smarthomies :wink:
seit 1 Woche habe ich Home Assistant und auch schon das erste Problem entdeckt. Die Update Intervalle der Sensoren werden scheinbar per Zufallsgenerator gewählt. Mal alle paar Sekunden, manche Werte ändern sich stundenlang nicht. Unten habe ich Screenshots angehängt. Ich hoffe das Anhängen hat geklappt. Das eine ist ein Temperatursensor, der über Zigbee eingebunden ist. Das andere ist ein Zwischenstecker mit Tasmota-Firmware. Es ist eigentlich bei allen Geräten so. dahe sehe ich das Problem bei HA. Was meint ihr?

Beispiel1
Beispiel2

Herzlich willkommen hier im HA-Forum! :grinning:

Naja, ich denke das liegt an den Sensoren bzw. deren Einstellungen und nicht an HA.
Die meisten Sensoren schicken nur einen neuen Wert, wenn sich der Sensorwert auch verändert hat,
d.h. in Deinem Beispiel ändert sich die aktuelle Leistung alle 2 Minuten ("Meldeschwelle des Sensors), der Leistungswert von “gestern” ist ja statisch (da Vergangenheit) und ändert sich somit nicht (mehr).
Ähnlich ist das mit der Batterie oder anderen Werte ohne große/schnelle Änderungen.

1 „Gefällt mir“

Also der Temperatursensor( je nach Hersteller) senden nur in bestimmten Intervallen Daten um Batterie zu schonen. Außer ein Wert wie Temp oder Luftfeuchtigkeit ändern sich, dann wird auch gesendet.

Moin harryp, danke für deine schnelle Antwort. Was du sagst klingt logisch, aber so ganz überzeugt bin ich nicht. Bei meiner PV-Anlage ändert sich die aktuelle Leistung ständig. Das ist auf der Tasmota-Seite nachvollziehbar. Dort ändert sich der Wert alle ~2 Sekunden. Jetzt gerade ist diese Wert in HA 10 Minuten alt. Das ist für eine PV eigentlich inakzeptabel. Vorhin habe ich meinen Drucker integriert. Er hat den Status “untätig”. Inzwischen habe ich etwas gedruckt, was HA überhaupt nicht registriert hat. Auch im Log finde ich keinen Eintrag. Die Toner-Füllstände zeigt HA aber korrekt an.

Da HA nicht abfragt, sondern Tasmota die Werte sendet, habe ich eben kurz gegoogelt und die Option PowerDelta gefunden. Wenn ich die auf 50 setze, geht in HA die Post ab, dann bleibt die Aktualisierungsrate bei 1 Sekunde stehen. Da werde ich noch ein wenig experimentieren müssen, um den idealen Wert zu finden.
Zur Info zitiere ich mal die Fundstelle.
“Powerdelta 50” bedeutet: "Sobald der Leistungswert 50% größer oder kleiner wird, wird der aktuelle Wert getriggert ".

@meins57: Auch dir danke für die Antwort/Unterstützung.

Nachtrag:
Ok, einen habe ich noch für die, die ein ähnliches Problem haben. Mit dem Befehl “Teleperiod” auf der Tasmota-Konsole kann ich die Sendezeit ändern.
Teleperiod 10 bedeutet, dass das gerät alle 10 Sekunden sendet.
Tschö! (Bis zum nächsten Problem :wink:)

:crayon:by HarryP: Zusammenfassung Doppelpost.
*@andrehamburg *
Bitte für Nachträge/Korrekturen die “bearbeiten” Funktion (geht 24h) benutzen. Danke!

1 „Gefällt mir“

Ich hänge mich hier mit ähnlichem Problem an. Bei mir ist es so, dass meine Feuchtigkeitssensoren (Netatmo, Gardena) teilweise über Stunden nicht in HA aktualisert werden. Sehe ich in der App nach, liegt die letzte Aktualisierung dort teils nur 30 Minuten zurück.

Bisher. habe ich für die Sensoren in HA keine Option gefunden, bei welcher das Update-Intervall für die Werte definiert werden kann. Jemand eine Idee?

Nachtrag: Ich musste die Gardena-Integration via HACS aktualisieren, dann ging es wieder.