Sudo Befehl im SSH Terminal gibt Fehler aus

Hallo Zusammen,

in meinem Home Assistan hab ich das Advanced SSH & Web-Terminal installiert.
Im Terminal besitze ich root rechte und somit sollte ich den Befehl ausführen können.
Bei der eingabe des Befehles:

sudo apt-get update && sudo apt-get upgrade -y
gibt die Fehlermeldung aus:

command not found

Bei meinen Recherchen hab ich keine Antwort dazu gefunden.
Ist dieser Befehl am Raspberry PI und Home Assistant notwendig, um Linux
auf den neusten Stand zu bringen?

Gruß

hquer

Hast du HA direkt auf dem Raspberry laufen? Dann brauchst du die Befehle nicht. Updates kannst du über das UI einspielen.

Wenn ich mich nicht irre, basiert HA auf Python.

Ich gehe mal davon aus, dass du HAOS installiert hast. Da werden Updates über HA in der GUI, oder die CLI mit dem Terminal Addon installiert.

ha os update
1 „Gefällt mir“

Hallo,

ja, ich hab HA direkt am Raspberry laufen.
Vielen Dank für euere Rückmeldungen.
Offen gesagt, hab ich im Moment noch etwas Probleme
immer den Zusammenhang zu finden, da ich oft den
Eindruck hab, dass viele Infos weggelassen oder
vorausgesetz werden was zu Missverständnissen führt.

Danke.
hquer

1 „Gefällt mir“

Wenn man auf der Kommandozeile Dinge ausführt sollte man wissen, was man dort tut. Stimmt. :wink:

Wenn du auf deinem Raspberry Pi mi HAOS irgendwas anderes installieren, ausfuehren, basteln oder tinkern willst. Lass es sein.
Besorg dir eine zweite Himbeere oder besser ein alten PC benutze den fuer HA. Dann kannst du mit der Himbeere spielen.

1 „Gefällt mir“

Ich habe das Thema hier mal wieder hochgezogen, da ich gerade mit einem ähnlichen Fehler kämpfe:

Seit 10/2023 wurden die Dateien von Node-Red in ein separates Verzeichnis ausgelagert und meine automatische Kontrolle der Flows auf fehlende Entitäten mit Watchman funktioniert somit nicht mehr automatisch.

Über den SMB-Zugang an meinem MacBook muss ich jetzt jedesmal die Datei:
“flows.json” von “addon_configs/a0d7b954_nodered” nach “config” kopieren, damit watchman wieder funktioniert.

Ich habe mir jetzt dazu einen Node-Red-Flow gebastelt, der immer nach einem “deploy” dies mit “sudo cp /addon_configs/a0d7b954_nodered/flows.json /config/”
automatisch machen soll.

Leider bekomme ich in Nodered diese


und auch im Terminal folgende Fehlermeldung:

Hat jemand eine Idee, wo der Fehler, neben dem vorm Bildschirm :grimacing: , liegen könnte?

HAOS kennt den Befehl sudo nicht.
Ich würde es im ersten schritt einfach ohne sudo probieren.

Danke, das wars (ohne “sudo” funktioniert es)! :grinning: