Hallo, ich hab meinen SLZB-06M von Energieversorgung über USB und Normaler Ethernet-Verbindung auf POE umgestellt. Ich kann über die IP-Adresse ganz normal auf die Weboberfläche zugreifen, jedoch in HA baut er die Verbindung nicht mehr auf.
In der Weboberfläche ist der einzige Unterschied den ich sehe, dass mit Stromversorgung über USB der Socket verbunden ist und bei POE nicht. Wenn ich zurückwechsle funktioniert auch alles ganz normal.
In der Oberfläche deines SLZB-06M steht was du in Zigbee2MQTT oder ZHA eintragen musst. Vermutlich versuchst du dich noch über USB zu verbinden du müsstest aber nun in Port sowas eintragen ”tcp://192.168.8.51:6638” natürlich mit deiner IP-Adresse und dem Port der in der Oberfläche angezeigt wird.
Ich hatte vorher schon Verbindung über Ethernet aktiviert. Der Usb hing an einer Steckdose deswegen denke ich würde die Verbindung darüber sowieso nicht funktionieren oder?
Auf alle Fälle hab ich auch nochmal IP, Port, adapter usw. kopiert und in HA eingefügt. Ich denke das hat sich aber nicht geändert.
Hast du den SLZB mal vom Strom getrennt und wieder angeschlossen?
Ich hatte das Problem das nach einem Firmware Update des SLZB ZHA den Adapter nicht mehr gefunden hatte. IP + Port hatten gepasst es kam trotzdem zu einer Fehlermeldung.Ping hat auch funktioniert.
Nachdem ich den SLZB einmal vom Strom genommen hatte und wieder gestartet hatte, hat er dann wieder in ZHA funktioniert. (mit den identischen Einstellungen von zuvor)
Alles andere hatte nicht funktioniert (alte Firmware zurück flashen, ZHA x mal neu gestartet, Reboot HA)
Hier mal ein Hinweis. Wenn Du vorher das ganze über USB laufen hattest und jetzt mit den Einstellungen in dem Verzeichnis zigbee2mqqtt, dort in der configuration.yaml das drin stehen hast kann das nicht funktionieren. Es sollte die Einstellung aus Deiner Weboberfläche unter Z2M und ZHA in etwa so aussehen:
# Pay attention, if you use the Z2M addon for HA, it is better to edit Z2M addon yaml configuration file directly (Select the 3 dot menu in the upper right corner → "Edit in YAML")
serial:
# Location of SLZB-06
port: tcp://192.168.1.100:6638
baudrate: 115200
adapter: zstack
# Disable green led?
disable_led: false
# Set output power to max 20
advanced:
transmit_power: 20
Das ist in meinem Testsystem, also direkt die configuration.yaml ansehen ob da die richtigen Daten drin stehen und in Konfiguration von Z2M in gui sollte nichts drin stehen.
und daher müssen bei der Z2M configuration.yaml auch keine Änderungen vorgenommen werden.
Abgesehen davon hat @patto11 hier bisher gar nicht angegeben ob er Z2M oder ZHA nutzt und
das sind die Einstellungen für Z2M und nicht auch für ZHA. Bei ZHA wäre es z.B.:
Radio Type: EZSP
socket://slzb-06.local:6638
@patto11 Verrat erst einmal ob Du Z2M oder ZHA nutzt und dann poste hier mal einen Screenshot von der SLZB-06M Dashboard-Ansicht des WebGUI, wenn der SLZB-06M per PoE angeschlossen ist. Das Du den HA Host neu booten solltest
Leider hast Du bei dem ersten Screenshot den Part etwas “abgeschnitten” der mich am meisten interessiert hätte, nämlich den:
Aber wenn Z2M keine Verbindung aufbaut dürfte darin auch nicht mehr stehen als man jetzt bei Dir sehen kann. Edit: Und in dem zweiten Screenshot steht bei Socket verbunden ja auch ein nein.
Gut jetzt wäre schon mal geklärt das Du Z2M nutzt und da wäre dann als nächstes natürlich das HA Z2M Protokoll von Interesse. Das solltest Du hier mal per
posten und zwar ab dem Startversuch von Z2M der dann z.B. so beginnt.
[11:38:24] INFO: Preparing to start...
[11:38:25] INFO: Socat not enabled
Edit: Poste hier bitte auch noch zusätzlich den Inhalt der Z2M configuration.yaml (/homeassistant/zigbee2mqtt/configuration.yaml) und denn dann auch wieder als Code.
[13:31:10] INFO: Preparing to start...
[13:31:10] INFO: Socat not enabled
[13:31:11] INFO: Starting Zigbee2MQTT...
Starting Zigbee2MQTT without watchdog.
[2025-10-26 13:31:18] error: zh:ember:uart:ash: Failed to init port with error Error: connect EHOSTUNREACH 192.168.68.63:6638
[2025-10-26 13:31:18] error: z2m: Error while starting zigbee-herdsman
[2025-10-26 13:31:18] error: z2m: Failed to start zigbee-herdsman
[2025-10-26 13:31:18] error: z2m: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start_crashes-runtime.html for possible solutions
[2025-10-26 13:31:18] error: z2m: Exiting...
[2025-10-26 13:31:18] error: z2m: Error: Failed to start EZSP layer with status=HOST_FATAL_ERROR.
at EmberAdapter.initEzsp (/app/node_modules/.pnpm/zigbee-herdsman@6.1.5/node_modules/zigbee-herdsman/src/adapter/ember/adapter/emberAdapter.ts:665:19)
at processTicksAndRejections (node:internal/process/task_queues:105:5)
at EmberAdapter.start (/app/node_modules/.pnpm/zigbee-herdsman@6.1.5/node_modules/zigbee-herdsman/src/adapter/ember/adapter/emberAdapter.ts:1547:24)
at Controller.start (/app/node_modules/.pnpm/zigbee-herdsman@6.1.5/node_modules/zigbee-herdsman/src/controller/controller.ts:133:29)
at Zigbee.start (/app/lib/zigbee.ts:67:27)
at Controller.start (/app/lib/controller.ts:101:13)
at start (/app/index.js:149:5)
Ansonsten wie von @petrel schon erwähnt, das Ding mal 10 Sek. stromlos machen. Lankabel raus, warten, wieder rein. Gerade nach Updates (HA und SLZB) spacken die gerne mal rum.
Dazu wollte ich gerade auch schon etwas schreiben, denn man sieht in den Screenshot 2 bei DNS zwei unterschiedliche IP-Bereiche. Einmal 192.168.68.x und einmal 192.168.1.x. Arbeitest Du da ggf. mit VLANs oder so?
Das kann so eigentlich nicht sein, es sei denn Du würdest da mit irgendwelchen Router-Kaskaden und/oder VLANs arbeiten. Ansonsten sollten sich die Geräte alle im gleichen IP-Bereich befinden. Die Fehlermeldung
Error: connect EHOSTUNREACH 192.168.68.63:6638
sagt ja das der Dongle über die IP scheinbar nicht zu ereichen ist. D.h. Deinen LAN-Aufbau und die IP-Vergaben, solltest Du noch einmal genau überprüfen. Es sei denn der SLZB-06M hätte vorher auch schon an dem gleichen Switch gehangen, nur das er jetzt über den noch per PoE mit Strom versorgt wird?
Oder auch ganz einfach hier mal angeben welche IPs die Geräte haben:
Der Client mit dem das WebGUI des SLZB-06M aufgerufen wurde.
Die IP von dem HA Host.
und eben auch ob der SLZB-06M vorher auch die IP 192.168.68.63 hatte und am gleich Switch angeschlossen war.
Wenn da zwei Router mit unterschiedlichen IP-Bereichen im Spiel sind geht das nur per Router-Kaskade und/oder VLANs. Wobei ich da eher auf eine Router-Kaskade tippe.
auch als YAML anzeigen lassen kannst, sondern den Inhalt der Datei die Du unter /homeassistant/zigbee2mqtt/configuration.yaml finden kannst.
Edit: Also dort (Bsp.).
Ich hab jetzt nochmal ein wenig rumgespielt. Stromversorgung mit USB und Lan direkt an Router und die Verbindung ist sofort wieder da. Folgend auch nochmal der Screenshot davon.
Wenn ich den Lan Kabel in den Switch stecke ist die Verbindung weg.
Der Switch ist neu, vorher hatte ich einen nicht POE fähigen Switch. Die Kabel sind aber alle identisch. Ich gehe mal davon aus, dass der Switch irgendwie die Verbindung “stört”.
D.h. der Client mit dem Du das WebGUI des SLZB-06M aufgerufen hast, der HA Host und auch der SLZB-06M, hängen jetzt alle an dem gleichen, neuen PoE-Switch?
Bei der Z2M Konfiguration erkenne ich nichts was irgendwie falsch sein, oder man anders machen könnte und die Fehlermeldung
sagt ja auch das es eher ein grundsätzliches Verbindungsproblem zu dem SLZB-06M gibt. Die Frage ist nur welches.
Edit: Da
passt aber irgendetwas nicht. Ich hatte nach der IP gefragt von dem Client (PC) von dem aus Du das WebGUI des SLZB-06M aufgerufen hast. Die http://192.168.68.63 ist aber die IP von dem SLZB-06M. Daher bitte auch die hier angeben. Nicht das die dann ggf. im IP-Bereich 192.168.1.xxx liegt.
Edit 2: Da ich jetzt auch gleich weg muss und falls auch die IP des Clients, mit dem Du das WebGUI des SLZB-06M aufgerufen hast, im IP-Bereich 192.168.68.xxx liegen sollte, dann habe ich im Moment leider auch keine Idee mehr. Eigentlich sind wir hier so ziemlich alle möglichen Fehlerquellen durchgegangen und warum dann Z2M scheinbar keine Verbindung zu dem Dongle über die IP 192.168.68.63:6638 aufbauen kann, wüsste ich im Moment dann leider auch nicht.