Shelly Plus H&T meldet über Websocket nicht mehr an HA (DuckDNS)

Hallo Leute,

ich bin noch ziemlicher frischling im HA.

Heute hatte ich nach Simon's Anleitung bei Youtube den externen Zugriff mittels DuckDNS eingerichtet.

Das funktioniert prima bisher.

Nur meine ganzen 3 Shelly's Plus H&T die vorher über Websocket zuverlässig sich meldeten sind jetzt nicht mehr verfügbar in HA.

Gegoogelt hab ich schon aber außer einen Hinweis umzustellen von:

ws://192.168.178:8123/api/shelly/ws

nach

wss://192.168.178:8123/api/shelly/ws

funktionierte nicht.

Auch den Domainnamen von DuckDNS einzusetzen ging nicht...

wss://UnsereDomain.duckdns.org:8123/api/shelly/ws

(wss und ws)

Hat jemand vielleicht eine Lösung?

Gruß Thomas

Hi Kathmai, vielleicht bring hier mein Nginx-Video Abhilfe, da HA dann lokal unverändert aufzurufen ist und nur von Extern über DuckDNS und https.

https://youtu.be/UZozmfh8QY8

Alternativ könntest du noch bis Januar warte, da kommt noch ein anderes Video zum Fernzugriff raus, der an den Lokalen Gegebenheiten überhaupt nichts verändert 👍

Hey Simon,

ja danke ich werds mal auf diesen Wege versuchen. Backup zurückspielen und dann mit deinem Video versuchen. Bevor die Shelly Plus H&T nicht funktionieren verzichte ich lieber auf den externen Zugriff...

Hallo,

kurze Rückmeldung. Ich hab dein Video befolgt. Kam aber immer eine Fehlermeldung über extern mit der Meldung SSL Handshake fehlgeschlagen...

Hab jetzt das Backup vor DuckDNS zurückgespielt und jetzt funktioniert es wieder wie zuvor.

Ich warte auf dein Video ohne Portweiterleitung.

Gruß kathmai

Morgen, könnte es eventuell sein das du kein Port forwarding für 80/443 auf deinem Router eingerichtet hast? (NAT). es besteht die Möglichkeit das du zwar raus kommst aber dein Router durch das NAT nicht mehr rein. Das Problem besteht öfters bei Lets Encrypt.