Probleme mit Kostal Plenticore Solar Inverter - Anmeldung funktioniert nicht

Hallo zusammen,

ich habe mir schon diverse YT-Videos und Foreneinträge zur Einrichtung der Integration angesehen. Aber ich scheitere an der Verbindung.
Wenn ich die Integration laden will und der Host und Pw eingeben werden soll, kommen immer Fehlermeldungen (Keine Authentifizierung oder Verbindung fehlgeschlagen. Ich habe schon alle möglichne Varianten ausprobiert
(nur Ip mit http/https, IP+port, URL vom “scb” wie im YT-Video gezeigt).
Habe in der config.yaml auch den Mobus-Eintrag für das KSEM eingefügt.
Nichts geht, ich verzweifele.

Im Log wird neuerdings folgender Fehler angezeigt:

Logger: homeassistant.components.kostal_plenticore.config_flow
Source: components/kostal_plenticore/config_flow.py:57
Integration: Kostal Plenticore Solar Inverter (documentation, issues)
First occurred: 12:13:13 (2 occurrences)
Last logged: 12:13:27

Error response: API Error: Invalid user/Authentication failed ([400] - authentication failed)

Die Anlage ist von 2021, plenticore plus 8.5, KSEM (HW0100), BYD Speicher HVS

Kann mir jemand noch einen Tipp geben?

Gruß Sascha

Es tut mir leid zu hören, dass Sie Schwierigkeiten haben, Ihren Kostal Plenticore Wechselrichter mit Home Assistant zu verbinden. Es gibt ein paar Dinge, die Sie überprüfen könnten, um das Problem zu lösen:

  1. Überprüfen Sie die Anmeldedaten: Stellen Sie sicher, dass Sie die korrekten Benutzername und Passwort für die Kostal Plenticore Weboberfläche verwenden. Normalerweise ist der Benutzername “user”, es sei denn, Sie haben ihn geändert. Das Passwort ist das, was Sie während der Inbetriebnahme des Wechselrichters festgelegt haben. Wenn Sie sich nicht sicher sind, können Sie versuchen, sich direkt auf der Weboberfläche des Wechselrichters anzumelden, um sicherzustellen, dass die Anmeldedaten korrekt sind.

  2. Überprüfen Sie die IP-Adresse und den Port: Stellen Sie sicher, dass Sie die korrekte IP-Adresse des Wechselrichters eingeben und dass der Wechselrichter erreichbar ist. Der Port sollte 80 sein, wenn Sie HTTP verwenden, und 443, wenn Sie HTTPS verwenden.

  3. Firmware-Version: Stellen Sie sicher, dass die Firmware des Wechselrichters auf dem neuesten Stand ist. Ältere Firmware-Versionen könnten Probleme mit der Authentifizierung verursachen.

  4. Home Assistant-Version: Stellen Sie sicher, dass Ihre Home Assistant-Installation auf dem neuesten Stand ist. Updates beheben oft bekannte Probleme und fügen Unterstützung für neue Funktionen hinzu.

  5. Verwendung des richtigen Integrationsmoduls: Es scheint, dass Sie das Kostal Plenticore Modul verwenden. Stellen Sie sicher, dass Sie die Anweisungen in der Dokumentation genau befolgt haben.

Wenn all diese Schritte nicht helfen, könnte es ein spezifisches Problem mit Ihrem Wechselrichter oder Ihrer Home Assistant-Installation geben, das weiterer Untersuchung bedarf. In diesem Fall empfehle ich Ihnen, ein Issue im Home Assistant GitHub Repository zu erstellen oder um Hilfe in der Home Assistant Community zu bitten. Geben Sie so viele Details wie möglich an, einschließlich der genauen Fehlermeldung, die Sie erhalten, und der Schritte, die Sie bereits unternommen haben, um das Problem zu lösen.

Hallo und Danke für die Rückmeldung.
Nach erneutem Lesen der Doku des Wechselrichters und des KSEM-Moduls funktioniert die Anbindung nun fehlerfrei.

Gruß Sascha

Was war dann jetzt der Fehler, ich habe das gleich Problem!?