Nachricht bei Netzausfall!

Ich habe eine PV Anlage mit Speicher der bei Netzausfall innerhalb von zehntelsekunden auf Akkubetrieb umschaltet. Ich möchte daher vom HA eine Nachricht erhalten sobald dieser Zustand eintritt. Die Automation sendet aber auch dann die Nachricht wenn HA neu gestartet wird. Wie kann ich dies unterbinden? Ich möchte die Nachricht wirklich nur dann erhalten wenn das Nezt ausfällt und das Haus vom Akku versorgt wird. Danke schon mal im Voraus.

Moin,
könntest du vielleicht den yaml Code der Automation posten damit wir gucken können wo der Fehler liegt.

LG
Tobi

Hallo! Danke für die Rückmeldung. Bin leider nicht der YAML Typ. Habs nur mit dem visuellen Editor versucht. Funzt leider auch nicht mit einer 2minütigen Verzögerung. Aber hier der Yamlcode:

alias: Netzausfall
description: ""
trigger:
  - platform: state
    entity_id:
      - sensor.sofar_status
    id: "1"
    for:
      hours: 0
      minutes: 2
      seconds: 0
condition: []
action:
  - service: telegram_bot.send_message
    data:
      message: NETZAUSFALL !!
mode: single

:crayon:by HarryP: Codezeilen formatiert (bitte immer in </> einbinden)

Du hast angegeben, dass du benachrichtigt werden willst, wenn der Zustand sich ändert…egal wie. Du solltest das bei Zustand noch genauer definieren mit von und zu.

das ändert leider auch nix. ich krieg die entsprechenden Zustände nicht angezeigt.

Du weist also nicht was der Sensor anzeigt wenn Netzausfall ist?
Du könntest noch eine Bedingung / Condition einbauen.

alias: Netzausfall
description: ""
trigger:
  - platform: state
    entity_id:
      - sensor.sofar_status
    id: "1"
    for:
      hours: 0
      minutes: 2
      seconds: 0
condition:
  - condition: not
    conditions:
      - condition: state
        entity_id: sensor.sofar_status
        state: ""
action:
  - service: telegram_bot.send_message
    data:
      message: NETZAUSFALL !!
mode: single

Und bei state: muss dann noch der normale Status rein, den er immer anzeigt, damit er bei dem nicht mehr auslöst.

LG
Tobi

funktioniert leider auch nicht. Die Nachricht kommt trotzdem bei Neustart des HA.
Aber Danke schon mal für die Unterstützung.

Nachtrag:

Doch es funktioniert. Man sollte den Status doch richtig schreiben (Groß - Kleinschreibung)
Danke für die Hilfe!

:crayon:by HarryP: Zusammenführung Doppelpost