Mqtt erkennt Wechselrichter nicht openDTU

Hallo Forum
Ich habe mit Tialk versucht mein Balkonkartwerk einzubinden, wir kriegen es nicht hin :frowning:

Einstellungen in openDTU und HA Mqtt sollten alle richtig sein, der Wechselrichter wird nicht als Gerät erkannt :sleepy:

Mit dem Addon Mqtt Explorer sind aber alle Werte da, also sollte die Verbindung richtig sein, nur werden keine neuen Geräte angelegt …

Kann bitte mal jemand erklären was zu tun ist - bitte recht einfach erklären, bin Anfänger ! oder besser noch per Whatsapp oder so, selbst diese Boardsoftware scheint mich zu überfordern :frowning:

Das sieht nicht so aus, als hättest du in den OpenDTU MQTT-Einstellungen “Home Assistant MQTT-Auto-Discovery aktivieren” aktiviert.

Auf Anhieb hatte es bei mir damals auch nicht geklappt. Nach einem Neustart von HA und einige Zeit später wurde es dann erkannt.

Alternativ kannst du dir auch eigene template Sensoren erstellen.

https://github.com/tbnobody/OpenDTU/blob/master/docs/MQTT_Topics.md

Das könnte dein Problem beschreiben.


Und das könnte dein Problem beheben, als Beispiel.

Guten Morgen z-master
Ja, das ist eingeschaltet, ich mache es mal aus und schaue mal ob sich etwas tut …
Wenn ich das deaktiviere verschwindet dann auch unten die Parameter mit dem Präfix Topic, bei Ma
rkus ist das eingeschaltet

Nachtrag:
Könnte es auch vielleicht was mit der unique_id zu tun haben :thinking:
Aber kein Plan wo ich das ändern - kontrollieren kann

device map (optional)

Information about the device this sensor is a part of to tie it into the device registry. Only works when unique_id is set. At least one of identifiers or connections must be present to identify the device

:crayon:by HarryP: Zusammenführung Doppelpost

@Heiko183 Das muss eingeschaltet sein, weil sonst keine Informationen an HA mitgegeben werden, anhand derer HA weiß, wie es die MQTT-Sensoren zusammenbauen/erstellen soll (automatisch). Zudem erwartet HA ein spezielles Präfix-Topic unter dem es nach Bauanleitungen guckt:

Okay, hatte es falsch verstanden, sorry.
Schalte es in der DTU nochmal ein, wenn sich nicht tut installiere ich mqtt nochmal neu, wenn dann nix ix mach ich den HA mal platt und halt nochmal komplett neu…

Der Hoymiles ist mal online

jetzt sind die Entitäten da :exploding_head:

Eigentlich habe ich nicht gemacht außer in der openDTU den Wechselrichter Name nochmal auf HM1500 geändert und in der openDTU bei mqtt das prafix Topic auf homeassistant/

Vielen Dank für die Hilfe

Mehr war ja auch nicht nötig. Hab ich doch geschrieben.

so ganz rund läuft es noch nicht

In der Karte auffem Dashboard vom Hoymiles verschwindet der Leistungswert alle halbe Minute ca.


In mqtt sind die Werte dann auch kurzzeitig weg, har vielleicht noch jemand Idee was das sein könnte ?


Danke
Heiko

:exploding_head: Danke, scheint nun durchweg konstant zu laufen

Hallo
Also Aussetzer habe ich keine mehr beobachten können, ins Logbuch wird aber fleißig rein geschrieben …, ist das normal ? ignorieren ?

Danke
Heiko