Local Tuya Integration - Gerät nicht verfügbar

Hallo zusammen!
Ich lese und verfolge viel von Simon, aber hier kommt mein erster Post - und das ist ein Problem (wer hätte das gedacht…).
Ich habe eine Infrarot Wandheizung installiert, die mit Tuya (und Sensoren und normaler Fernbedienung) steuerbar ist. Habe brav nach Anleitung ein Tuya Developer Projekt angelegt und über die IOS Smartlife-App das Gerät mit dem Cloudprojekt verknüpft - steht dort auch als “online” drin. Dann die LocalTuya-Integration installiert und mit den ents. Credentials installiert - soweot so gut. Bei “Add device” wird auch sofort meine Heizung mit IP-Adresse gefunden und angelegt… aber es ist “nicht verfügbar” :frowning:
Ich habe alternativ das Ganze nochmal (nach Rücksetzen aller Parts) die “Tuya Smart”-App verwendet; hier kommt beim “add device” in der Integration allerdings die Abfrsage nach den ganzen Datenpunkten (die ich nicht kenne bzw. nicht weiß, wie man die ermittelt und erfasst).
Alle mehrfach gemacht, neu gestartet etc. - keine Besserung.
Per App lässt sich das Teil prima bedienen, aber das war nicht der Plan.

Hat jemand eine Idee, wo ich ansetzen kann?
Habe (immer) die neueste Version von HA und auch HACS.
Vielen Dank vorab und Gruß aus Berlin!

Hallo nach Berlin !

gehts Dir da wie mir? das scheint mir fast identisch zu sein. Ich schaffe es auch nicht.

Schau mal obs das gleiche ist. ich habs auch schön bebildert. Mir konnte hier auch keiner helfen. Dann könnten Wir ne` Selbsthilfegruppe gründen :slight_smile:

PS. ich weis auch, dass es “ein switch” und ein “Temperatur Sensor” ist und habe es mit “generic Thermostat” eine HACS App probiert = auch gescheitert. In Tuya wird es angezeigt, direkt mit Name erkannt und IP. ich hab dann probiert es als “climate / binar sensor / teperature und switch” einzubinden. was ich geschafft habe ist, dass es eine Karte gibt wo mir jetzt " an / aus -zustand"! anzeigt. Aber schalten kann ich nicht, und den Temperatursensor konnt ich auch nicht auslesen. Ich denke lieber Hauptstadt-Freund wir müssten das per Code-Schnipsel integrieren, nur dazu fehlt mir graue Masse, obwohl es ja einfach gehalten ist, leider wie immer alles Englisch.

ich sitze nun schon 4 Tage dran, ich werd wohl über VM oder so mein Handy aufm PC simulieren und von den Apps alles steuern, denn HA ist für mich nicht einfacher sondern kompliziert nur noch alles, schöne neue welt.

grafik

Ein Zugewinn aber ist, dass ich mit meiner PC Installation das Streamdeck ansteuern kann, dass ist echt genial. Nur bei jedem PC start muss die VM im Hintergrund laufen, auch wieder blöd.

Dankeschön.

Die ganze Local Tuya Thematik ist wirklich ne Sache für sich.

Ich habe 6 Tuya Geräte darüber eingebunden von denen eines immer wieder Probleme macht.

Setup:

  • 3x Brilliant Deckenlampe
  • 1x Brillant Square Deckenlampe (Das Problemkind)
  • 2x Blitzwolf Steckdose

Die Steckdosen funktionieren seit mehr als 3 Jahren ohne Mucken.
Die ersten drei Brilliant Deckenlampen laufen mittlerweile auch problemlos über local Tuya.
Die Brilliant Square (Befindet sich durch eine offene Tür ca. 2 Meter neben einer der funktionierenden Brilliant Lampen) erscheint so alle Paar Tage als “nicht Verfügbar”.

Manchmal sehe ich das nur in den Logs und sie kommt selbst wieder rein, manchmal muss ich den Strom aus und wieder ein schalten (Lampen reboot), dann geht es wieder.

Was ich bisher gelernt habe:
Local Tuya reagiert extrem empfindlich darauf, wenn auf irgend einem anderen Gerät die Smartlife App aktiv ist. Sei es auf dem Handy oder (und das hat ewig gebraucht herauszufinden) auf der Alexa als Skill.
Seit ich den Skill von der quasselbüchse entfernt habe läuft alles bis auf das Problemkind super und ohne Störung.
Mit Skill auf Alexa hatte ich ebenfalls “nicht Verfügbar” Probleme beim Hinzufügen der Geräte mit local Tuya.

Also mein kleiner Beitrag:
Alle, und wirklich alle smart life Apps/Skills deaktivieren/beenden bevor Ihr etwas über local Tuya einbindet oder bedienen wollt.

1 „Gefällt mir“

Ja das stimmt, dass sagt aber Simon ausdrücklich in einem Video, daran liegt es jedenfalls bei mir nicht, ich schliesse Android smart life app immer sofort, wenn ich sie denne mal benutze, also wichtig evtl. noch, nicht nur “wegwischen” sondern komplett schliessen. LG Marco Ps. ja Tuya wird wohl auch nicht so gemocht in den HA Kreisen…

Vielleicht hilft euch das zu den Datenpunkten weiter: Electrical Product-Tuya IoT Development Platform-Tuya Developer

Ich denke ihr seid auch als Tuya Developer angemeldet. Da könnt ihr die Datenpunkte zu eurem Gerät auch auslesen:

links auf Cloud klicken, dann auf API Explorer. Dort dann links unter Device Control auf Query Properties.
Da kannst du dann die device_id eintragen und ganz unten auf submit request.
Nun sollten rechts Schnipsel wie

{
        "code": "cur_current",
        "custom_name": "",
        "dp_id": 18,
        "time": 1693880283998,
        "value": 0
      },

erscheinen, wo sich dann rauslesen lässt, dass der id Punkt 18 den cur_current anzeigt

Moin zusammen und super, dass sich jemand gemeldet hat - wenngleich nicht unbedingt mit einer Lösung, sondern nur als “Mitbetroffene” :wink:

Ich bin ein wenig weitergekommen und kann tatsächlich meine Infrarot-Wandheizung ein-/ausschalten und auch den Temperaturverlauf als Sensor anzeigen lassen :muscle:
So richtig weiß ich aber nicht warum :thinking:
Ich habe ein Gerät hinzugefügt (wunderbar) und habe es irgendwie (?) geschafft, 2 Entitäten hinzuzufügen (1x switch, 1x sensor mit aktueller Temperatur). Ich hoffe, ich schaffe es, hier einen Screenshot einfzufügen:


Ich verstehe es einfach nicht, weshalb ich 2x die Integration sehe und jeweils dazu genau EINE Entität. Sobald ich “Eintrag hinzufügen” drücke, wird die vorherige Entität gelöscht und ich muss sie neu konfigurieren. Hier das Bild dazu:

Ich kann auch nicht reproduzieren, wie ich mal zu 2 Einträgen gekommen bin. Ich vermute, dass mir hier HA-Basics fehlen - oder die Integration erlaubt nur 2 Zugriffe gleichzeitig. Ich hätte natürlich gern auch die Temperatur aktiv gesteuert, aber erstmal bin ich froh über dne ersten Schritt.

Wie können wir uns dem Ziel nähern?
Schönen Tag und Gruß aus Berlin!

U-P-D-A-T-E:

Ich hab nochmal alles gelöscht und das Gerät als “climate” eingefügt (hatte ich schonmal ohne Erfolg) - Tataaa! Jetzt geht’s wo wie ich wollte bzw. wie es z.B. auch von meinem Homematic Thermostat kenne. Mal sehen, ob ich da noch irgendwie eine Programmierung hinbekomme. Zumindest einen “countdown” gibts ja auch in der Smartlife-App.
Wenn ich irgendwie helfen kann (Ihr müsst nur sagen, welche Informationen ich hereaussuchen soll), bitte gerne :grinning:

ja, hab die device ID reinkopiert, dann kommt dann rechts das, wie übertrage ich das jetzt das ich dashboard die als Bsp. die " aktuelle Temperatur " also “temp_current”
angezeigt bekomme ? ( keine Erfahrungen mit den Codeschnipseln )

LG Marco und danke allen für die Hilfe !!!

Wenn du das Gerät neu koppelst und als climate hinzufügst, wirst du doch bestimmt nach den ganzen Datenpunkten gefragt. Jetzt weißt du, dass temp_set id 16 ist, upper_temp id 19, temp_current id 24, usw.

Bei mir kommt:

{
  "code": 28841002,
  "msg": "No permissions. Your subscription to cloud development plan has expired.",
  "success": false,
  "t": 1705268669295,
  "tid": "184b773fb32611ee8b9b4ef73d358bf3"
}

Was ist davon zu halten?

:crayon:by HarryP: Fettdruck entfernt und Codezeilen formatiert (bitte immer in </> einbinden)

Hi Leute,
ich bin normalerweise der “typische Leser” in Foren und versuche zu lernen und das Gewünschte irgendwie hinzubekommen - jetzt kommt’s mir fast komisch vor, dass ich es geschafft habe und ich - vielleicht - mal etwas zurückgeben kann :wink:
Also anhand der o.g. Screenshots glaube ich: Ihr fummelt an der falschen Stelle; sieht nach dem Tuya-Cloudprojekt im Dashboard aus. Ich hab da nach der Ersteinrichtung des Devices (mit Ausnahme Ermittlung und Festhalten der div. Credentials im Editor) nichts mehr gemacht. Alles danach in HA!
Ich versuche mal, es wieder zusammenzubekommen:
a) Account bei Tuya und Cloud-Projekteinrichten
b) Smartlife App (bei mir IOS) installieren (braucht auch einen Account!), Verbindung zum eigenen LAN und Gerät hinzufügen. Hier kann man testen, ob das betr. Endgerät per App bedienbar ist.
c) Dann (wie Simon schrieb): die App schließen!!!
d) in HA über HACS die Integration “Local Tuya” installieren (immer wieder mal neu starten :wink:)
d) Integration konfigurieren: dazu braucht man

  • Access-ID, -Access-Secret, -User-ID - den Wert “localtuya” so stehen lassen, speichern
    e) Bei Konfigurieren: Gerät hinzufügen. Beim ersten Versuch wurde der “local key” noch automatisch eingetrsagen, später musste ich den manuell erfassen (muss man sich aus dem Dashboard bei Tuya holen).
    f) ich habe “climate” als Typ angegeben. Dafür habe ich dass Gerät mit der FB eingeschaltet und dafür gesorgt, dass die aktuelle Temperatur (current) und die Zieltemperatur (Target) unterschiedlich sind. In dem folgenden Dialog (Datenpunkte) habe ich (erstmal nur) die Dropdownliste für “current” aufgeklappt und die Zeile ausgewählt, wo der angezeigte Wert der aktuellen Temp entspricht. Bei Target dasnn die Zeile, wo ich mit der FB eine Wunschtemp gewählt hatte.
    g) speichern und das wars :grinning:

:thinking: Oops… hab das gerade wg. der Diasloge nochmal gemacht - und alles ist weg :thinking:

Schaut mal, ob das soweit mit Euren Ansätzen matched. Ich muss erst mal selbst wieder rekonstruieren. Dann mache ich mal (evtl. aber erst morgen) von allen Schritten einen Screenshot.
Viel Erfolg!

U-P-D-A-T-E
**chts geht mehr :frowning: hab einfach dasselbe gemacht, wie zuvor beschrieben und nun bekomme ich wieder Meldung, die ich eingangs (als Grund für mein erstes Posting) bekam “Gerät nicht verfügbar”.

Oh je… “never change a running system” - wenn ich das jemals wieder hinbekomme, fasse ich das nicht mehr an

Hast du den Tuya Developer Account verlängert, wie im oberen Video gezeigt?

Habe ich versucht, leider ist es recht kompliziert.
Simons Video rennt. Mehr Infos wären sinnvoll.

1 „Gefällt mir“

Hello Friends!
I tried and tried, unlinked my device in Tuya Dev Center, relinked it again - nothing :frowning:
By accident I saw in the statistics of my - “unknown” - device, that HA gets and saved the values of current and target temperature! Wow - so there must be only a tiny missing somtething :thinking:
I looked at the entity state and there where no values for


thats where I marked the correct values yellow!
Then I again started the configuration within the integration and explicitely set all “optional” values like this:
Tuya-b
and then - tataaaa! - I got this:

Maybe this can help you too :muscle:

1 „Gefällt mir“

Ich habs nun eben auch über Testen der Einstellungen in der “climate-tuya-installation-des Thermostats” geschafft - nur wenn ich es ausschalte, kann ichs nicht wieder einschalten, das ist aber egal da eh der Automatikmodus des Thermostates läuft, so lasse ich es und hab sofort auch nen Backup gemacht. Ich bin nach der Anleitung der DPs Werten und der IDs also “value” oder " true/false " ect gegangen und habe etwas probiert. Läuft. Dankeschön nochmals allen Helfern hier, in meinem Fall hab ich die Einbindung nun geschafft.

MFG Marco

1 „Gefällt mir“

Habe ich versucht, leider ist es recht kompliziert.
Wer kann helfen?

Einfach irgendwas eingeben. Ist völlig egal

Das ist ja einfach, wenn es klappt?
Danke.

Hi,

ich habe inzwischen die Datenpunkte für mein Gerät auch erhalten.
Aber mir fehlt der Ansatz wo/wie ich die Eintragen muss.
Wenn ich die einzelnen Datenpunkte in der ersten Maske eingebe wird
in der nächsten Maske der Gerättyp abgefragt. Es ist ein Licht und das
gebe ich auch ein. Dann kommte eine Maske mit verschiedenen werden wo
als Auswahl überall die einzelnen Datenpunkte angezeigt werden. Aber alle
mit dem Wert -1.

Ich denke, da ist der Fehler und eigentlich sollte da dann der korrekte Wert
angezeigt werden, oder?

Vg,

Dirk