Fritzbox VPN WireGuard® und homeassistant WireGuard®

Das isses! Ich hab das übersehen, und falsch gedacht.
Danke!

Hallo zusammen,
ich benötige auch einmal Eure Hilfe. Ich habe seit ein paar Tagen DSL über Vodafone mit DS-Lite. Seitdem klappt der Fernzugriff mit DuckDns nicht mehr, da keine IP4-Adresse vorhanden ist.
Deswegen habe ich jetzt die hier beschriebene WireGurad-Variante ausprobiert, aber komm einfach nicht weiter. Wireguard läuft auf der Fritzbox und die VPN-Verbindung am Handy wird auch hergestellt.

In der HA-App auf dem Handy habe ich standardmäßig die http://homeassistant.local:8123 eingetragen, die über das WLAN auch läuft. Hat von Euch einer eine Idee woran es liegen könnte?

Hast du es mal mit http://IP-Adresse:8123 versucht?

Kommst du denn per remote auf deine eigene Fritzbox, also fritz.box? Oder wenigstens an die IP?
Kannst auch probieren, die IP:8123 aufzurufen.
Allerdings gibts noch einen Knackpunkt: Es gibt auch im Jahre 2023 noch Mobilprovider die kein IPv6 haben. Aber dein Wireguard hat ja Verbindung, daher schliesse ich das erstmal aus.

Danke für den Hinweis. Mit http://ip:8123 klappt es.

1 „Gefällt mir“

Hi, ich denke das Problem liegt wie bei mir am DS-Lite Zugang. Seit mein Provider auf IPv6 und DS-Lite umgestellt hat funktioniert der VPN Zugang nicht mehr. Ich hatte bislang IPsec und jetzt auch WireGuard ausprobiert. Damit komme ich aber nicht in mein Heimnetz und nicht auf mein Home Assistant. Wenn ich den Testlink von Fritz!Box aufrufe wird mit angezeigt, dass eine IPv6 und IPv4 funktioniert, aber eben nicht vom Telefon außerhalb meines Netzes. :frowning:

IPv6 ist bei Wireguard kein Problem, allerdings sollte das andere Ende der Verbinung natürlich auch IPv6 haben.
Es soll auch 2023 noch Mobilfunkprovider geben die keine IPv6 verteilen.

Hi zusammen,

ich habe WireGuard auf meinem Handy installiert, in der FRITZ!Box auch entsprechend alles eingerichtet und komme von unterwegs prima auf HA drauf und kann steuern.
Jetzt war ich in der Schweiz, war auf WLANs angewiesen und konnte dort keinen VPN aufbauen. Die Fehlermeldung habe ich natürlich nicht :see_no_evil:
Habe recherchiert und herausgefunden, dass es daran liegen könnte, dass in den WLANs gewisse Ports nicht offen sind.
Jetzt reise ich demnächst in den asiatischen Raum und stelle mir die Frage, ob sich dort auch so eine Mühe gemacht wird oder ob das mit dem Ports nur so ein europäisches Sicherheits-Gedöns ist :thinking:

Ich habe Rauchmelder, welche als Sirenen dienen, die ich deaktivieren möchte, bevor der Nachbar meine Pflanzen gießen kommt :hear_no_evil:

Kommt drauf an wo … China mach ich dir nicht viel Hoffnung

Nee, China ist es nicht. Da denk ich mir auch, dass das sicherlich viel/alles geblockt wird.
Philippines :philippines:

Man kann, wenn man das will, Wireguard auch auf einen Standard Port wie 80 oder 443 umbiegen. Hier kann man sich dann recht sicher sein, dass dieser nicht geblockt wird.

Eher DSLite wird jedoch das Problem, wenn die Verbindung des Endgeräts kein IPv6 kann.

Wireguard auf mehr als einem Gerät im Netzwerk laufen zu haben ist jedoch eher unsinnig bzw. unnötig.

Naja, das ist was für Leute wie mich die Gürtel UND Hosenträger bevorzugen.
Wenn HA mit dem Wireguard-Addon abgesemmelt ist, dann gehts immer noch über die Fritzbox. Ob man darüber dann noch was retten kann steht auf einem anderen Blatt.

@DirNja Wieso möchtest du deine Sirenen von so weit weg deaktivieren? Sind die soooo laut?
Sonst mach die doch schon aus wenn du das Haus verlässt.

Danke für den Tipp mit dem anderen Ports. Mal überlegen…

Ja, die Sirenen sind Rauchmelder und ich möchte den Gärtner nicht unnötig belästigen. Er informiert mich, wenn er Gießen geht, ich deaktiviere den Alarm und dann informiert er mich wieder wenn er fertig ist…

1 „Gefällt mir“

Zugriff hat zu 90% leider nicht geklappt/würde geblockt.
Was muss ich nun genau einstellen, damit ich definitiv Zugriff auf HA bekomme?

Wenn es geblockt wird, solltest Du Standard Ports wie 80 oder 443 für Deinen Wireguard Server nutzen. Es gingen aber auch common ports wie 993. Diese dürften eher nicht geblockt werden. Allerdings kannst Du dann keinen anderen, externen Dienst auf diesen Port legen.

Schau Dir auch mal die MTU size an. Ich hatte im ICE Wlan immer wieder das Problem, dass die VPN Verbindung ähnlich wie bei Dir fast nie zustande kam. (Bei mir läuft in nem LXC ein wireguard server). Nach dem Umstellen der MTU Size auf 1280 hatte ich vom ICE Wlan dann auf einmal konstant Verbindung. Es würde mich nicht wundern, wenn einige Hotel Wlans oder public Wlans ebenfalls Probleme verursachen wenn die MTU nicht “passt”

wie kann man diesen Port ändern? :thinking:
Die IP bzw. auch Port wird automatisch assigned bei der Einrichtung. Auch im Edit Fenster, kann man diese nicht ändern. Bei mir siehts so aus:

Ich setze meine FRITZ!Box ausschließlich als Modem im Bridge Mode ein. WireGuard läuft auf meinem Router. Daher kann ich bei FRITZ!Box Einstellungen nur begrenzt helfen.

Im Internet dazu gesucht?

Moin,
kenne mich mit der Fritzbox Implementierung auch nicht aus.
Das sind die Einstellungen des anderen Netzwerk wie es aus sieht.
Da kannst du von dir aus nichts ändern.
Las mich raten das Problem ist ihr habt bei beiden boxen den gleichen IP bereich? 192.168.178.X

Dann musst du dein oder das ander Netz umstellen.
Meine Empfehlung beide.

LG