Energiedashboard mit Batterie?

Hallo Community!
Bin seit einiger Zeit interessierter Leser und begeistert von euren Projekten. Das zuerst:-))
Nun, ich Versuche meinen Akku in das Energiedashboard zu integrieren und es gelingt mir so noch nicht.
Es braucht dazu zwei Sensoren für Eingang und Ausgang, die ich so erstellt habe:

template:
- sensor:
      - name: " Battery Power In "
        unit_of_measurement: "kWh"
        device_class: energy
        state_class: "total_increasing"
        state: >
          {{ (states('sensor.ac500_dc_input_power') | float(0) + states('sensor.ac500_dc_input_power1') | float(0) + states('sensor.ac500_ac_input_power') | float(0)
              | abs | round(2, default=0) }}

- sensor:
      - name: " Battery Power Out "
        unit_of_measurement: "kWh"
        device_class: energy
        state_class: "total_increasing"
        state: >
          {{ (states('sensor.ac500_dc_output_power') | float(0) + states('sensor.ac500_ac_output_power') | float(0)
              | abs | round(2, default=0) }}

Da dies ohne Fehler neu zu starten ging, wollte ich die zwei ‘neuen’ Sensoren dann integrieren. Leider finde ich sie nicht in der Auswahl im Energiedashboard. Hat jemand vielleicht einen Tipp für mich? Danke!
Dieter

Erstmal herzlich willkommen hier im HA-Forum! :slight_smile:

Was haben denn die Sensoren an sich für Werte? ac und dc sind ja schonmal ein Unterschied…

Du rechnest da Watt zusammen und das sollen dann kWh sein, das geht so nicht.

Die Werte werden in Watt angezeigt.

Das BMS (Batteriemanagement System) gibt mir die Sensoren aus und liefert die auch brav an HA.
Der Akku kann mit AC und DC Energie erhalten-auch gleichzeitig - und auch abgeben.
Deshalb habe ich die Eingangssensoren addiert. Ist ein Wert eventuell ‘0’ wird auch nix dazu gerechnet.
Es ist auch bei der Output Seite so. Aus diesem Grund habe ich die Sensoren auch hier zusammen gefasst und Homeassistant zeigt mir die Sensoren auch richtig an, und ich konnte diese bereits auf meinem Home-Dashboard darstellen.

Nur die Integration ins Energiedashboard gelingt mir noch nicht. Scheinbar benötigt HA zu einem Energiesensor noch eine weitere Information?

Juhuuu:)) …es läuft nun und mein Akku ist eingebunden
Folgende 3 Schritte waren dazu notwendig.

  1. ‘frittes’ gab mir die Idee dazu, dass es bei mir nicht kW/h im Template sein sollte, sondern ‘W’
    Geändert und dort die device_class: power, eingetragen.

  2. Ich habe 2 neue Helfer erstellt mit ganz neuen Namen. (in_akku,out_akku)-Riemann Summe. Die dort gewünschte Entität waren die oben erstellten.

  3. Diese konnte ich im Energiedashboard für mein Batteriesystem auswählen.

Neustart von HA und etwas warten… passt!

Dankeschön :blush:

Auch wenn schon erledigt:

Power Flow Card Plus:
flixlix/power-flow-card-plus: A power distribution card inspired by the official Energy Distribution card for Home Assistant (github.com)

Genau das wollte ich auch gerade hier vorstellen. Hier ein kleiner Screenshot

Hier werden momentanwerte und tageswerte angezeigt. Es ist eine hacs Erweiterung und ist wirklich einfach zu benutzen.

Viele Grüße

Servus, wie hast du das hinbekommen das der Tageswert auch angezeigt wird?

Du kannst bei “Secondary info” eine weitere Entitaet angeben. Ich habe hier einen “Helfer” erstellt, der die kWh hochzaehlt.

Hier ein Screenshot