Daten löschen in influxDB

Moin, das würde passen. Gab auch die V1

Hier kurz beschrieben.
Wir löschen → ha_tablet_battery_level
wir setzen den ersten Befehl ab.


Wir merken uns. Befindet sich zwischen file_editor … und home_assistant …

Wir setzen den Löschbefehl ab.
Die Meldung die kommt ist vollkommen richtig da InfluxDB keinen Rückgabewert vorsieht bei Löschungen.


Zum Schluss schaun wir nochmals nach mit dem ersten Befehl


Wir schaun nochmals nach.
Nicht mehr da.
Fertig.

Danke, ich teste mal und berichte.

Auf jeden Fall schon mal sehr gut beschrieben.

Und die Config nicht vergessen :grin:

Update:
Mit deinem Syntax hatte der erste Befehl bei mir nicht funktioniert. Ich musste zunächst die " " entfernen.

Der zweite Befehl hat danach aber überhaupt nicht funktioniert:

Ich versteh aber auch nicht, welchen Identifier Influx da möchte.

:crayon:by HarryP: Zusammenführung Doppelpost (bitte “bearbeiten” Funktion nutzen)

Hi,
da kann ich dir leider nicht weiterhelfen. Bei mir funkt das tadellos.

Sind das auch Anführungszeichen bei % und entity_id ? Sieht auf dem Screenshot komisch aus. Aber ggf. muss ich mal zum Augenarzt. :grinning:

Ich rede von doppelten Anführungszeichen (Taste 2).

Ja, das sind die Zeichen über der Taste 2.

ich habe exakt deinen Befehl kopiert und habe nur die “Variablen” entsprechend angepasst. Deswegen frage ich mich, was uns unterscheidet.

Ich benutze das Home Assistant Community Add-on: InfluxDB in der Version 5.0.0. Läuft als Hassio auf einem Intel NUC (was mal keine Rolle spielen sollte).
In der InfluxDB benutze ich InfluxQL und NICHT Flux !!

Habe den Fehler gefunden.
Wenn ich den 1:1 rauskopiere funkt es nicht da er warum auch immer keine “Gänsefüßchen” macht. Du musst alle " mit Gänsefüßchen (Taste 2) ersetzen und das ganz hinten steht in Hochkommata.

USE "home_assistant"; DELETE FROM "GB" WHERE "entity_id" = 'gb_sent_taglich'

Das sollte jetzt richtig sein. Habe oben Blockzitat genommen. Scheint nicht so clever gewesen zu sein. Ist wie gesagt ein Beispiel. Habe es gerade getestet mitcopy/paste funkt.