Cloudflare HTTPS

Hallo zusammen,
grob ist mir bekannt, was das Problem ist. Nur leider finde ich keine Lösung dafür.

Habe Home Assistant in einer Docker-Installation. Daneben natürlich die anderen “Add-Ons” eben auch als Docker, da unter Docker keine direkten Add-Ons möglich sind. (Docker-HA, Docker-MQTT, Docker-Piper, Docker-Whisper, Docker-Claudflare)

Bisher über ein selber erstelltes Zertifikat (nicht verifiziert!) auf HTTPS umgeschaltet, auch wenn bisher nur im LAN.

Jetzt habe ich eine eigene Domain (abc.de) und diese ist über Cloudflare getunnelt (ebenfalls Docker für Cloudflare).

Wenn ich jetzt von “draußen” über Claudflare auf mein HomeAssist zugreife, dann bekomme ich eine Fehlermeldung. Schalte ich auf HTTP (ohne S) um, dann klappt es.

Andere Geräte (z.B. Router) funktionieren problemlos über HTTPS über den Cloudflare-Docker.

Ich denke, dass das eigene Zertifikat das Problem darstellt, aber wie und wodurch kann ich das richtig ersetzen? Oder liege ich komplett falsch?

Funktionieren tut damit in etwa folgendes:
Internet(HTTP) —> HTTP-Zugriff auf Cloudflare → HTTPS Tunnel → HTTPS-Cloudflare-Docker bei mir → HTTP-Anfrage HomeAssist → Http-Home-Assist

Setze ich bei Home-Assistant das selber erstellte Zertifikat ein, dann kann ich zwar im LAN über HTTPS zugreifen, aber weder HTTP noch HTTPS über das Internet → Cloudflare → Cloudflare-Docker → HomeAssist funktioniert.

Was ist das Problem? Muss ich Cloudflare mein selber ausgestelltes Zertifikat bekannt machen (aber wie?) oder muss ich Cloudflare ein Zertifikat für mich erzeugen lassen (aber wie?) und es in den Docker-Umgebungen (welche und wie) bekannt machen?

Jetzt kann ich dank des Tunnels zwar “einfach” über HTTP aus dem internet auf HA zugreifen, aber das ist nicht wirklich gut. Zudem ist der Sprachassistent nur über HTTPS einsetzbar, also entweder weltweiten Zugriff oder lokale Sprache, nicht aber beides.

Bitte keine Hinweise der Art: dann installiere halt HA-OS. Ich habe HA-Docker und möchte auf der Grundlage eine Lösung finden.

Ich freue mich wie immer auf die Hilfsbereitschaft der Community und danke für jede konstruktive Hilfestellung! Nachfragen gerne!

Gruß
Grisu

Hast du bei cloudflare dann auch HTTPS umgestellt und die Verifizierung ausgeschalten?

Das ist wichtig, weil sonst HTTPS über cloudflare nicht geht.

Hallo,
ja, den entsprechenden Eintag innerhalb des Tunnels (Home-Assistant-Server) habe ich auf HTTPS umgestellt.
Aber egal, ob ich mit HTTP oder HTTPS vom Internet aus Zugreife, wenn ich in meinem LAN mit HTTPS arbeite, dann fängt cloudflare den Zugriff ab und bringt eine “ups, hier ist was schief gelaufen”-Seite.

Die erweiterte Option bei HTTPS (siehe Bild) hast du auch gesetzt?

Die ist bei einem eigenem Zertifikat natürlich wichtig. :wink:

Hallo,
SUPER, den hatte ich übersehen! Man(n) sollte eben nicht immer alles Huschi-Huschi machen, sondern mal genauer durchlesen.

Danke für den Zaunpfahl! Jetzt klappt alles wie gewünscht
Gruß
Grisu

1 „Gefällt mir“

:+1: sehr schön, dass es jetzt geht.

Hallo,
ich hänge gerade am geleichen Problem, dass ich nur via http und nicht via https auf HA komme. Ich finde leider die Einstellung aus dem Screenshot nicht. Kannst du mir da bitte kurz auf die Sprünge helfen ? :smile:

Hallo nichsen,

die Infos sind etwas “dünn”. :wink: Du hast bei der HA Instanz ein Zertifikat oder nicht? Cloudflare ist eingerichtet? Interner Port? Wie sind deine Einstellungen bei Cloudflare, wenn eingerichtet?

Hi,
ja sry hier ein paar mehr Infos :wink: . Ich bin Stück für Stück dem Video gefolgt. Ich habe kein Zertifikat angelegt. Sondern “nur” den Tunnel konfiguriert. Via http ging es heute morgen. Darauf hin habe ich versucht das auf https umzustellen.
Ein Zertifikat habe ich nicht in HA.
Cloudflare ist eingerichtet und verbunden (habe ins Log geschaut).
Du hattest da einen Screenshot mit “No TLS Verify” aus Cloudflare gepostet, diese Einstellung finde ich da leider nicht.

VG

Den gibt es bei http auch nicht. Der Hinweis bezog sich auf den vorhergehenden Fragesteller, der ein eigenes Zertifikat hat/hatte.

Cloudflare Tunnel läuft? Einstellungen in der YAML hast du auch. Was für eine Fehlermeldung kommt denn, wenn du https://deinhomeassistant.TLD.xxx eingibst? So ungefähr sollte es bei Cloudflare aussehen, mit dem Doppelpunkt :8123.

Ich habe nochmal alles zurückgesetzt und von Vorne gemacht (Cloudflare Addon und neue Subdomain), dann hat es funktioniert. Was genau das Problem beim ersten Versuch war weiß ich leider nicht.

1 „Gefällt mir“

Sehr schön :wink:. Da funktioniert doch alles wie es soll.