Bewegungsmelder Aqara Steuerung

Hallo,

Habe heute versucht einen Aqara Melder auf eine Automation zu packen…

Meine Vorstellung:

Melder soll nach Spnnenuntergang und unter 40 Lux angehen.
Wenn sich jemand dort im Raum aufhält soll das Licht nicht ausgehen und quasi neu von vorne eine beliebige Zeit ablaufen…und dann ausgehen.

Bekomme es nicht hin das der melder anbleibt .
Er geht immer kurz aus …dann geht er wieder auf erkannt .

Hat da jemand zufällig eine Lösung und mir eine vorlage zukommen lassen…

Habe als Auslöser aktuell einen Trigger der die Automation alle 3 sek prüft .

Lg
Thomas

Ich tippe mal du hast einen Bewegungsmelder (PIR) und kein Anwesenheitssensor mit mmwave?

Hier mal meine Automation für mein Kllerlicht.
alias: Keller-Licht
description: ""
trigger:
  - platform: state
    entity_id:
      - binary_sensor.everything_presence_one_keller_occupancy
    to: "on"
    id: an
  - platform: state
    entity_id:
      - binary_sensor.everything_presence_one_keller_occupancy
    to: "off"
    id: aus
    for:
      hours: 0
      minutes: 0
      seconds: 30
condition: []
action:
  - choose:
      - conditions:
          - condition: trigger
            id: an
        sequence:
          - service: switch.turn_on
            data: {}
            target:
              entity_id:
                - switch.keller_schalter_left
                - switch.keller_tisch_lampe
      - conditions:
          - condition: trigger
            id: aus
        sequence:
          - service: switch.turn_off
            data: {}
            target:
              entity_id:
                - switch.keller_schalter_left
                - switch.keller_tisch_lampe
mode: single

kannst bei der condition für an noch eine condition für die Helligkeit einbauen.
Wen du die Helligkeit vom Bewegungsmelder nimmst habe aber im Hinterkopf das die meistens nur bei Bewegung aktualisiert wird.

Das würde ich nicht machen.

LG

2 „Gefällt mir“

Schau mal hier. Ich würde es so ähnlich machen, wie es @maxe beschreibt

Eine zusätzliche Bedingung bei dir wären die 40 lux

1 „Gefällt mir“

@totow ja das ist ein PIR Melder.
Du hast da 30 sek eingestellt frage wäre läuft die zeit dann wieder neu an bei jeder bewegung bzw wenn er erkannt wird.

Aktuell geht es bei mir kurz aus dann wieder an.
Wäre pefekt wenn er die Zeit wieder neu startet das das licht nicht zwischendurch ausgeht .

Versuche es mal mit Mode “Restart” und wähle die “30 Sekunden” größer als den (internen) Cooldown deines Bewegungsmelders.

Es wird erst getriggert wenn der Sensor 30s auf dem state ist. Als wen Bewegung neu erkannt wird wird nicht ausgeschaltet.

Was soll das bringen?
nach dem der Timer im BWM um ist springt der Sensor in HA um und wen der state so 30s bleibt löst der Trigger aus. Da kenn auch 1s hin.

LG

Ich verwende den gleichen Sensor und das gleiche Szenario bei meinem Kleiderschrank.
Mit der Automation lasse ich das Licht einschalten.
Die Bedingungen sind beinahe gleich wie die hier angegebenen.

Als Aktion habe ich:

  1. das Licht einschalten
  2. eine bestimmte Zeit warten (in meinem Fall 25 Sekunden - also Cooldown im Bewegungsmelder sind 15 Sekunden eingestellt)
  3. Warten bis eine andere Aktion ausgeführt wird (in meinem Fall: Bis der Bewegungsmelder für 5 keine Bewegung mehr erkennt).
  4. Ausschalten des Lichtes

Schöne Grüße

Im schlimmsten Fall läuft der interne Cooldown ab und wird intern neu gestartet, aber der Auslöser in HA wird nicht neu gestartet, weil die Bedingung für ist inaktiv für XX Sekunden u.U. zuerst erreicht wird und die Automation in die falsche Richtung weiterläuft. (So hatte ich das Gefühl)

@silberfuxx das Problem hast du nicht wenn du beim Trigger mit der Zeit arbeitest, sondern sofort triggerst und danach mit einem delay arbeitest.

@totow hab die Automation von dir mal als vorlage benutzt…bis jetzt läuft es super werde es mal weiter beobachten und berichten…

Danke nochmal an Alle für die Hilfe!

Werde weiter berichten ob es tatsächlich passt :blush:

Das wäre wohl der (einzige) Vorteil, wobei die meisten, so wie ich das herausgelesen habe, keine großen Freunde sind von Delays, da das bei Neustarts o.ä. Probleme macht.
Ich hatte das auch zuerst und bin davon abgekommen und es lief “gefühlt” danach zuverlässiger bei mir.
Danke für deine Einschätzung

Die Zeit im Trigger direkt blockiert die Automation nicht wie ein extra eingestellter Delay.

Sorry, ich habe dich falsch verstanden. Ich bin auch kein Freund von Delay. Mein Fehler. :frowning: