Better Thermostat reagiert nicht korrekt

Hallo zusammen, bin relativ neu in HomeAssistant und habe versucht den Blueprint von Simon zu benutzen. Ich habe mich schon in einige Fehler im Forum eingelesen komme aber einfach nicht drauf was ich falsch eingestellt habe. Bei mir soll die Temperatur im Schlafzimmer auf 20,5 Grad gestellt werden. Nur leider wird das Zimmer nicht beheizt obwohl der Temperatursensor eine viel kältere Temperatur anzeigt. Könnt ihr mir sagen was mein Fehler ist?



in Lila die Zieltemperatur. Die überhaupt nicht eingehalten wird.

mode: restart
max_exceeded: silent
variables:
  climate_entity_var: climate.better_thermostat_sz
  presence_detector: input_boolean.jemand_zu_hause
  away_temprature: 18
  eco_temprature: 20
  automation_blocker: null
  automation_blocker_boolean: false
  window_contact: binary_sensor.fensterkontakt_schlafzimmer
  window_contact_boolean: true
  morning_eco_temprature: 18
  morning_comfort_temprature: 20.5
  morning_comfort_checker_boolean: input_boolean.presence_schlafzimmer
  day_eco_temprature: 18
  day_comfort_temprature: 20.5
  day_comfort_checker_boolean: input_boolean.presence_schlafzimmer
  evening_eco_temprature: 18
  evening_comfort_temprature: 20.5
  evening_comfort_checker_boolean: input_boolean.presence_schlafzimmer
  night_eco_temprature: 18
  night_comfort_temprature: 20.5
  night_comfort_checker_boolean: input_boolean.presence_schlafzimmer
trigger:
  - platform: state
    entity_id: input_boolean.jemand_zu_hause
    from: 'off'
    to: 'on'
  - platform: state
    entity_id: input_boolean.jemand_zu_hause
    from: 'on'
    to: 'off'
    for: 1200
  - platform: time_pattern
    minutes: /5
  - platform: time
    at: '00:01:00'
  - platform: time
    at: '09:00:00'
  - platform: time
    at: '14:30:00'
  - platform: time
    at: '22:30:00'
condition:
  - condition: or
    conditions:
      - '{{ automation_blocker == none }}'
      - >-
        {{ automation_blocker_boolean and states[automation_blocker].state ==
        'on' }}
      - >-
        {{ not automation_blocker_boolean and states[automation_blocker].state
        == 'off' }}
action:
  - choose:
      - conditions:
          - condition: or
            conditions:
              - >-
                {{ window_contact != none and (window_contact_boolean and
                states[window_contact].state == 'on') }}
              - >-
                {{ window_contact != none and (not window_contact_boolean and
                states[window_contact].state == 'off') }}
        sequence: []
      - conditions:
          - condition: state
            entity_id: input_boolean.jemand_zu_hause
            state: 'off'
        sequence:
          - service: climate.set_temperature
            data:
              temperature: 18
            target:
              entity_id: climate.better_thermostat_sz
      - conditions:
          - condition: time
            after: '00:01:00'
            before: '09:00:00'
        sequence:
          - choose:
              - conditions:
                  - condition: template
                    value_template: '{{ morning_comfort_checker_boolean != none }}'
                sequence:
                  - choose:
                      - conditions:
                          - condition: template
                            value_template: >-
                              {{ states[morning_comfort_checker_boolean].state
                              == 'on' }}
                        sequence:
                          - condition: not
                            conditions:
                              - condition: template
                                value_template: >-
                                  {{ (state_attr(climate_entity_var,
                                  'temperature') | float(0)) ==
                                  morning_comfort_temprature }}
                          - service: climate.set_temperature
                            data:
                              temperature: 20.5
                            target:
                              entity_id: climate.better_thermostat_sz
                    default:
                      - condition: not
                        conditions:
                          - condition: template
                            value_template: >-
                              {{ (state_attr(climate_entity_var, 'temperature')
                              | float(0)) == morning_eco_temprature }}
                      - service: climate.set_temperature
                        data:
                          temperature: 18
                        target:
                          entity_id: climate.better_thermostat_sz
            default:
              - condition: not
                conditions:
                  - condition: template
                    value_template: >-
                      {{ (state_attr(climate_entity_var, 'temperature') |
                      float(0)) == morning_eco_temprature }}
              - service: climate.set_temperature
                data:
                  temperature: 18
                target:
                  entity_id: climate.better_thermostat_sz
      - conditions:
          - condition: time
            after: '09:00:00'
            before: '14:30:00'
        sequence:
          - choose:
              - conditions:
                  - condition: template
                    value_template: '{{ day_comfort_checker_boolean != none }}'
                sequence:
                  - choose:
                      - conditions:
                          - condition: template
                            value_template: >-
                              {{ states[day_comfort_checker_boolean].state ==
                              'on' }}
                        sequence:
                          - condition: not
                            conditions:
                              - condition: template
                                value_template: >-
                                  {{ (state_attr(climate_entity_var,
                                  'temperature') | float(0)) ==
                                  day_comfort_temprature }}
                          - service: climate.set_temperature
                            data:
                              temperature: 20.5
                            target:
                              entity_id: climate.better_thermostat_sz
                    default:
                      - condition: not
                        conditions:
                          - condition: template
                            value_template: >-
                              {{ (state_attr(climate_entity_var, 'temperature')
                              | float(0)) == day_eco_temprature }}
                      - service: climate.set_temperature
                        data:
                          temperature: 18
                        target:
                          entity_id: climate.better_thermostat_sz
            default:
              - condition: not
                conditions:
                  - condition: template
                    value_template: >-
                      {{ (state_attr(climate_entity_var, 'temperature') |
                      float(0)) == day_eco_temprature }}
              - service: climate.set_temperature
                data:
                  temperature: 18
                target:
                  entity_id: climate.better_thermostat_sz
      - conditions:
          - condition: time
            after: '14:30:00'
            before: '22:30:00'
        sequence:
          - choose:
              - conditions:
                  - condition: template
                    value_template: '{{ evening_comfort_checker_boolean != none }}'
                sequence:
                  - choose:
                      - conditions:
                          - condition: template
                            value_template: >-
                              {{ states[evening_comfort_checker_boolean].state
                              == 'on' }}
                        sequence:
                          - condition: not
                            conditions:
                              - condition: template
                                value_template: >-
                                  {{ (state_attr(climate_entity_var,
                                  'temperature') | float(0)) ==
                                  evening_comfort_temprature }}
                          - service: climate.set_temperature
                            data:
                              temperature: 20.5
                            target:
                              entity_id: climate.better_thermostat_sz
                    default:
                      - condition: not
                        conditions:
                          - condition: template
                            value_template: >-
                              {{ (state_attr(climate_entity_var, 'temperature')
                              | float(0)) == evening_eco_temprature }}
                      - service: climate.set_temperature
                        data:
                          temperature: 18
                        target:
                          entity_id: climate.better_thermostat_sz
            default:
              - condition: not
                conditions:
                  - condition: template
                    value_template: >-
                      {{ (state_attr(climate_entity_var, 'temperature') |
                      float(0)) == evening_eco_temprature }}
              - service: climate.set_temperature
                data:
                  temperature: 18
                target:
                  entity_id: climate.better_thermostat_sz
      - conditions:
          - condition: time
            after: '22:30:00'
            before: '00:01:00'
        sequence:
          - choose:
              - conditions:
                  - condition: template
                    value_template: '{{ night_comfort_checker_boolean != none }}'
                sequence:
                  - choose:
                      - conditions:
                          - condition: template
                            value_template: >-
                              {{ states[night_comfort_checker_boolean].state ==
                              'on' }}
                        sequence:
                          - condition: not
                            conditions:
                              - condition: template
                                value_template: >-
                                  {{ (state_attr(climate_entity_var,
                                  'temperature') | float(0)) ==
                                  night_comfort_temprature }}
                          - service: climate.set_temperature
                            data:
                              temperature: 20.5
                            target:
                              entity_id: climate.better_thermostat_sz
                    default:
                      - condition: not
                        conditions:
                          - condition: template
                            value_template: >-
                              {{ (state_attr(climate_entity_var, 'temperature')
                              | float(0)) == night_eco_temprature }}
                      - service: climate.set_temperature
                        data:
                          temperature: 18
                        target:
                          entity_id: climate.better_thermostat_sz
            default:
              - condition: not
                conditions:
                  - condition: template
                    value_template: >-
                      {{ (state_attr(climate_entity_var, 'temperature') |
                      float(0)) == night_eco_temprature }}
              - service: climate.set_temperature
                data:
                  temperature: 18
                target:
                  entity_id: climate.better_thermostat_sz
    default:
      - condition: not
        conditions:
          - condition: template
            value_template: >-
              {{ (state_attr(climate_entity_var, 'temperature') | float(0)) ==
              eco_temprature }}
      - service: climate.set_temperature
        data:
          temperature: 20
        target:
          entity_id: climate.better_thermostat_sz
id: '1701277984172'
alias: Eco Heizung Schlafzimmer
description: ''

Ich habe selber die Lösung unter der Erklärungsseite von Simon gefunden. Hier schreibt Reinhard folgendes: Kann mir jemand erklären wie genau ich das Ganze ändern muss? Reicht überall folgendes einzutragen?

action:
- choose:
  - conditions:
    - condition: or
      conditions:
      - '{{ window_contact != none and (window_contact_boolean and states[window_contact].state
        == ''on'') }}'
      - '{{ window_contact != none and (not window_contact_boolean and states[window_contact].state
        == ''off'') }}'
    sequence: []
  - conditions:
    - condition: state
      entity_id: !input presence_detector
      state: 'off'
    sequence:
    - service: climate.set_temperature
    **- service: climate.turn_on**
      data:
        temperature: !input away_temprature
      target:
        entity_id: !input climate_entity

"Mir ist aufgefallen, dass der TRV im Badezimmer in der Früh nicht eingeschalten wird. Die Automation setzt zwar die target Temperatur korrekt, und ich hätte auch erwartet dass daher der Termostat angeht, aber er bleibt off (heizt nicht). (Im BetterThermostat UI tile bleibt die “Flamme” off, da Ventil des Thermostat bleibt zu)
Ich habe mich mit den Varianten der Better Thermostat settings für off gespielt, leider ohne Erfolg.
Was jedoch geholfen hat war einen expliziten climate.turn_on step zu deinem Blueprint nach jedem setzen/prüfen der target temperature hinzuzufügen.
"

1 „Gefällt mir“

Ich habe das selbe Problem.
Wenn man es so einfügt wie du oben makiert hast wird die Temperatur nicht mehr eingestellt.
Bei mir Funktioniert das ganze seit 1 Monat aber manchmal geht aus irgendeinem grund eine Heizung aus und diese bleibt dann auch aus und übernimmt nur die Temperatur änderung.( Ohne Heizbetrieb)

Das 2. Problem was ich mir vorstellen könnte ich das wenn man überall ein Turn on befehl setzt die Heizkörper auch im Sommer eingeschaltet wird

Hallo,
ich habe Better Thermostat schon seit einiger Zeit in Betrieb. Leider muss ich feststellen, das das nicht so richtig funktioniert. Ich habe eigentlich alles richtig eingestellt, aber wenn die Solltemperatur nicht erreicht ist, schaltet es nicht ab wenn man das Fenster öffnet und der Fensterkontakt geöffnet signalisiert. Wenn die Temperatur erreicht war, dann schaltet es das Thermostat richtig ab. Ist schon ein merkwürdiges verhalten. Da ich das ganze jetzt leid bin werd ich wohl versuchen das mit node-red und dem standard Thermostat zu erledigen. Wobei node-red eigentlich nur beim öffnen des Fensters das Thermostat ausschalten soll. Also wenn da schon mal jemand etwas zusammengestellt hat würde ich mir viel Arbeit sparen. :wink:
Vielleicht probier ich das mit der normalen Automatisierung, da hab ich schon meine Gartenbewässerung hinbekommen.

Also das funktioniert bei mir Einbandfrei.
Hab jerzt auch eine 2. Automatisierung am laufen damit der oben genannte Fehler nicht mehr auftaucht. Die Frage ist nur ob es funktioniert wenn BT aufgrund zu hoher aussentemp abschaltet.
Ich werde wenn ich dran denke berichten.
Welche Thermostate nutzt du?

Danke für die Info. Ich versteh es nur nicht wenn ich das Fenster zum lüften öffne, dann schaltet es richtig ab, wenn ich aber kurz nachdem es angefangen hat auf zu heizen, also die flammen sind rot, dann kann ich das Fanter öffnen und das Thermostat wird nicht abgeschaltet. Das heisst der Heizkörper wird weiter aufgeheizt. Leider hab ich noch nicht feststellen können woran das liegt. Die Thermostate die ich verwende sind diese:


funktionieren eigentlich super nur mit der Aus - Funktion steh ich auf Kriegsfuss. Vielleicht kannst Du einfach mal wenn es am aufheizen ist das Fenster öffnen und abwarten ob der Heizkörper kalt wird. Bei mir nur beim ersten lüften.

So eins habe ich auch.
Die andern sind bei mir Leider noch Fritz dect 301.
Die haben sowieso eine Verzögerung von bis zu 15 min… Muss dann immer die OK Taste drücken um ein Status Update zu starten.

Bei dem ich nenne es mal China Thermostat was bei mir über Zigbee2mqtt läuft musste ich bei BT auswählen “tausche auto und heat”
Vorher hat es nicht funktioniert.
Probier das mal und geb uns eine Rückmeldung.

So ist meins eingestellt

Das hatte ich auch schon eingestellt und die selben Probleme. Die Thermostate die ich hab sehen denen aus China sehr ähnlich sind aber von Rollei und wohl mit einer anderen Firmware. Bis jetzt hab ich immer nur festgestellt, das wenn das Fenster kurz vorher geöffnet war und das Thermostat wieder auf heizen ging und ich dann wieder das Fenster geöffnet habe, es nicht ausgeschaltet hat, obwohl es in den Integrationen auf aus war. Vielleicht versteh ich auch nur etwas falsch oder das Ventil ist noch nicht ganz geschlossen so das man meint es wird noch geheizt.

Im empfehle nach jeder konfiguration oder änderung in BT Homeassistant neu zu starten. Sonst ändert sich das manchmal nicht vernüftig

Dann fürchte ich, liegt das Problem nicht an Better Thermostat sondern den Ventilen.

Ich habe selbige, mit dem Sky Connect über Z2M angeschlossen. Teilweise Nutzung mit und teilweise ohne Better Thermostat.

Problem ist überall, dass diese nicht immer zuverlässig und nicht immer vollständig schließen. Habe die QOS schon auf 2 gestellt und weiterhin Probleme.

Bin noch nicht sicher, ob es die Kommunikation mit dem Sky Connect ist und ein anderer Stick die Probleme lösen wird.
Glücklich bin ich mit den Thermostaten in jedem Fall nicht.

Hi, ich glaub ich muss die austauschen. Bis jetzt haben die eigentlich gut funktioniert, aber seit gestern heizt das eine ohne erkennbaren Grund einfach auf 30 Grad hoch. Dann hab ich es versucht neu anzulernen, aber da kamen dann ständig Fehlermeldungen die wohl nirgens erfasst sind. Das zeigt F1 oder F3, dann nachdem ich es abgeschraubt hab und so hab laufen lassen ging es wieder, bis heute morgen. Das 2. fängt wohl auch an zu spinnen. Im Log stehen dann so merkwürdige Gradwerte wo ich glaube das da der Fehler liegt.

log21_01_02
Das sind Werte die vollkomen von der Realität abweichen, das war vor einiger Zeit noch nicht so.

Hab noch etwas gefunden was vielleicht helfen könnte. Es gibt ja die Quirks - Dateien die eine bessere Funktion bieten sollen. Nur weis ich nicht ob das so gut funktioniert. Ich habe mal das Verzeichnis erstellt und die Datei hochgeladen, sowie in der config.yaml den Pfad zu quirks eingetragen. Nur weis ich nicht wie man das sieht ob die Datei verwendet. Im Logfile ist nichts davon zu sehen. Ein Tip oder wie es richtig funktioniert wäre super.

Hallo Zusammen,
seit Kurzem startet Better Thermostat bei mir nicht mehr vernünftig wenn ich HA Neustart gemacht habe. Die beiden Sonoff-Thermostate haben noch nie Probleme gemacht und ich denke, dass hier auch nicht das Problem liegt.
Wenn ich händisch die Better Thermostat-Integration neu starte, nachdem HA Neustart, ist alles gut. Ich verwende das ECO Heating Ultimate Blueprint. Top-Teil!

Was kann ich tun bzw. wie kann erforschen wo das Problem liegt?

Danke.

In den Logs nach Fehlern schauen wäre ein guter Anfang.

Jetzt läuft es wieder. Wenn es wieder der Fall ist, werde ich sofort das Log-File unter die Lupe nehmen. Danke für den Hinweis.

home-assistant.log oder home-assistant.log1 ?

Moin,

das erste ist das aktuelle, das mit der Zahl dran, ist vom Vortag, oder nach einem Neustart, dann mit dem Inhalt vom, vor dem Neustart.

Aber da kann man einfach mal selbst hineinschauen, dann findet man das auch selbst heraus :slight_smile:

VG
Bernd

1 „Gefällt mir“

Guten Abend,
ich habe exakt das gleiche Problem, die Temperaturen werden zwar richtig eingestellt(man erkennte es daran, dass wenn man die Temperatur am Thermostat händisch auf diesen Wert dreht, das Symbol für comfort temperature im Display erscheint), aber eben nicht angesteuert. Es bleibt einfach auf der aktuellen Temperatur.
Ich würde gerne den Tipp mit “service: climate_turn_on” probieren, allerdings finde ich die YAML Datei nicht in der ich das eingeben kann.
Hat jemand einen Tipp wo ich das finde?
Danke euch!

Hallo zusammen,

ich habe seit einigen Tagen Zigbee Stellantriebe für meine Heizkörper in Betrieb. Dazu habe ich die better thermostat Integration installiert. Nur leider macht diese gar nicht das was sie soll.

Beispiel das Thermostat in meiner Ankleide, dort als Zieltemperatur 21.5° eingestellt. Diese wurde bei weitem übersteuert sodass schon rund 23° im Raum sind.
In der Ansicht der Ventilstellungen die ich mir mal erstellt habe steuert der gar nichts und bleibt immer bei 100% Ventilstellung.
image

Wenn man sich das Thermostat anschaut sollte es eigentlich passen:
image

Hat jemand eine Idee was ich da falsch mache?