Add-ON "Raspberry-Matic" funktioniert nicht

Hallo Zusammen,

ich habe auf einem Raspberry 4 alles installiert, wie es erklärt wurde. Leider werden bei mir keine Geräte bzw. Entitäten in HA angzeigt. Es erscheint die Fehlermeldung "No connection to interface RasperryMatic-VirtualDevices".

Es wurde die Firewall auf Ports offen gestellt. Der Name oder die IP vom Continer wurden ausprobiert.

Der CCU WebUI HTTP (Extern)- Port ist bei mir abweichend: 88, da 80 bei mir für den Proxy- Manager genutzt wird.

Der CCU WebUI HTTPS (Extern)- Port ist ebenfalls abweichend: 444, da 443 bei mir für den Proxy- Manager genutzt wird.

Habt ihr eine Idee ? Vielen Dank

Interface.png

Hi Phillip,
super beschrieben und gute Tag-Auswahl, danke dir 💙

Nur um Missverständnisse auszuschließen:

  1. Du hast RaspberryMatic auf deinem Home Assistant OS installiert (Keine Docker-Installation)?
  2. Du kannst über RaspberryMatic deine Homematic Geräte steuern?

Wenn dem so ist, bleibt mir noch eine Frage:

Du hast gesagt, die Ports 443 und 80 sind bei dir abweichend. Hast du damit:

  1. Die Ports von Home Assistant selber gemeint?
  2. Oder die von RaspberryMatic (Konfiguration -> Deaktivierte Ports im Add-on)?

@simon42 Ja ich nutze es auf dem OS:

1. Home Assistant 2022.11.5 Supervisor 2022.11.2 Operating System 9.3 Frontend 20221108.0 - latest
2. Korrekt
2. Die Ports auf dem jeweiligen AddOn. Die Ports 443, 80 werden vom AddOn "Nginx Proxy Manager" genutzt, daher habe ich 88 und 444 in der RaspberryMatic unter (deaktivierte) Ports eingegeben.
Vielen Dank

Aaaaaaaaaah, verstehe.
Versuch mal bitte Folgendes (nur so eine spontane Idee):
Firewall auf RaspberryMatic selber deaktivieren.
Zusätzlich noch Port 2000, 2001, 2010, 9292, und 8181 unter deaktivierte Ports eintragen, damit diese am Host veröffentlicht werden.

Home Assistant Host anschließend komplett einmal neu starten.

Alte Konfiguration vom Homematic Local unter Integrationen löschen und neu anlegen →

In der Konfiguration von Homematic Local muss dann als IP die IP deines Home Assistant Host, sowie dein Port für den Port 80 unter "JSON-RPC Port" eingetragen werden (und nicht "verwende TLS" anhaken)

Home Assistant Host anschließend komplett einmal neu starten.

Vielleicht verändern sich ja zumindest mal die Fehlermeldungen ;)

@simon42

Wenn ich die IP meines HA eingebe kommt sofort "Verbindung fehlgeschlagen".

Die Firewall kann ich nicht komplett deaktivieren.

Gebe ich den Containernamen ein, dann wird eine Verbindung, aber wie zuvor ohne Entinitäten aufgebaut.

(Erfolg).png

Firewall_Konfig.png

Sind denn die Ports auf der Add-on-Konfigurationsseite ebenfalls freigeschaltet?
Hier auch mal die Liste der Ports, die bei mir unter Port-Freigaben in RaspberryMatic eingetragen sind:

80;
8082;
2098;
2099;
8082;
9092;
5435;
2000;
2001;
2002;
2010;
8181;
8701

IP-Adressen für den eingeschränkten Zugriff ist leer.

Ein Screenshot von der Integrations-Konfigurationsseite wäre ebenfalls praktisch 👍

Moin Philip,

ich möchte mal betonen, dass die beiden ersten Mitglieder im Forum von Simon "Philip" und "Philipp" heißen xD

So genug Geplänkel, kannst du bitte mal die Konfigurationsseite deines RaspberryMatic CCU Addons zeigen? HA --> Einstellungen --> Addons --> RaspberryMatic CCU --> Konfiguration

Grüße

Alles umgestellt trotzdem keine Connection. Anbei die Screenshots.

Vielen Dank

Screenshot_20221201_190206_Home Assistant.jpg

Screenshot_20221201_190235_Home Assistant.jpg

Screenshot_20221201_190244_Home Assistant.jpg

Screenshot_20221201_190254_Home Assistant.jpg

Screenshot_20221201_190408_Home Assistant.jpg

Muss SSH nicht genutzt werden?

Hi,

der Screenshot von der Integrations-Konfiguration fehlt leider... Könntest du ja vieleicht noch posten als Ergänzung.

Kannst du anschließend testweise bitte mal versuchen, alles bei den Ports von der Add-on-Konfiguration rauszuschmeißen, den Host danach neu starten und die Verbindung anschließend über den Containernamen aufzubauen?

Falls ja, ist das Problem die vorhin von dir erwähnte nicht komplett abschaltbare Firewall oder die Integrations-Konfiguration. Wenn nicht, liegt das Problem in der Config von RaspberryMatic selber. So kommen wir zumindest mal etwas näher an die Ursache.

Außerdem dürfen keine Sonderzeichen wie # im Passwort vom RaspberryMatc-Konto sein, hatte ich vorhin vergessen zu erwähnen.

@simon42 Das mit dem Passwort kann ich nicht bestätigen. Das CCU Passwort der RaspberryMatic Integration von HA kann Sonderzeichen haben. Ist Zumindest bei mir der Fall und ich habe Rauten, Währungen und alles Mögliche im Passwort :wink:

Das mag sein, steht aber in der Doku... siehe: https://github.com/danielperna84/custom_homematic#authentication

Kommt vermutlich auch darauf an, ob TLS oder unverschlüsselt 😉
Würde ich generell keinem empfehlen 😅

@simon42 Guten Abend Ihr Beiden,

Passwort ist auf ein Zahlenwert geändert, die Ports sind alle entfernt, Host ist neu gestartet. Leider keine andere Meldung als sonst. Die Verbindung wäre "erfolgreich"

Wie schaut denn bei Euch die abschaltbare Firewall- Option aus ?

Konfiguration_Integration_03.png

Konfiguration_Integration_02.png

Konfiguration_Integration.png

Ich danke Euch für den unermütlichen Einsatz 😀 !

Versuch mal bitte, den JSON-RPC Port zu entfernen und den Admin-User zu nehmen.

Google Chrome - Einstellungen – Home Assistant_2022-12-02_17.56.31@2x.png


**Daumen Drück**

@simon42 Du meinst den JSON Port oder ?
Auch dann die gleiche Meldung, aber keine Verbesserung.

Eine der Fehlermeldungen: "

  • check_connection failed: No clients exist. Trying to create clients for server RaspberryPi
  • _create_clients failed: Interface: HmIP-RF is not available for backend."

Das ist ja echt merkwürdig. Kannst du mal das Log vom RaspberryMatic-Addon posten, nachdem es gestartet wurde?

Und kommen jetzt immer noch die Fehlermeldungen von wegen "Connection Refused"?

Dann muss ja eigentlich ein Interface nicht starten können (Auf dem RaspberryMatic). Da waren die letzten Fehler aber echt lange her... Welche Version von RaspberryMatic wird denn bei dir angezeigt?

@simon42

Die Fehlermeldung trat bei den Benachrichtigungen nicht mehr auf.

Current version: 3.65.11.20221005


Das sieht ja eigentlich so aus, als ob RaspberryMatic sauber läuft...

Füge bitte noch diese Einträge zu den IP-Adressen in der CCU-Firewall hinzu und versuche dich mal mit dem Benutzer Admin (großes A) zu verbinden:

172.30.33.0/24

172.30.32.0/23

Vielleicht solltest du alternativ auf das Homematic-Forum ausweichen, da ist der Entwickler von RaspberryMatic auch unterwegs...

Bei mir fängt, wenn das auch nicht klappt, stochern im Dunkeln an 😕

Hi @philip-knabe,

das hier könntest du auch mal probieren:

https://forum.simon42.com/home-assistant-allgemein/raspberrymatic-addin-zugriff-auf-raspberrymatic-extern/paged/2/#post-425

Es hat bis vorhin funktioniert. Nun bekomme ich, nach dem Update auf Operating System 9.4, die gleichen Fehlermeldungen wie früher😑.

Logger: hahomematic.central_unit
Source: runner.py:120
First occurred: 11:11:00 (3874 occurrences)
Last logged: 19:17:50

check_connection failed: No clients exist. Trying to create clients for server Raspberrymatic
_create_clients failed: Interface: HmIP-RF is not available for backend.
create_clients failed: Unable to create client for central [("Unable to connect (ConnectionRefusedError(111, 'Connection refused'),).",)]. Check logs.
create_clients failed: Unable to create client for central [('Unable to connect (<ProtocolError for de838cd8-raspberrymatic:2010/RPC2: 503 Service Unavailable>,).',)]. Check logs.

Logger: hahomematic.json_rpc_client
Source: runner.py:120
First occurred: 11:11:02 (11604 occurrences)
Last logged: 19:17:50

_do_post failed: ClientConnectorError
_do_login failed: Unable to open session: Cannot connect to host de838cd8-raspberrymatic:443 ssl:True [SSLCertVerificationError: (1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: self signed certificate (_ssl.c:997)')]
_post_script failed: Error while logging in via JSON-RPC.
_post failed: Error while logging in via JSON-RPC.